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About This Guide

The Novell Vibe OnPrem 3 Advanced User Guide explains how to use advanced features of the Vibe 
product.

Chapter 1, “Are You an Advanced Vibe User?,” on page 11
Chapter 2, “Creating and Managing Workspaces,” on page 15
Chapter 3, “Managing Folders,” on page 25
Chapter 4, “Controlling Access,” on page 39
Chapter 5, “Branding a Folder or Workspace,” on page 49
Chapter 6, “Creating and Managing Landing Pages,” on page 51
Chapter 7, “Creating Custom Workspace Views,” on page 73
Chapter 8, “Creating Custom Folder Views,” on page 83
Chapter 9, “Designing Custom Folder Entry Forms,” on page 93
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 103
Chapter 11, “Creating and Managing Workflows,” on page 107
Chapter 12, “Managing Remote Applications,” on page 139
Chapter 13, “Managing Your Data Quota,” on page 145
Chapter 14, “Restoring Deleted Items,” on page 149
Chapter 15, “Using Vibe on Your Mobile Phone,” on page 151
Chapter 16, “Using Novell Vibe with Novell GroupWise,” on page 161
Appendix A, “What’s New in Vibe 3,” on page 163

Audience

This guide is intended for all new Novell Vibe users who want more information about advanced 
Vibe functionality.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation 
included with this product. Please use the User Comments feature at the bottom of each page of the 
online documentation, or go to www.novell.com/documentation/feedback.html and enter your 
comments there.

Documentation Updates

For the most recent version of this manual, visit the Novell Vibe OnPrem 3 Documentation Web site 
(http://www.novell.com/documentation/vibe_onprem3). 
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Additional Documentation

You can find more information in the Novell Vibe documentation, which is accessible from the 
Novell Vibe OnPrem 3 Documentation Web site (http://www.novell.com/documentation/
vibe_onprem3). 

To access the Novell Vibe OnPrem 3 User Guide from within Vibe, click the Help icon (question 
mark).
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1
1Are You an Advanced Vibe User?

Novell Vibe OnPrem is an enterprise collaboration tool designed to increase individual productivity, 
team effectiveness, and organizational success by providing the right set of tools to the right people. 
Key Vibe features include Team workspaces, calendars, task lists, document management, 
discussion threads, wikis, blogs, RSS feeds, and workflows.

Vibe enables ordinary users to perform content-management functions. Because all Vibe users need 
to manage a personal workspace, and can also create team workspaces, all users have the potential to 
become “advanced Vibe users.”

Although all Vibe users have the ability to become advanced users, many users never have the need 
to progress beyond the basic Vibe functionality. This is because Vibe lends itself to two main 
groups: content consumers and content providers.

Section 1.1, “Content Consumers,” on page 11
Section 1.2, “Content Providers,” on page 11

1.1  Content Consumers
Content consumers use Novell Vibe to get important information that pertains to them. They 
participate in team workspaces in order to better collaborate with colleagues and facilitate their work 
assignments. They identify subject-matter experts and search for important information. 

Content consumers can learn how to accomplish these and other important tasks in the Novell Vibe 
OnPrem 3 User Guide.

1.2  Content Providers
Content providers use Novell Vibe to manage teams by creating team workspaces and making 
information easily accessible through landing pages and other advanced Vibe features.

Advanced Vibe users might perform any of the following functions:

Create or manage workspaces and folders: When you create your own workspace or folder, 
you are the owner of that workspace or folder. By default, you are also the owner of all sub-
workspaces and sub-folders.

For example, suppose that your manager assigns you to head an advertising campaign for a new 
product. Because accomplishing this assignment involves the combined efforts of various 
members of your team, you decide to create a new workspace dedicated to the new campaign.

For in-depth information, see Chapter 2, “Creating and Managing Workspaces,” on page 15 
and Chapter 3, “Managing Folders,” on page 25.
Control user access to workspaces and folders: As the owner of a workspace or folder, you 
are responsible for controlling which users have access rights, and deciding which rights are 
appropriate for which people.
For example, as the advertising campaign manager for a new product, you need to decide if 
Vibe users who are not members of your team are allowed to create entries in your team 
workspace, or whether non-team members should even be allowed to view the workspace.
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Also, when new users join the team, it is your responsibility to grant them appropriate rights.
For in-depth information, see Chapter 4, “Controlling Access,” on page 39.
Create unique brands for workspaces and folders: As the owner of a workspace or folder, 
you are responsible for creating a unique and attractive brand. Creating a unique brand is a 
good way to differentiate your workspace or folder from other places in the Vibe site.
For example, as the advertising campaign manager for a new product, you brand your team 
workspace with a graphic of the product logo, along with the new marketing slogan.
For in-depth information, see Chapter 5, “Branding a Folder or Workspace,” on page 49.
Create landing pages: As the owner of a workspace, you can present the most important 
information on the home page of the workspace. At the same time, you can change the look and 
feel of the home page. (You cannot create landing pages in personal workspaces.)
For example, as the advertising campaign manager for a new product, you create a landing 
page in the team workspace. In the landing page you display the current product shipment 
schedule, the latest news concerning the product, open tasks as they relate to your team 
members, and so forth.
For in-depth information, see Chapter 6, “Creating and Managing Landing Pages,” on page 51.
Create custom workspace and folder views: As the owner of a workspace or folder, you can 
create custom views that modify what is displayed on the home page of your workspace or 
folder. You can display uploaded files, remote applications, pictures, and more.
For example, as the advertising campaign manager for a new product, you can customize the 
home page of your team workspace to display pictures of the various marketing logo options 
for the product, as well as uploaded notes from team meetings.
For in-depth information, see Chapter 7, “Creating Custom Workspace Views,” on page 73 and 
Chapter 8, “Creating Custom Folder Views,” on page 83.
Create custom folder entry forms: As the owner of a workspace or folder, you can create 
custom folder entry forms that users can fill in when they are making entries in the workspace 
or folder. 
For example, as the advertising campaign manager for a new product, you decide to create a 
new folder called, “Slogans.” Inside this folder, you create a new entry form that enables team 
members to easily submit their ideas for catchy slogans for the new product. The entry form 
contains a field for the team member to type his or her name, a field where they can type the 
slogan, a field where they can upload pertinent pictures, and so on.
For in-depth information, see Chapter 9, “Designing Custom Folder Entry Forms,” on page 93.
Create and manage workflows: As the owner of a workspace or folder, you can create 
workflows that automate otherwise time-consuming manual processes.
For example, as the advertising campaign manager for a new product, you notice that expense 
reporting is taking more time than you want. The current process is for members of your team 
to request an expense reimbursement from you, the manager, then for you to send the request to 
HR, who then transfers the request to Finance. To automate this process, you implement a 
workflow that sends you an e-mail notification requesting your approval when the request is 
submitted. When you give your approval, the workflow is automatically transferred to HR. If 
HR approves the request, then the workflow is transferred to Finance, where the reimbursement 
is addressed.
For in-depth information, see Chapter 11, “Creating and Managing Workflows,” on page 107.
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Manage remote applications: As the owner of a workspace or folder, you can enable remote 
applications that have been set up by your Vibe administrator.
For in-depth information, see Chapter 12, “Managing Remote Applications,” on page 139.
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2
2Creating and Managing 
Workspaces

Novell Vibe OnPrem enables you to create and manage your workspaces in the following ways:

Section 2.1, “Creating and Managing a Team Workspace,” on page 15
Section 2.2, “Creating and Managing a Discussions Workspace,” on page 16
Section 2.3, “Creating and Managing a Basic Workspace,” on page 17
Section 2.4, “Creating and Managing a Project Management Workspace,” on page 17
Section 2.5, “Creating and Managing a Team Workspace Root Workspace,” on page 20
Section 2.6, “Using Global Workspaces,” on page 21
Section 2.7, “Creating Workspace Hierarchies,” on page 21
Section 2.8, “Creating Custom Workspace Views,” on page 22
Section 2.9, “General Workspace Management,” on page 23

2.1  Creating and Managing a Team Workspace
Team workspaces are the key to helping you and your team accomplish tasks and meet objectives, 
together.

As the owner of a workspace, you are primarily responsible for workspace administration. You can 
create other containers for information (sub-workspaces and folders), adjust access control to 
determine who can do what in the workspace, and provide some initial content to assist team 
members with getting started.

For information about how to perform basic management tasks on a team workspace, such as 
creating the workspace, adding team members, and sending e-mail to team members, see “Managing 
a Team Workspace” in the Novell Vibe OnPrem 3 User Guide.

Section 2.1.1, “Allowing Visitors to Your Team Workspace,” on page 15
Section 2.1.2, “Using Team Workspaces to Create Hierarchies,” on page 16

2.1.1  Allowing Visitors to Your Team Workspace
By default, only team members can view and participate in the workspaces and folders contained in 
the team workspace. There might be times when you want to allow other people to visit your team 
workspace (which, by default, means that they can read entries and comment on them, but they 
cannot create entries).

To allow visitors to your team workspace:

1 Navigate to the team workspace where you want to allow visitors.
2 Click Workspace > Access Control.

Novell Vibe displays the Configure Access Control page for the team workspace.
Creating and Managing Workspaces 15
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3 Ensure that the workspace is not inheriting its access control settings. Select the no radio 
button, then click Apply.

4 (Conditional) If Visitor is not already a column in the provided table, click Add a role > Visitor:
5 On the left side of the table, click Add a User, then use the type-to-find feature to select the 

name of the person who you want to add as a visitor to the team workspace.
6 In that new user’s row, select the check box in the Visitor column.
7 Repeat Step 5 and Step 6 until you have added all your visitors.
8 Click Save Changes > Close.

The people for whom you selected the Visitor role now have the right to view your team workspace 
and to add comments to existing entries. They cannot create new entries.

For more information on managing access control, see Section 4.2, “Managing Access Control for 
Users and Groups,” on page 41.

2.1.2  Using Team Workspaces to Create Hierarchies
Team workspaces in Vibe can be used to organize information inside of existing workspaces, 
creating different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating 
Workspace Hierarchies,” on page 21.

2.2  Creating and Managing a Discussions 
Workspace
The Discussions workspace can be the home page for a set of discussion forums. You can also use 
the Discussions workspace to house other types of folders. 

Discussions workspaces can be particularly useful for site administrators, or other Novell Vibe users 
who are responsible for creating the overall structure of the Vibe site. For example, you can use a 
Discussions workspace to organize a set of company-wide discussions on various topics. This can 
help organize your Vibe site, so users know where they should go if they are looking for a particular 
discussion forum.

Section 2.2.1, “Creating a Discussions Workspace,” on page 16
Section 2.2.2, “Using Discussions Workspaces to Create Hierarchies,” on page 17

2.2.1  Creating a Discussions Workspace
1 Navigate to the place in Vibe where you want to create the Discussions workspace. 

Depending on your rights, you might create this workspace at the Global level, if you are 
creating a company-wide Discussions workspace; or you might create this workspace in a 
lower-level workspace, if the Discussions workspace is intended for only a smaller number of 
Vibe users.

2 Click Workspace > New Workspace in the Action toolbar.
The New Workspace page is displayed.
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3 In the Workspace Title field, specify a name for the Discussions workspace.
4 In the Workspace section, select Discussions Workspace.
5 In the Workspace Folders section, select Discussion.

You can add additional Discussion folders after the workspace has been created.
6 Click OK.

2.2.2  Using Discussions Workspaces to Create Hierarchies
Discussions workspaces in Novell Vibe can be used to organize information inside of existing 
workspaces, creating different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating 
Workspace Hierarchies,” on page 21.

2.3  Creating and Managing a Basic Workspace
Basic workspaces in Novell Vibe can be used to organize information inside of existing workspaces, 
creating different levels of hierarchy within a workspace. 

You can also use other types of workspaces to create hierarchies. For information explaining the 
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating 
Workspace Hierarchies,” on page 21.

To create a basic workspace:

1 Navigate to the place in Vibe where you want to create the basic workspace. 
2 Click Workspace > New Workspace in the Action toolbar.

The New Workspace page is displayed.
3 In the Workspace Title field, specify a name for the basic workspace.
4 In the Workspace section, select Workspace.
5 In the Workspace Folders section, select the folders that you want the new workspace to 

contain.
You can add additional folders after the workspace has been created.

6 Click OK.

2.4  Creating and Managing a Project 
Management Workspace
Project Management workspaces include special accessories that help leaders track the progress of 
task completion for potentially large projects. Although Project Management workspaces can 
contain any type of folder, they are specifically designed to work in conjunction with Tasks and 
Milestones folders.

Section 2.4.1, “Creating a Project Management Workspace,” on page 18
Section 2.4.2, “Managing a Project Management Workspace,” on page 18
Section 2.4.3, “Understanding Tasks and Milestones,” on page 18
Creating and Managing Workspaces 17
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2.4.1  Creating a Project Management Workspace
1 Navigate to the place in Novell Vibe where you want to create the Project Management 

Workspace.
2 Click Workspace > New Workspace in the Action toolbar.

The New Workspace page is displayed.
3 In the Workspace Title field, specify a name for the Project Management workspace.
4 In the Workspace section, select Project Management Workspace.
5 Click OK.

2.4.2  Managing a Project Management Workspace
After you create the Project Management workspace, notice that the workspace contains key folders, 
such as a Tasks folder, Milestones folder, Files folder, and so forth.

The home page of the Project Management workspace provides the following features that enable 
you to better manage your project:

Task Summary Accessory: This accessory lists all of the tasks that exist in the Tasks folder of your 
Project Management workspace.

To modify the information in this accessory, navigate to the Tasks folder of this Project Management 
workspace. For information about Tasks folders, see “Working with Tasks Folders” in the Novell 
Vibe OnPrem 3 User Guide.

Project Information Box: Displays the Status, Manager, and Due Date of the project.

To modify this information:

1 Click Workspace > Edit Workspace in the Action toolbar.
2 In the Project Information Box section, modify the Manager, Status, and Due Date fields as 

needed.
3 Click OK.

Project Statistics: Displays the current task and milestone statistics that are associated with the 
project.

2.4.3  Understanding Tasks and Milestones
Because tasks and milestones contribute important information to your Project Management 
workspace, it is important that you understand how they work.

“Understanding Tasks” on page 18
“Understanding Milestones” on page 19

Understanding Tasks

Tasks folders keep track of the progress made in completing work assignments. For information 
about Tasks folders, see “Working with Tasks Folders” in the Novell Vibe OnPrem 3 User Guide.
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Understanding Milestones

The Milestones folder contains the various milestones for a project. Each milestone entry has 
specific Tasks folders that are associated with the milestone. When all of the tasks in the Tasks 
folders are complete, you can mark the milestone that is associated with those tasks as completed.

“Creating a Milestone” on page 19
“Using the Milestones Folder” on page 19
“Modifying a Milestone” on page 20

Creating a Milestone

1 Navigate to the Milestones folder in your Project Management workspace.
2 Click Add Milestone.

The Milestone page is displayed.
3 Specify the following information:

Title: Provide a title for the milestone.
Description: Describe the milestone.
Due Date: Specify when the milestone is due.
Responsible: Specify the users who are responsible for completing the milestone.
Responsible Groups: Specify the groups who are responsible for completing the milestone.
Responsible Teams: Specify the teams who are responsible for completing the milestone.
Send an E-Mail Notification to Responsibles: Send an e-mail notification to users, groups, 
and teams who are responsible for completing the milestone, notifying them about the new 
milestone.
Status: Use the drop-down list to specify a status for the milestone (Open, Reopen, 
Completed).
Task Folders: Use the tree to navigate to and select the Tasks folders that you want to associate 
with the milestone.
The tasks in these Tasks folders must be completed before the milestone can be marked as 
Completed.
Attachments: Attach any appropriate files.
Subscribe to This Entry: You can configure Vibe to send you notifications when activity 
takes place in this entry. For more information, see “Subscribing to a Folder or Entry” in the 
Novell Vibe OnPrem 3 User Guide.
Send E-Mail When Entry is Submitted: To ensure that certain co-workers are aware of your 
entry, you can send them an e-mail directly from Vibe, notifying them that an entry has been 
created. For more information, see “Filling Out the Send E-Mail Page” in the Novell Vibe 
OnPrem 3 User Guide.

Using the Milestones Folder

The Milestones folder contains the following columns that contain information about each 
milestone:

Name: Displays the name of the milestone.
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Responsible: Displays the people who are responsible for the milestone.

Tasks: Displays the Tasks folders that are associated with the milestone.

Mouse over the colors in the bar chart, and Vibe explains the value (needs action, in process, 
completed).

Status: Displays the status of the milestone.

Due date: Displays the due date of the milestone.

Modifying a Milestone

1 In the Milestones folder, click the milestone name in the Name column.
The milestone entry is displayed.

2 In the Entry toolbar, click Modify.
The Milestone page is displayed.

3 Make any modifications, then click OK.
You might need to refresh the page for your changes to be displayed.

2.5  Creating and Managing a Team Workspace 
Root Workspace
A Team Workspace Root workspace is designed to contain multiple team workspaces. Use this type 
of workspace if you want to create additional team workspaces as sub-workspaces to this 
workspace. When users with appropriate rights view this workspace, they can easily create a new 
team workspace by clicking the Add a Team Workspace button, as described in “Creating a Highly 
Visible Team Workspace” in the Novell Vibe OnPrem 3 User Guide. The Add a Team Workspace 
button is not displayed in regular team workspaces. 

You can control who has access to create workspaces in Team Workspace Root workspaces by 
modifying the access controls, as described in Chapter 4, “Controlling Access,” on page 39.

For more information on organizing team workspaces for a Novell Vibe site, see “Organizing Team 
Workspaces” in the  Novell Vibe OnPrem 3 Administration Guide.

To create a Team Workspace Root workspace:

1 Navigate to the location where you want to create the Team Workspace Root workspace.
2 Create a regular team workspace, as described in “Creating a Team Workspace inside of an 

Existing Team Workspace” in the Novell Vibe OnPrem 3 User Guide.
3 Navigate to the workspace that you just created in Step 2.
4 Click Workspace > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
5 In the Default View section, select Team Workspace Root.
6 Click Apply > Close.
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2.6  Using Global Workspaces
Global workspaces contain information beyond the scope of teamwork that might be of interest 
broadly across your organization.

Global workspaces can be created only by Novell Vibe administrators. For more information on 
Global workspaces, see “Creating Global Workspaces” in the  Novell Vibe OnPrem 3 Administration 
Guide.

2.7  Creating Workspace Hierarchies
Creating hierarchies in Novell Vibe is a powerful way to organize workspaces in a meaningful way. 
Hierarchies can make information easier to find and increase effectiveness across the Vibe site.

Vibe provides three types of workspaces that you can use to create hierarchies within existing 
workspaces. Each type of workspace has its advantages and disadvantages for creating workspace 
hierarchies, so depending on your objectives and your environment, you might want to use any of 
the types of workspace.

Section 2.7.1, “Discussions Workspaces,” on page 21
Section 2.7.2, “Basic Workspaces,” on page 22
Section 2.7.3, “Team Workspaces,” on page 22

2.7.1  Discussions Workspaces
If you don’t anticipate your workspace having hundreds or thousands of sub-folders, Discussions 
workspaces are recommended over basic workspace and team workspaces.

The following sections describe the advantages and disadvantages of using a Discussions workspace 
to create hierarchies within existing workspaces:

“Advantages” on page 21
“Disadvantages” on page 21

Advantages

Retains the access control rights of higher-level (parent) workspaces by default
Lists sub-folders and sub-workspaces on the workspace home page (and displays how many 
items are in each folder)

Disadvantages

Does not scale well (if you have hundreds or thousands of sub-folders, you should use a basic 
workspace to improve performance)
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2.7.2  Basic Workspaces
The following sections describe the advantages and disadvantages of using a basic workspace to 
create hierarchies within existing workspaces:

“Advantages” on page 22
“Disadvantages” on page 22

Advantages

Retains the access control rights of higher-level (parent) workspaces by default
Scales well (because basic workspaces do not list sub-folders and sub-workspaces on the 
workspace home page)

Disadvantages

Does not list sub-folders and sub-workspaces on the workspace home page

2.7.3  Team Workspaces
The following sections describe the advantages and disadvantages of using a Team workspace to 
create hierarchies within existing workspaces:

“Advantages” on page 22
“Disadvantages” on page 22

Advantages

Lists sub-folders and sub-workspaces on the workspace home page (and displays how many 
items are in each folder)

Disadvantages

Does not retain the access control rights of higher-level (parent) workspaces by default
Does not scale well (if you have hundreds or thousands of sub-folders, you should use a basic 
workspace to improve performance)

2.8  Creating Custom Workspace Views
Novell Vibe enables you to create custom workspace views. Workspace views define what is 
displayed on the main page of your workspace. When you create custom workspace views, you can 
configure workspaces to display optional features such as remote applications, attachments, and 
more.

For information on how to create custom workspace views, see Chapter 7, “Creating Custom 
Workspace Views,” on page 73.
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2.9  General Workspace Management
If you have appropriate rights, you can perform various types of management functions on a 
workspace, such as copying the workspace to another location, moving the workspace, adding 
folders to the workspace, deleting the workspace, and so forth.

For information on how to perform these and other types of management tasks, see “General 
Workspace Management” in the Novell Vibe OnPrem 3 User Guide.
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3
3Managing Folders

Novell Vibe OnPrem enables you to manage your folders in the following ways:

Section 3.1, “Managing Folder Views,” on page 25
Section 3.2, “Working with Folder Entry Types,” on page 26
Section 3.3, “Enabling Folders to Receive Entries through E-Mail,” on page 28
Section 3.4, “Configuring Folders to Send E-Mail Notifications to Other Users,” on page 30
Section 3.5, “Working with Mirrored Folders,” on page 30
Section 3.6, “Setting Up and Using WebDAV,” on page 33
Section 3.7, “Viewing Vibe Folders as RSS or Atom Feeds,” on page 36
Section 3.8, “Applying Landing Page Elements to a Folder,” on page 37

3.1  Managing Folder Views
Novell Vibe enables you to change the way you and other users view your folder. You can change 
the default view, or allow multiple views.

Section 3.1.1, “Changing the Default Folder View,” on page 25
Section 3.1.2, “Enabling Alternate Folder Views,” on page 26

3.1.1  Changing the Default Folder View
Vibe enables you to change the default view of folders for which you have appropriate rights. This 
can be an existing folder view or a custom folder view that you created. For information about how 
to create a custom folder view, see Chapter 8, “Creating Custom Folder Views,” on page 83.

“Enabling Views to Be Used as the Default View” on page 25
“Selecting a New Default Folder View” on page 26

Enabling Views to Be Used as the Default View

Before you can set a view as the default folder view, you need to enable that view.

1 Navigate to the folder where you want to change the default view.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is launched.
3 In the Allowed Views section, select the view whose look best presents your folder list or 

workspace.
4 Click Apply.

The folder view has now been added to the Default View section, and can be chosen as the 
default view, as described in “Selecting a New Default Folder View” on page 26.
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Selecting a New Default Folder View

1 In the Configure Default Settings page, in the Default View section, select the folder view that 
you enabled in “Enabling Views to Be Used as the Default View” on page 25.

2 Click Apply > Close.

3.1.2  Enabling Alternate Folder Views
Because only folder owners have rights to set the default view of a folder, Vibe enables folder 
owners to select alternate views that external users of the folder are allowed to use, if they are not 
satisfied with the default view, or feel more comfortable using another view. For example, you can 
configure your Calendar folder to allow users to view the folder in the Tasks folder view, if they so 
desire.

1 Navigate to the folder where you want to enable alternate views.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Allowed Views section, select all of the views that you want to enable as alternate folder 

views.
4 Click Apply > Close.

Users can now view the folder in an alternate view.

1 Click Folder > Folder Options in the Action toolbar.
The Folder Options dialog box is displayed.

2 In the View Options section, select the desired alternate view, then click OK.

3.2  Working with Folder Entry Types
Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 26
Section 3.2.2, “Recursively Applying Folder Entry Types,” on page 27

3.2.1  Enabling Alternate Folder Entry Types
You can select the types of entries that you want to allow users to create in a certain folder. You can 
configure your folder to allow additional entry types, or you can change the current entry type. If 
you add additional entry types, users who submit entries into this folder can choose which type of 
entry they want to add, such as a task entry, calendar entry, and so forth.

1 Navigate to the folder where you want to enable alternate entry types.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Default Entry Types section, select the entry types that you want to allow users to create 

in the folder.
4 Click Apply > Close.
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If you enable additional entry types, users who submit entries into this folder can click Add in the 
Folder Entry toolbar, then use the drop-down list to choose the type of entry they want to add, 
depending on which types of entries you enabled on the folder.

Site administrators and folder owners can use the Form and View Designers functionality to create 
new entry types (custom forms), which then appear in this list. (When folder owners create new 
entry types, those entry types are listed in the Local Definitions section of this list.)

For more information on how to create custom entry types, see Chapter 9, “Designing Custom 
Folder Entry Forms,” on page 93.

3.2.2  Recursively Applying Folder Entry Types
You can apply entry definition types to folders or entries that have already been created.

This feature must first be enabled by your Novell Vibe administrator. If it is not enabled, it is not 
visible. 

“Applying Definition Settings to All Sub-Folders” on page 27
“Applying Definition Settings to Existing Entries” on page 27

Applying Definition Settings to All Sub-Folders

You can apply all definition settings of a parent folder to all sub-folders.

1 Navigate to the folder where you want to apply entry definition types to folders or entries that 
have already been created.

2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 In the Recursively apply section, select Change contained folders to inherit this folder’s 
definitions.

4 Click Apply > Close.

All definition settings on the Configure Default Settings page are applied to all sub-folders.

Applying Definition Settings to Existing Entries

If you have previously added entries to this folder and the entry definition type does not match that 
of the other folder entries (for example, you might have a Blog folder that contains primarily Blog 
definition types, but some of your entries are currently displayed as Discussion definition types), 
you can use this section to change the definition settings to make all folder entries the same.

1 Navigate to the folder where you want to apply entry definition types to folders or entries that 
have already been created.

2 Click Folder > Configure in the action toolbar.
The Configure Default Settings page is displayed.

3 In the Recursively apply section, select Change contained folders to inherit this folder’s 
definitions, then select Change contained entries to be of the following entry type.

4 In the drop-down list, select the entry type that you want to apply to all existing entries in the 
folder.
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To add entry types to this drop-down list, select the entry types in the Default Entry Types 
section, then click Apply.

5 Click Apply.

3.3  Enabling Folders to Receive Entries through 
E-Mail
Novell Vibe enables you to e-mail entries into folders. This is useful if for some reason you don’t 
have access to the Vibe site and still want to create an entry. You can also send text messages into 
folders, so when you don’t have access to a computer or the Internet, you can still capture thoughts 
and contribute to conversations.

To enable folders to receive entries via e-mail, complete the following sections:

Section 3.3.1, “Enabling and Configuring the Inbound E-Mail Server,” on page 28
Section 3.3.2, “Enabling Incoming E-Mail for the Vibe Site,” on page 28
Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 28
Section 3.3.4, “Defining Who Has Access to E-Mail Entries,” on page 29

3.3.1  Enabling and Configuring the Inbound E-Mail Server
The Vibe administrator should have enabled and configured the inbound e-mail server during the 
Vibe installation, as described in “Enabling Inbound E-Mail” in the Kablink Vibe OnPrem 3 
Installation Guide. 

For information about enabling and configuring inbound e-mail after the Vibe installation, see 
“Reconfiguring the Vibe Site” in the Kablink Vibe OnPrem 3 Installation Guide.

3.3.2  Enabling Incoming E-Mail for the Vibe Site
For folders to be able to receive entries via e-mail, Vibe administrators need to enable the Vibe site 
to allow incoming e-mail.

For information on how to enable Vibe to allow incoming e-mail, see “Disabling/Enabling Inbound 
E-Mail Postings” in the  Novell Vibe OnPrem 3 Administration Guide.

3.3.3  Enabling E-Mail Posting with a Simple URL
When you define a simple URL for a folder, Vibe creates a URL that enables you to quickly 
navigate to the folder, and also creates a corresponding e-mail address that users of the folder can e-
mail to.

1 Navigate to the folder where you want to define the URL.
2 Click Folder > Configure in the Action toolbar.
3 In the Define a simple URL for this folder or workspace section, specify the URL that you want 

to use to reference the folder in the Define URL field. 
4 Click Add.
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5 Select Allow e-mail posts to this folder via the following addresses.
6 Click Apply, then click Close.

You can now make entries to the folder by e-mail or by text-messaging your entry to the e-mail 
address that you created.

3.3.4  Defining Who Has Access to E-Mail Entries
By default, only users with rights to create entries in a particular folder can e-mail entries into that 
folder.

Vibe enables you to view who has rights to create entries in a folder, grant rights to other Vibe users, 
or configure the folder to allow all users to create entries by e-mailing into it.

“Viewing Who Has Rights” on page 29
“Granting Rights to Other Vibe Users” on page 29
“Setting Up a Folder That All Users Can Send E-Mail To” on page 29

Viewing Who Has Rights

1 Navigate to the folder where you want to view who currently has rights to create entries in the 
folder.

2 Click View > Who Has Access in the Action toolbar.
3 In the provided table, the Create Entries section lists all of the users who have rights to create 

entries in the folder.
These are the users who have rights to e-mail entries into the folder.

Granting Rights to Other Vibe Users

You can grant other Vibe users rights to create entries in a folder.

For information on how to do this, see Section 4.2, “Managing Access Control for Users and 
Groups,” on page 41.

Setting Up a Folder That All Users Can Send E-Mail To

You can enable your Vibe folder to receive e-mail entries from all users, regardless of whether they 
have access to create entries in the folder or not.

This enables e-mail entries to be submitted by anybody, inside or outside of the Vibe system. If you 
are worried about receiving spam messages in your folder, do not set up your folder to accept e-mail 
entries in the way described in this section.

1 Navigate to the folder where you want to enable all users to create entries via e-mail.
2 Click Folder > Access Control in the Action toolbar.
3 Ensure that No is selected in the Inherit Role Membership section. If it is not, select No, then 

click Apply.
4 In the table, click Add a User.
5 In the provided field, use the Type-to-Find feature and specify E-mailing posting agent.
6 In the E-mailing posting agent row, select the check box in the Participant column.
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7 Click Save Changes > Close.
Now all users can create entries in this folder via e-mail, using the e-mail address that you 
created in Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 28.

3.4  Configuring Folders to Send E-Mail 
Notifications to Other Users
As a folder owner, you can configure Novell Vibe to send other users e-mail notifications, to inform 
them of any activity in the folder and any sub-folders of the folder. However, a user’s individual 
settings override or cancel notifications established by folder owners.

You cannot directly configure a sub-folder to send e-mail notifications; instead, you must configure 
the parent folder.

1 Navigate to the folder from where you want to send the e-mail notifications.
2 Click Folder > E-Mail Settings in the Action toolbar.

The E-Mail Settings page is displayed.
3 In the Select the Type of E-Mail Notification section, select the type of e-mail notification that 

you want to send.
Digest: Vibe sends one message that summarizes all of the activity in the folder and its 
sub-folders (available for folders only). Vibe sends digest notifications at a schedule 
established by your site administrator.
Individual Messages (with Attachments): Vibe sends one message for every new or 
changed entry, and messages include attached files. Vibe sends all types of individual 
notifications every five minutes.
Individual Messages without Attachments: Vibe sends one message for every new or 
changed entry. The e-mail messages do not include files that might be attached to the new 
or changed entries. Vibe sends all types of individual notifications every five minutes.
Message Suitable for Text Messaging: Vibe sends a message suitable for viewing as a 
text message. The content of the message includes only the entry title and a link to the new 
or changed entry. Vibe sends all types of individual notifications every five minutes.

4 Specify the users who you want to receive the e-mail notifications.
You can specify specific e-mail addresses, users, groups, or send the notifications to all team 
members.

5 Click Apply > Close.

3.5  Working with Mirrored Folders
A mirrored folder is a library folder within Novell Vibe that is synchronized with a folder located on 
a system drive outside of Vibe. When you perform basic actions (adding subfolders and files, 
modifying files, deleting folders and files) by using the Vibe interface or by accessing the file on the 
drive, the change is reflected in the other interface. The advantage to using mirrored files is that you 
can apply Vibe tools to files on a drive, including tools such as text search, workflow, and discussion 
(in the form of comments applied to the entry in the library folder).
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For information about setting up mirrored folders for your Vibe site, see “Configuring Mirrored 
Folder Resource Drivers” in “Advanced Installation and Reconfiguration” in the Kablink Vibe 
OnPrem 3 Installation Guide.

Vibe supports two types of external folders:

A directory on a file system
A folder on a WebDAV server

When you mirror a folder, the action cannot be undone.

Section 3.5.1, “Prerequisites,” on page 31
Section 3.5.2, “Creating a Mirrored Folder,” on page 31
Section 3.5.3, “Deleting a Mirrored Folder,” on page 31
Section 3.5.4, “Configuring a Mirrored Folder,” on page 32
Section 3.5.5, “Synchronizing a Mirrored Folder,” on page 32
Section 3.5.6, “Mirrored Folder Tips,” on page 33

3.5.1  Prerequisites
The following prerequisites apply for setting up mirrored folders.

An administrator must have enabled mirrored folder functionality during the Vibe installation 
process, as described in “Configuring Mirrored Folder Resource Drivers” in “Advanced 
Installation and Reconfiguration” in the Kablink Vibe OnPrem 3 Installation Guide.
An administrator must have specified which folders on the server can be mirrored.
The file that you mirror must either be located on the Vibe server, or accessible from the Vibe 
server. (For example, the file can be mapped from the Vibe server.)

For information on how to modify mirrored folder settings after the Vibe installation, see 
“Reconfiguring the Vibe Site” in the Kablink Vibe OnPrem 3 Installation Guide.

3.5.2  Creating a Mirrored Folder
Ensure that you meet the prerequisites discussed in Section 3.5.1, “Prerequisites,” on page 31.

1 Navigate to the workspace where you want to set up the Mirrored Files folder.
2 Click Workspace > New Folder in the Action toolbar.
3 Provide a title for the folder in the Folder Title field.
4 Select Mirrored Files in the Folder section, then click OK.

After you create a Mirrored Files folder, you need to configure it. For information on how to do this, 
see Section 3.5.4, “Configuring a Mirrored Folder,” on page 32.

3.5.3  Deleting a Mirrored Folder
1 Navigate to the Mirrored Files folder that you want to delete.
2 Click Folder > Delete Folder in the Action toolbar.
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The Delete This Folder page is displayed.
3 Select Also delete source contents if this folder or any of the sub-folders are mirrored folders.

If you do not select this option, the folder and its contents are removed from Vibe only, and are 
restored in the next synchronization.

4 Click OK.

NOTE: Undeleting files that have been deleted through a mirrored folder is not supported in Vibe. 
Files that are deleted through a mirrored folder cannot be recovered.

For more information on undeleting items in Vibe, see Chapter 14, “Restoring Deleted Items,” on 
page 149.

3.5.4  Configuring a Mirrored Folder
After you create a Mirrored Files folder, you need to configure it.

1 Select the Mirrored Files folder that you created in Section 3.5.2, “Creating a Mirrored Folder,” 
on page 31.

2 Click Folder > Edit Folder in the Action toolbar.
3 Specify the following information:

Resource Driver: Use this drop-down list to select the file on the external file system that you 
want the Mirrored Files folder to mirror.
You can select only files that your Vibe administrator has configured to be used as mirrored 
files.
Resource Root Path: This is the file path to the folder that you selected in the Resource Driver 
field.
Resource Path Relative to the Root Path: If you want to display entries in a lower-level 
folder than the folder defined in the Resource Root Path field, use this field to specify the 
remaining file path.

4 Click OK.

3.5.5  Synchronizing a Mirrored Folder
After you have configured your mirrored folder to mirror the appropriate files, as described in 
Section 3.5.4, “Configuring a Mirrored Folder,” on page 32, you need to synchronize the Vibe 
Mirrored Files folder with the external folder that it is mirroring. 

Vibe enables you to manually synchronize your mirrored folder, or set up an automated 
synchronization schedule for it.

“Manually Synchronizing a Mirrored Folder” on page 32
“Setting Up a Synchronization Schedule for a Mirrored Folder” on page 33

Manually Synchronizing a Mirrored Folder

1 Navigate to the Mirrored Files folder that you want to synchronize.
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2 Click Folder > Manually Synchronize in the Action toolbar.
The Vibe Mirrored Files folder is synchronized with the external folder that it is mirroring.

Setting Up a Synchronization Schedule for a Mirrored Folder

1 Navigate to the Mirrored Files folder that you want to synchronize.
2 Click Folder > Schedule Synchronization in the Action toolbar.

The Schedule Mirrored Folder Synchronization page is displayed.
3 Specify the following information:

Enable Scheduled Synchronization: Select this check box to enable scheduled 
synchronization. If you do not select this check box, the scheduled synchronization is not 
activated.
Every Day: Select this option if you want your mirrored folder to be synchronized every day.
Weekly: Select the days when you want your mirrored folder to be synchronized. (You can 
select multiple days.)
At Time: Specify the time that you want your mirrored folder to be synchronized.
If you select this option, your mirrored folder is synchronized only once per day.
Repeat Every: Select the hourly interval when you want your mirrored folder to be 
synchronized.

4 Click Apply > Close.

3.5.6  Mirrored Folder Tips
Consider these tips when working with mirrored files:

When you specify the path to the system folder, specify the full (absolute) path to the folder.
After creating the mirrored folder, you cannot alter the pathname, and you cannot reconfigure 
the Vibe library folder to be a non-mirrored folder.
To initialize the new mirrored folder, click Folder > Edit Folder, and use the Synchronize tool.
Do not attach additional files to entries in a mirrored folder. Behavior regarding additional 
attachments is unpredictable.
When you delete a file on the server, Vibe deletes the entire entry in the library folder (not just 
the attached file).
When you add sub-folders to a mirrored folder in Vibe, sub-folders are added to the folder in 
the other system.

3.6  Setting Up and Using WebDAV
WebDAV is a standard collaborative editing and file management protocol. Novell Vibe supports the 
use of WebDAV tools, and enables you to manage your Vibe files through WebDAV. Vibe utilizes 
WebDAV when editing attached files, and you can also set up WebDAV to view documents in a Vibe 
folder.
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If you are using WebDAV on Windows 7, you or your Vibe administrator must ensure that your 
workstation meets all the necessary prerequisites in order to support WebDAV, as described in 
“Configuring Vibe to Support WebDAV on Windows 7” in the  Novell Vibe OnPrem 3 
Administration Guide.

If you cannot use WebDAV as described in the following sections, consult your Vibe administrator.

Section 3.6.1, “Using WebDAV to Edit Individual Files,” on page 34
Section 3.6.2, “Using WebDAV on a Vibe Folder,” on page 34

3.6.1  Using WebDAV to Edit Individual Files
You can use either of the following methods to edit files through WebDAV:

“Editing a File Directly from the Vibe Interface” on page 34
“Using the WebDAV URL to Open the File in a Document Editor” on page 34

Editing a File Directly from the Vibe Interface

When you use the Edit-in-Place functionality to edit a Vibe file, as described in “Editing Files” in 
the Novell Vibe OnPrem 3 User Guide, Vibe uses WebDAV to retrieve, lock, modify, and unlock the 
file. No special setup or configuration is needed in Vibe to use WebDAV in this way.

NOTE: Edit-in-Place functionality is not supported on Mac when you use Microsoft Office as your 
document editor. To use Edit-in-Place functionality on Mac, you must use OpenOffice as your 
document editor.

Using the WebDAV URL to Open the File in a Document Editor

You can obtain the WebDAV URL for individual files within Vibe, as described in “Obtaining the 
WebDAV URL for a File” in the Novell Vibe OnPrem 3 User Guide.

After you have obtained the WebDAV URL for the file, you can specify the URL in a document 
editor such as Microsoft Office to open the file. Refer to the documentation for your specific 
document editor for instructions on how to accomplish this.

3.6.2  Using WebDAV on a Vibe Folder
When you use WebDAV on a Vibe folder, you can create a mapped drive to a Vibe folder, enabling 
users to browse and navigate the Vibe folder in a WebDAV interface. To manage your Vibe folders 
through a WebDAV interface, you must first configure the Vibe folder to support WebDAV, then 
create a mapped drive to the Vibe folder.

NOTE: Because of limitations with WebDAV on Mac, you cannot use WebDAV to view a Vibe 
folder in a Mac environment.

“Prerequisite for Windows XP and Windows Vista” on page 35
“Configuring a Folder to Support WebDAV” on page 35
“Viewing the Vibe Folder in Your Windows Environment” on page 35
“Viewing the Vibe Folder in Your Linux Environment” on page 36
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Prerequisite for Windows XP and Windows Vista

When you use WebDAV on a Vibe folder on Windows XP or Windows Vista, you must first install 
the Software Update for Web Folders (KB907306). For information on how to perform this 
installation, see Software Update for Web Folders (http://www.microsoft.com/downloads/
details.aspx?familyid=17c36612-632e-4c04-9382-987622ed1d64&displaylang=en), and follow the 
provided instructions.

Configuring a Folder to Support WebDAV

In most types of Vibe folders, Vibe allows you to add multiple files with the same name to a single 
folder, if each file is added as a separate entry. (Files folders, however, require each file to have a 
unique name.)

When a folder is configured to support WebDAV, Vibe requires that each file added to the folder 
must have a unique name. This is because when you view a folder through WebDAV, you see only 
the files that are within the folder and not the entries that contain each file.

To configure a folder to support WebDAV by requiring that all files uploaded to the folder have a 
unique name:

1 Navigate to the folder that you want to configure to support WebDAV.
2 Click Folder > Edit Folder in the Action toolbar.
3 Toward the bottom of the page, select Require that all files uploaded into this folder have a 

unique name.
4 Click OK.

For information about what users experience when they try to add a file to a WebDAV-enabled 
folder when the file has the same name as a file that has already been added to the folder, see 
“Adding Files to a Files Folder and Other WebDAV-Enabled Folders” in the Novell Vibe OnPrem 3 
User Guide.

Viewing the Vibe Folder in Your Windows Environment

There are two ways to view the Vibe folder in your Windows environment. 

After your Vibe folder has been configured to support WebDAV, as described in “Configuring a 
Folder to Support WebDAV” on page 35, you can view the Vibe folder in your Windows 
environment in either of the following ways:

“Creating a Mapped Drive to the Vibe Folder” on page 35
“Adding a Vibe Folder as a Network Place” on page 36

Creating a Mapped Drive to the Vibe Folder

If you are using Windows XP as your client operating system, creating a mapped drive to the Vibe 
folder as described in this section does not work. Instead, add the Vibe folder as a network place, as 
described in “Adding a Vibe Folder as a Network Place” on page 36.

1 Navigate to the folder where you want to create the mapped drive.
2 Click the link in the footer.
3 In the provided table, copy the WebDAV URL.
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4 Map a drive to the folder.
You accomplish this by using the Map Network Drive feature for Windows.

5 Specify your Vibe credentials, then complete the setup process.

Adding a Vibe Folder as a Network Place

If you are using Windows Vista as your client operating system, adding a Vibe folder as a network 
place as described in this section does not work. Instead, create a mapped drive to the Vibe folder, as 
described in “Creating a Mapped Drive to the Vibe Folder” on page 35.

1 Navigate to the folder where you want to create the mapped drive.
2 Click the link in the footer.
3 In the provided table, copy the WebDAV URL.
4 Add the folder as a network place.

You accomplish this by using the My Network Places feature for Windows.

Viewing the Vibe Folder in Your Linux Environment

After your Vibe folder has been configured to support WebDAV, as described in “Configuring a 
Folder to Support WebDAV” on page 35, you can view the Vibe folder in your Linux environment.

1 Navigate to the folder where you want to create the mapped drive.
2 Click the link in the footer.
3 In the provided table, copy the WebDAV URL.
4 Use either Nautilus or Konqueror to access the Vibe folder.

For specific information on how to use Nautilus or Konqueror, consult your Linux 
documentation.

5 Specify your Vibe credentials, then complete the setup process.

3.7  Viewing Vibe Folders as RSS or Atom Feeds
RSS and Atom are Web formats used to publish frequently updated content such as blog entries, 
news headlines, or podcasts. RSS and Atom documents, which are often called feeds, contain either 
a summary or full content from an associated Web site. RSS and Atom make it possible for people to 
keep up with their favorite Web sites in an automated manner that's easier than checking the sites 
manually. RSS and Atom enable you to set up feeds to Novell Vibe folders and view those feeds in 
one convenient location.

You can set up a Vibe folder to be accessed by an RSS or Atom reader. When you do this, the Vibe 
folder sends new or modified folder entries to your RSS or Atom reader. This is an easy way that 
you can stay informed on activity in a certain folder.

To set up a Vibe folder as an RSS or Atom feed:

1 Navigate to the folder that you want to set up as an RSS or Atom feed.
2 Click the Footer toolbar, located at the bottom of the folder page.
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3 If you are setting up an RSS feed, in the RSS URL section in the provided table, select and copy 
the RSS URL.
or
If you are setting up an Atom feed, in the ATOM URL section in the provided table, select and 
copy the Atom URL.

4 In your RSS reader or Atom reader, create a new RSS or Atom feed, and paste the RSS URL or 
the Atom URL that you copied in Step 3.
The folder is now set up as an RSS or Atom feed, and entries that are created in the folder 
appear in your RSS or Atom reader.

For information on using your Novell GroupWise client as an RSS reader, see “RSS Feeds” in the 
GroupWise 8 Windows Client User GuideGroupWise 8 Windows Client Help. Or, see “RSS Feeds” 
in the GroupWise 8 Linux/Mac Client User GuideGroupWise 8 Linux Client HelpGroupWise 8 Mac 
Client Help.

3.8  Applying Landing Page Elements to a Folder
Landing pages and landing page elements can enhance the presentation and utility of your Novell 
Vibe folders. You can set up a landing page on your folder, or you can simply apply some key 
landing page elements to the folder, such as hiding the Vibe masthead, the Navigation panel, and so 
forth.

Section 3.8.1, “Displaying a Landing Page on a Folder,” on page 37
Section 3.8.2, “Applying Specific Landing Page Elements to a Folder,” on page 37

3.8.1  Displaying a Landing Page on a Folder
Just as landing pages can enhance the presentation and utility of your Vibe workspaces, they can 
also enhance your Vibe folders.

For information on how you can create a landing page for a folder, see Section 6.11, “Creating a 
Landing Page for a Folder,” on page 71.

3.8.2  Applying Specific Landing Page Elements to a Folder
You can leverage certain landing page elements in your Vibe folder without implementing an actual 
landing page. 

For example, you might want to hide the Navigation panel from your folder in order to create more 
viewing room for users who view the folder.

You can apply the following landing page elements to a folder, without implementing an actual 
landing page:

Hide the Vibe Masthead
Hide the Navigation panel
Hide the Footer toolbar
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To make these modifications to your folder without implementing an actual landing page, you need 
to add the Landing Page element to your folder Form definition. For information on how to add the 
Landing Page element to your folder Form definition, see Chapter 8, “Creating Custom Folder 
Views,” on page 83.
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4Controlling Access

If you are a Novell Vibe OnPrem site administrator or a workspace and folder owner, it is your 
responsibility to keep your content safe and your content consumers happy, by making sure they 
have access to the files and folders they depend on. Access control in Vibe is how you accomplish 
this.

Workspace and folder owners are responsible for controlling user access in their workspaces or 
folders. Site administrators are responsible for controlling user access across the entire site.

Section 4.1, “Understanding Access Control,” on page 39
Section 4.2, “Managing Access Control for Users and Groups,” on page 41
Section 4.3, “Managing Access Control for Remote Applications,” on page 48

4.1  Understanding Access Control
Access control is the method by which you specify which users have the right to perform which 
tasks in which places.

Novell Vibe uses role-based access control. By default, there are seven roles, and each role contains 
specific rights. If you want a particular user to have certain rights, then you can assign that user to 
the appropriate role.

For example, a user who has been assigned to the Participant role in a workspace or folder can add 
comments or replies, create entries, delete his or her own entries, modify his or her own entries, and 
read entries in that folder or workspace.

The following sections help you better understand how access control works in Vibe.

Section 4.1.1, “Default Access Control Behavior in Workspaces,” on page 39
Section 4.1.2, “Default User Rights,” on page 40
Section 4.1.3, “Default Roles,” on page 40
Section 4.1.4, “Default Users and Groups,” on page 41

4.1.1  Default Access Control Behavior in Workspaces
By default, most places inherit the access settings of their parent. When you establish settings for a 
primary space, all sub-places automatically apply the same settings, saving administration time. 
However, unlike other types of workspaces, Team workspaces do not retain the access control 
settings of higher-level (parent) workspaces by default.

You can change the access control settings of a lower-level workspace and folder to be different 
from its parent workspace or folder. For information on how to do this, see Section 4.2, “Managing 
Access Control for Users and Groups,” on page 41.
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4.1.2  Default User Rights
By default, all Vibe users have rights to perform the following actions:

Participate in any team workspaces in which they are a member (create folders and entries, 
make comments, etc.)
Create team workspaces (by default, only members of a team can view and participate in team 
workspaces)
Visit all personal workspaces (read entries and comment on them)
Participate in all global workspaces and folders

4.1.3  Default Roles
Vibe includes default roles that you can assign to users and groups. The default roles for workspaces 
and folders are described in “Understanding Default Roles for Workspaces and Folders” on page 40, 
and the default roles for entries are described in “Understanding Default Roles for Entries” on 
page 41. These sections describe the function of each default role, but do not describe all of the 
rights associated with each role. For a complete list of rights, click the name of the role in the table 
on the Configure Access Control page. (In the Action toolbar, click Workspace > Access Control or 
Folder > Access Control.)

For a complete list of roles that site administrators can add, see “Controlling User Access 
throughout the Vibe Site” in the  Novell Vibe OnPrem 3 Administration Guide. For a detailed 
description of each right that can be associated with a given role, see “Understanding the Various 
Rights for Roles” in the  Novell Vibe OnPrem 3 Administration Guide.

Vibe enables site administrators to create their own custom roles, as described in “Defining a New 
Role” in the  Novell Vibe OnPrem 3 Administration Guide. If you have a need for a custom role, 
consult your Vibe administrator.

By default, you can assign users to various roles in workspaces and folders, as well as in entries.

Understanding Default Roles for Workspaces and Folders

Role Description

Visitor Has read-only and comment-only access.

Participant Can create entries and modify those entries, plus perform tasks associated 
with the Visitor role.

Guest Participant Can read entries, create entries, and add comments.

Team Member Has all the rights of a Participant. In addition, can generate reports and 
manage community tags.

Workspace and Folder 
Administrator

Can create, modify, or delete workspaces or folders; moderate participation 
(modify or delete the entries of others); design entries and workflows; set 
entry-level access controls on entries of others; and can perform tasks 
associated with the Participant and Team Member role.

Workspace Creator Can create sub-workspaces. In Team Workspace Root workspaces, this role 
allows users to create their own team workspaces.
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Understanding Default Roles for Entries

4.1.4  Default Users and Groups
As you create users and groups in your Vibe site, you can assign default or custom access control 
roles to them. In addition to the users and groups that you create, Vibe includes four default users 
and groups to which you can assign roles. For information on how to do this, see Section 4.2, 
“Managing Access Control for Users and Groups,” on page 41.

4.2  Managing Access Control for Users and 
Groups
When you have appropriate rights, you can control which users have access to workspaces, folders, 
and entries. Furthermore, you can regulate what actions they are allowed to perform. For example, 
you can allow a specific team to view a workspace, but only allow certain members of that team to 
create entries in the workspace.

Site Administrator Has all rights associated with access control. Available only to Vibe 
administrators.

Role Description

Read Can read the entry.

Read and Reply Can read the entry and add comments or replies to the entry.

Write Can read the entry, add comments or replies, and modify the entry.

Delete Can read the entry, add comments or replies, modify, and delete the entry.

Change ACL Can read the entry, add comments or replies, modify, and delete the entry. 
They can also modify the access control settings of the entry.

Default User and Group Description

Owner of a Workspace or 
Folder

The person who created the workspace, or the person assigned to be the 
owner of the workspace.

Team Members The individuals who are designated as team members in a given place.

For information about how to add team members, see “Adding Additional 
Team Members to Your Workspace” in the Novell Vibe OnPrem 3 User 
Guide.

All Users Every person registered within the Vibe site.

Site Administrator The person who has rights to perform any task in any workspace or folder. 
Available only to Vibe administrators.

Role Description
Controlling Access 41



42 Novell
You can control access to workspaces, folders, and entries.

Section 4.2.1, “Controlling Access to Workspaces and Folders,” on page 42
Section 4.2.2, “Controlling Access to Entries,” on page 46

4.2.1  Controlling Access to Workspaces and Folders
“Accessing the Configure Access Control Page” on page 42
“Activating the Table” on page 43
“Adding Roles to the Access Control Table” on page 44
“Adding Users to the Access Control Table” on page 44
“Adding Groups to the Access Control Table” on page 45
“Assigning Roles to Users and Groups” on page 45
“Adjusting Access Controls in Another Place” on page 45
“Creating Access Controls for Remote Applications” on page 46

Accessing the Configure Access Control Page

Novell Vibe provides a table on the Configure Access Control page that enables you to make all of 
your needed access control modifications. You must use this table to perform any access control 
modifications in Vibe.

1 Navigate to the workspace or folder where you want to modify user access rights.
2 Click Workspace > Access Control in the Action toolbar if you want to change the access 

control settings for a workspace.
or
Click Folder > Access Control in the Action toolbar if you want to change the access control 
settings for a folder.
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The Configure Access Control page is displayed.

Activating the Table

Before you can make modifications to the table on the Configure Access Control page, you need to 
ensure that the folder or workspace does not inherit its access control settings from its parent folder 
or workspace:

1 In the Folder Inheritance section, select no, then click Apply.

You can now make modifications to the table.
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Figure 4-1   Access Control Table

Adding Roles to the Access Control Table

1 Click the Add a Role link at the top of the table.
2 From the drop-down list, select the role that you want to add.

Vibe adds a new column to the table for the new role.
3 Assign the appropriate user or group to this role by selecting the check box in the user’s or 

group’s row, as described in “Assigning Roles to Users and Groups” on page 45.
For information on how to add a new user to the access control table, see “Adding Users to the 
Access Control Table” on page 44.
For information on how to add a new group to the access control table, see “Adding Groups to 
the Access Control Table” on page 45.

4 Click Save Changes.

Adding Users to the Access Control Table

You can individually add users to the Access Control table, or you can add them by using the Vibe 
clipboard.

“Adding Individual Users” on page 44
“Adding Users from the Clipboard” on page 45

Adding Individual Users

1 Click the Add a User link in the left column of the table.
2 In the Add a User field, begin typing the name of the user that you want to add, then select that 

user from the provided list.
Vibe adds a new row to the table for the new user.
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3 Assign the user to the appropriate role by selecting the check box in the column of the user’s 
row, as described in “Assigning Roles to Users and Groups” on page 45.

4 Click Save Changes.

Adding Users from the Clipboard

1 In the upper left corner of the Access Control table, click Add User Names from Clipboard.
All of the users who are currently on your clipboard are added to the Access Control table.
For more information on how to use the Vibe clipboard, see “Using the Vibe Clipboard” in the 
Novell Vibe OnPrem 3 User Guide.

2 Assign the users to the appropriate role by selecting the check box in the column of each user’s 
row, as described in “Assigning Roles to Users and Groups” on page 45.

3 Click Save Changes.

Adding Groups to the Access Control Table

1 Click the Add a Group link in the left column of the table. 
2 In the Add a Group field, begin typing the name of the group that you want to add, then select 

that group from the provided list.
Vibe adds a new row to the table for the new group.

3 Assign the group to the appropriate role by selecting the check box in the column of the group’s 
row, as described in “Assigning Roles to Users and Groups” on page 45.

4 Click Save Changes.

Assigning Roles to Users and Groups

A role is a set of privileges. When you assign a user or group to a role, that user or group 
automatically has all the rights associated with that role.

1 Ensure that the user or group and the role that you want to associate with the user or group are 
visible in the Access Control table.
For information on how to add a role or a user or group to the table, see “Adding Roles to the 
Access Control Table” on page 44, “Adding Users to the Access Control Table” on page 44, 
and “Adding Groups to the Access Control Table” on page 45.

2 In the row of the user or group, select the check box that is located in the role column that you 
want to assign to the user or group.

3 Click Save Changes.

If you want to unassign a role:

1 Deselect the appropriate check box, then click Save Changes.

Adjusting Access Controls in Another Place

Vibe enables you to adjust the access control settings of any workspace or folder, directly from the 
Configure Access Control page.

1 In the workspace tree at the top of the Configure Access Control page, navigate to the place 
where you want to adjust the access controls.
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2 Click the linked title of the place where you want to adjust the access controls.
Vibe displays the Configure Access Control page for the page that you specified.

Creating Access Controls for Remote Applications

Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. 

For information on how to do this by using access controls, see Section 12.4, “Managing Access 
Controls for Remote Applications,” on page 143.

4.2.2  Controlling Access to Entries
Vibe enables you to set access controls for an entry that differ from the access controls of the parent 
folder. You might want to do this if you have granted a group of users access to a folder, but only 
want a subset of that group to have access to see certain entries within the folder. Or, you might want 
to set access controls on a particular entry to make that entry visible to users who don’t have access 
to the folder where the entry resides, as described in “Exposing a Vibe Entry to a Wider Audience 
Than the Folder Access Controls Allow” on page 48.

Before you can modify access controls for an entry, you need to ensure that the entry does not inherit 
its access control settings from the parent folder:

To set access controls on an entry:

1 Navigate to the entry where you want to modify user access rights.
2 Click Actions > Access Control in the Entry toolbar.

The Configure Access Control page is displayed.

3 To set access controls that differ from the access controls of the parent folder, select Specify the 
access controls for this entry, then click Apply.
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4 Use the table to modify user access to the entry. 
You can assign various roles to team members, groups, or individual users. 
For information about the roles that you can assign, see “Understanding Default Roles for 
Entries” on page 41.
For information about how to add users and groups to the access control table, see “Adding 
Users to the Access Control Table” on page 44 and “Adding Groups to the Access Control 
Table” on page 45.

5 (Optional) Select Include the Folder Access Controls if you want to extend the new entry-level 
access controls to include the access controls that are already in place for the folder. Selecting 
this option automatically grants users with the same access rights to the entry that they have to 
the folder.
Deselect Include the Folder Access Controls if you want the new entry-level access controls to 
override the folder-level access controls. If you deselect this option, you must use the entry-
level access controls to specify each user or group that you want to have access to the entry. 
Users who have access to the folder that contains the entry but have not been granted access 
rights to the entry itself do not have access to the entry. 

6 Click Save Changes > Close.
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Exposing a Vibe Entry to a Wider Audience Than the Folder Access Controls Allow

You can expose a Vibe entry to make it visible to a wider audience than the folder where the entry 
resides. For example, if your folder is visible only to team members, the default access controls 
allow only team members to see all entries that are created in the folder. However, by deselecting 
Include the Folder Access Controls, you can enable a wider audience to view a specific entry. You 
might want to do this if the majority of content in a folder is sensitive and should be restricted to a 
limited audience, but you want to expose a specific entry to a larger audience.

For example, suppose that you are a member of a finance team that is responsible for the accounting 
of your company’s quarterly earnings. All the information in your team’s workspace is confidential. 
However, when it is time to announce the company’s quarterly earnings, you create a Vibe entry that 
contains the earning results, and you modify the access controls of this specific entry to make the 
entry visible to all company employees.

To expose a Vibe entry to a wider audience than is currently allowed in the folder:

1 Modify the entry access controls as described in Section 4.2.2, “Controlling Access to Entries,” 
on page 46.
Ensure that you deselect Include the Folder Access Controls, as described in Step 5 of this 
section.

NOTE: When you expose a Vibe entry to a wider audience than is currently allowed in the folder, 
users must perform a search in order to locate the entry, or they must have the entry shared with 
them. Users cannot locate the entry by navigating the Workspace tree, as described in “Navigating 
the Workspace Tree” in the Novell Vibe OnPrem 3 User Guide.

4.3  Managing Access Control for Remote 
Applications
Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. 

For information on how to do this by using access controls, see Section 12.4, “Managing Access 
Controls for Remote Applications,” on page 143.
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5Branding a Folder or Workspace

Branding a folder or workspace is a good way to make the folder or workspace more unique and 
identifiable. When you brand a folder or workspace, the brand is applied to all sub-workspaces and 
sub-folders. However, folder and workspace owners in lower-level folders and workspaces can 
override the higher-level brand settings by adding a workspace brand of their own. For example, the 
Global Workspaces folder can be branded with the company logo and slogan, while a team 
workspace at a lower level in the workspace tree can be branded with a logo for the product that the 
team is responsible for. Members of that team can then override the team brand by branding 
individual folders within the team workspace that they are responsible for.

Novell Vibe OnPrem administrators can disable this functionality when they create a site-wide 
brand, as discussed in “Creating a Site-Wide Brand” in the  Novell Vibe OnPrem 3 Administration 
Guide. 

If you are unable to brand a folder or workspace as discussed in this section, contact your Vibe 
administrator.

To brand a folder or workspace:

1 Navigate to the folder or workspace where you want to create the brand.
2 Click Workspace > Brand Workspace if you are branding a workspace.

or
Click Folder > Brand Folder if you are branding a folder.
The Workspace/Folder Branding dialog box is displayed.

3 Specify the following information to create your desired brand:
Use Branding Image: Select this option if you want to use the drop-down list to select an 
existing image, or click the Browse icon  to browse to an image on your computer’s file 
system.
Use Advanced Branding: Select this option, then click Advanced if you want to create a brand 
that includes advanced features, such as linking to another Vibe page or displaying a YouTube 
video.
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You can add a YouTube video in your branding section by clicking the Video icon .
For more information about displaying YouTube videos in Vibe, see “Displaying YouTube 
Videos in a Folder Entry” in the Novell Vibe OnPrem 3 User Guide.
For more information about linking to another Vibe page, see “Linking to a Folder or Folder 
Entry” in the Novell Vibe OnPrem 3 User Guide.
If you add a URL to the advanced branding, the URL cannot contain the following parameter: 
url_created_by_teaming. If this parameter does exist, delete it before saving your brand.
Background Image: Use the drop-down list to select an existing image, or click the Browse 
icon  to browse to an image on your computer’s file system.
The background image is displayed behind your regular branding.
Stretch Image: Stretches the image to occupy the entire branding area.
If you stretch your background image, the image overrides any background color that you have 
set.
Background Color: Adds a background color that occupies the entire branding area. To 
change the background color, click the color name to the right of this field, select the new color, 
then click OK.
If you added a background image and stretched the image, the background color is not 
displayed.
Text Color: Changes the text color of the workspace name in the upper-right corner of the 
branding area. To change the text color, click the color name to the right of this field, select the 
new color, then click OK.
Clear branding: Clears all your current branding selections.

4 Click OK.
The folder or workspace now displays the brand that you created.
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6Creating and Managing Landing 
Pages

Landing pages in Novell Vibe OnPrem can benefit your workspaces and folders in two key ways:

Improved Customization: Landing pages provide an excellent opportunity to put a custom, 
personal face on workspaces and folders in your Vibe site, while still providing the team-
focused, collaborative functionality that Vibe affords.
Increased Retrievability: Landing pages increase the accessibility and visibility of the 
information that is most critical to your team or organization. You can bring important entries 
or entire folders to the forefront of workspaces, ensuring that users access the information they 
need in a quick, efficient manner.

For example, a landing page for a city’s public sector might look something like this:

Section 6.1, “Enabling the Landing Page View for a Workspace,” on page 52
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Section 6.2, “Setting Up Your Landing Page,” on page 53
Section 6.3, “Publishing Your Landing Page,” on page 64
Section 6.4, “Modifying the Contents of Your Landing Page,” on page 64
Section 6.5, “Deleting Content from Your Landing Page,” on page 65
Section 6.6, “Automatically Displaying the Newest Folder Entries on Your Landing Page,” on 
page 65
Section 6.7, “Adding Accessories to Your Landing Page,” on page 67
Section 6.8, “Enabling Graphics to Be Used on a Landing Page,” on page 69
Section 6.9, “Displaying YouTube Videos on a Landing Page,” on page 70
Section 6.10, “Creating a Landing Page for a Personal Workspace,” on page 70
Section 6.11, “Creating a Landing Page for a Folder,” on page 71
Section 6.12, “Downloading Existing Landing Pages,” on page 72

6.1  Enabling the Landing Page View for a 
Workspace
Before you can create the landing page, you need to enable the landing page view for the workspace.

Novell Vibe includes a default workspace landing page view. The default landing page view 
contains a Landing Page Layout section, a Description section, a Branding section, an Icon section, 
and an Attachments section.

Or, you can create a custom landing page view for a workspace that contains only the sections that 
you choose. For information on how to create a custom landing page view for a workspace, see 
Chapter 7, “Creating Custom Workspace Views,” on page 73.

To enable the landing page view:

1 Navigate to the workspace where you want to create the landing page.
You can create a landing page for a personal workspace only if your Vibe administrator has 
enabled you to do so. For more information, see Section 6.10, “Creating a Landing Page for a 
Personal Workspace,” on page 70.

2 Click Workspace > Configure in the Action toolbar.
The Configure Default Settings page is displayed

3 In the Default View section, select Landing Page.
4 Click Apply > Close.

What was previously displayed on the main page of the workspace is no longer displayed and 
the main page of the workspace is blank.

5 Continue with Section 6.2, “Setting Up Your Landing Page,” on page 53.
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6.2  Setting Up Your Landing Page
After you enable a landing page as described in Section 6.1, “Enabling the Landing Page View for a 
Workspace,” on page 52, you need to set it up to display the desired layout options and content, as 
described in the following sections:

Section 6.2.1, “Choosing Layout Options for Your Landing Page,” on page 53
Section 6.2.2, “Adding Content to Your Landing Page,” on page 53
Section 6.2.3, “Configuring Landing Page Elements,” on page 55

6.2.1  Choosing Layout Options for Your Landing Page
1 Navigate to the landing page that you created in Section 6.1, “Enabling the Landing Page View 

for a Workspace,” on page 52.
2 Click Workspace > Edit Workspace in the Action toolbar.

3 In the Landing Page Layout section, below the workspace Title field, you can select from the 
following options to modify the display of your landing page:

Hide the Masthead: Select this option to hide the masthead (Navigation toolbar). This 
hides everything above the Action toolbar.
Hide the Navigation Panel: Select this option to hide the Navigation panel.
Hide the Footer: Select this option to hide the Footer toolbar.

4 Click OK to save the layout changes.

6.2.2  Adding Content to Your Landing Page
1 Navigate to the landing page that you created in Section 6.1, “Enabling the Landing Page View 

for a Workspace,” on page 52.
2 Click Workspace > Edit Workspace in the Action toolbar.
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3 In the Landing Page Layout section, in the content editor, use the element palette to select the 
landing page element that you want to display on your landing page.

You can add the following elements:
Table: Creates a table with the number of columns that you specify. You can add other 
elements inside this table.
List: Creates a list where you can add other elements.
Entry: Enables you to reference an entry that has previously been created in Novell Vibe.
Folder: Enables you to reference a folder that has previously been created in Vibe. You 
can choose how many entries from the folder that you want to display on your landing 
page at any one time.
Graphic: Enables you to reference a graphic that has previously been added to the 
workspace.
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Link (URL): Enables you to create a link to a Web URL.
Link to Folder/Workspace: Enables you to add a link to a Vibe folder or workspace.
Link to Entry: Enables you to add a link to a Vibe entry.
Utility Element: Enables you to add various utilities, such as the My Workspace link.
Custom JSP: Enables you to reference a custom JSP file that has previously been created 
by a Vibe administrator.

4 Drag the element that you want to display on your landing page and drop it onto the landing 
page canvas.

After you drop the element onto the landing page canvas, you are prompted to configure it. 
The way you configure a landing page element depends on the type of element that you add. 

5 Configure the landing page element as described in Section 6.2.3, “Configuring Landing Page 
Elements,” on page 55.

6.2.3  Configuring Landing Page Elements
You need to configure the elements of your landing page when you are first creating them, as 
described in Section 6.2.2, “Adding Content to Your Landing Page,” on page 53.

You can also reconfigure the elements of your landing page at any time, as described in Section 6.4, 
“Modifying the Contents of Your Landing Page,” on page 64.

After you have added and configured the elements of your landing page, you are ready to publish the 
landing page. For information on how to do this, see Section 6.3, “Publishing Your Landing Page,” 
on page 64.

“Adding a Table” on page 56
“Adding a List” on page 56
“Adding an Entry” on page 57
“Adding a Folder” on page 58
“Adding a Graphic” on page 59
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“Adding a Link (URL)” on page 60
“Adding a Utility Element” on page 62
“Adding a Custom JSP” on page 63

Adding a Table

To add a table to the landing page:

1 In the Landing Page Layout section, in the content editor, click Table in the element palette, 
then drag it and drop the table into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the table:
Show border: Select this option if you want the border of the table to be visible.
Number of columns: Specify the number of columns that you want the table to have. You 
can have up to five columns.
Column 1 width: Specify the width that you want the first column to have.
If your table has multiple columns, you can specify the width for each column.

3 Click OK.

After you add a table to a landing page, you can add content within the table.

1 Select an element from the element palette and drag and drop it into the location of the table 
where you want to add the content.

Adding a List

To add a list to the landing page:

1 In the Landing Page Layout section, in the content editor, click List in the element palette, then 
drag it and drop it into the desired area of the landing page canvas.
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2 Set the following configuration options to finish setting up the list:
Title: Specify a title for the list.
Show border: Select this option if you want the border of the list to be visible.

3 Click OK.

After you add a list to a landing page, you can add content within the list.

1 Select an element from the element palette and drag and drop it into the location of the list 
where you want to add the content.

Adding an Entry

The actual content of your landing page is created in entries. The landing page simply references 
entries that have already been created within Vibe.

To add an entry to the landing page:

1 In the Landing Page Layout section, in the content editor, click Entry in the element palette, 
then drag it and drop it into the desired area of the landing page canvas.
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2 Set the following configuration options to finish setting up the entry:
Current entry: This field is populated only if you have already configured this element, 
as described in this section. After you have configured this element as described in this 
section, the entry that is being referenced is shown here.
New entry: Specify the entry that you want to display on the landing page.
This field uses type-to-find functionality, so Vibe displays the available options as you 
type.
Show the title bar: Select this option if you want the title bar of the entry to be visible.

3 Click OK.

Adding a Folder

1 In the Landing Page Layout section, in the content editor, click Folder in the element palette, 
then drag it and drop it into the desired area of the landing page canvas.
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2 Set the following configuration options to finish setting up the folder:
Current folder: This field is populated only if you have already configured this element, 
as described in this section. After you have configured this element as described in this 
section, the folder that is being referenced is shown here.
New folder: Specify the folder that you want to display on the landing page.
This field uses type-to-find functionality, so Vibe displays the available options as you 
type.
Number of entries to show: Specify the number of folder entries that you want to be 
displayed at any one time.
Show the title bar: Select this option if you want the folder title bar to be displayed.
Show the folder description: Select this option if you want the folder description to be 
displayed.
Show entries opened: Select this option if you want opened entries to be displayed.

3 Click OK.

Adding a Graphic

Before you can add a graphic to your landing page, you need to attach the graphic to the landing 
page, as described in Section 6.8, “Enabling Graphics to Be Used on a Landing Page,” on page 69.

1 In the Landing Page Layout section, in the content editor, click Graphic in the element palette, 
then drag it and drop it into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the graphic:
Graphic: In the Graphic drop-down list, select the graphic that you want to display.
All attachments that are attached to the landing page workspace are displayed in this list. 
Attachments are also displayed in the Current Attached Files section at the bottom of the 
page.
Show border: Select this option if you want the border of the list to be visible.

3 Click OK.
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Adding a Link (URL)

1 In the Landing Page Layout section, in the content editor, click Link (URL) in the element 
palette, then drag it and drop it into the desired area of the landing page canvas.

2 Set the following configuration options to finish setting up the URL link:
Title: Specify the title that you want to be displayed.
URL: Specify the URL that you want to link to.
To link to a URL outside of Vibe, you must include http:// at the beginning of the URL.
To link to a page within Vibe, the best method is to use the Link to Folder/Workspace 
element or the Link to Entry element.
An alternative is to paste a Vibe permalink into this field. To get the permalink URL of a 
Vibe page, simply navigate to the page that you want to link to, click Permalink in the 
footer toolbar, then copy the permalink URL from the Permalink field.
Open URL in a new window: Select this option if you want to open the URL in a new 
browser window.

3 Click OK.

Linking to a Folder/Workspace

You can create a link to any folder or workspace for which you have appropriate rights.

1 In the Landing Page Layout section, in the content editor, click Link to Folder/Workspace in 
the element palette, then drag it and drop it into the desired area of the landing page canvas.
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2 Set the following configuration options to finish setting up the link:
Current folder/workspace: If you are editing this element after it has already been 
created, this field displays the folder or workspace that you are currently linking to. If you 
are creating a new element, this field is blank.
New folder/workspace: Specify the folder or workspace that you want to link to.
Title: Specify a title for the link.
Open the folder/workspace in a new window: Select this option if you want to open the 
folder or workspace in a new browser window.

Linking to an Entry

Enables you to create a link to any entry for which you have appropriate rights.

1 In the Landing Page Layout section, in the content editor, click Link to Entry in the element 
palette, then drag it and drop it into the desired area of the landing page canvas.
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2 Set the following configuration options to finish setting up the link:
Current entry: If you are editing this element after it has already been created, this field 
displays the entry that you are currently linking to. If you are creating a new element, this 
field is blank.
New entry: Specify the folder entry that you want to link to.
Title: Specify a title for the link.
Open the entry in a new window: Select this option if you want to open the entry in a 
new browser window.

Adding a Utility Element

Most utility elements are options that are normally displayed either in the Vibe masthead or 
Navigation panel; however, because it is often desirable to hide the masthead and Navigation panel 
in order to make more room for information on your landing page, utility elements enable you to 
display important features in a more concise view.

1 In the Landing Page Layout section, in the content editor, click Utility Element in the element 
palette, then drag it and drop it into the desired area of the landing page canvas.

2 Select from the following utility elements:
Link to “Vibe administration page”: Provides a link to the Vibe Administration page.
This link is visible only to Vibe users who have administrative rights.
Link to “My Workspace”: Displays a link to your personal workspace.
Link to “Share this folder or workspace”: Displays a Share This Workspace or Share This 
Folder link.
Link to “Follow this folder or workspace”: Displays a Follow This Workspace or Follow 
This Folder link.
Sign-in form: Displays a Sign In form when users are not logged in to Vibe.

3 Click OK.
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Adding a Custom JSP

Custom JSP files are stored in the WEB-INF\jsp\custom_jsps directory. If you want to include a 
custom JSP file in your landing page, you must store the file in this directory in order to reference it 
from Vibe.

Typically, only Vibe administrators have access to this directory. If you want to create a custom JSP 
file, consult your Vibe administrator.

After the custom JSP file has been placed in the WEB-INF\jsp\custom_jsps directory:

1 In the Landing Page Layout section, in the content editor, click Custom JSP in the element 
palette, then drag it and drop it into the desired area of the landing page canvas.

2 In the Custom JSP name field, type the name of the custom JSP file that you want to reference.
You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
enable JSP files to be used in the Vibe site.

3 Depending on how you want to use this custom JSP file, select either Associate a folder with 
this custom jsp, or Associate an entry with this custom jsp.
For example, if your administrator has enabled a custom JSP file that enhances the way entries 
are displayed on the landing page, and you want to utilize this JSP file for a specific folder, you 
would select Associate a folder with this custom jsp.

4 Set the appropriate configuration options to finish setting up the custom JSP:
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Current folder: If you are editing this element after it has already been created, this field 
displays the folder that the custom JSP file is currently associated with. If you are creating a 
new element, this field is blank.
New folder: Begin typing the name of the folder that you want the custom JSP file to be 
associated with, then select the folder name when it appears in the drop-down list.
Number of entries to show: Specify how many folder entries you want to be displayed on the 
landing page at any one time.
Show the title bar: Select this option if you want the title bar of the entry to be visible.

5 Click OK.

6.3  Publishing Your Landing Page
After you have added elements to your landing page and configured them, you can publish the 
contents of the landing page.

1 Scroll to the bottom of the page that contains the landing page editor.
2 Click OK.

The landing page is displayed with all of the content that you previously added.

6.4  Modifying the Contents of Your Landing Page
Novell Vibe enables you to modify the elements that have been previously added to your landing 
page.

1 Navigate to the landing that contains the elements that you want to modify.
For information about each type of element that you can modify, see Section 6.2.3, 
“Configuring Landing Page Elements,” on page 55.

2 Click Workspace > Edit Workspace in the Action toolbar.
3 In the Landing Page Layout section, in the content editor, click the edit icon  located in the 

upper right corner of the landing page element that you want to modify.
The properties dialog box of the element that you are modifying is displayed.
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4 Modify the properties of the element, then click OK.

6.5  Deleting Content from Your Landing Page
Novell Vibe enables you to delete elements that have previously been added to your landing page.

1 Navigate to the landing page that contains the element that you want to delete.
2 Click Workspace > Edit Workspace in the Action toolbar.
3 In the Landing Page Layout section, in the content editor, click the delete  icon located in the 

upper right corner of the landing page element that you want to delete.
4 Click OK to delete the element.

6.6  Automatically Displaying the Newest Folder 
Entries on Your Landing Page
You do not need to manually modify your landing page every time you want to replace an entry. 
Because it can be tedious to delete an entry and then add another one from the Add/Delete form in 
the Edit Workspace page, Novell Vibe enables you to leverage the power of workflows to help keep 
your landing page up-to-date, with minimal manual effort.

For example, suppose that you are the manager of a particular product, and you want to use your 
team landing page to display the product’s earnings for the most recent quarter. You could reference 
a particular entry in the Quarterly Earnings folder, where all of the quarterly earnings for the product 
are stored; however, this would mean that at the end of each quarter you would need to manually 
delete the old entry from your landing page, and then add the new entry for the new quarter. Vibe 
provides an easier way: simply reference the Quarterly Earnings folder from your landing page, and 
at the end of each quarter start the Publish workflow (as described in Section 11.6.1, “Available 
Workflows,” on page 134) on the entry that contains the earning for that quarter. This displays the 
entry that contains the updated quarterly earnings.

Section 6.6.1, “Pointing to the Folder Where the Entry Resides,” on page 66
Section 6.6.2, “Using the Publish Workflow to Publish Entries to Your Landing Page,” on 
page 66
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6.6.1  Pointing to the Folder Where the Entry Resides
When you are adding content to your landing page (as described in Section 6.2.2, “Adding Content 
to Your Landing Page,” on page 53), if you display an entry that you might want to replace in the 
future, reference the folder where the entry resides instead of referencing the entry directly.

1 Navigate to your landing page.
2 Click Workspace > Edit Workspace.
3 In the Landing Page Layout section, in the content editor, click Folder in the element palette, 

then drag it and drop it into the desired area of the landing page canvas.

4 Set the following configuration options to finish setting up the folder:
Current folder: This field is populated only if you have already configured this element, 
as described in this section. After you have configured this element as described in this 
section, the folder that is being referenced is shown here.
New folder: Specify the folder where the entry that you want to display resides.
This field uses type-to-find functionality, so Vibe displays the available options as you 
type.
Number of entries to show: Specify the number of folder entries that you want to be 
displayed at any one time.
Show the title bar: Select this option if you want the folder title bar to be displayed.
Show the folder description: Select this option if you want the folder description to be 
displayed.
Show entries opened: Select this option if you want opened entries to be displayed.

5 Click OK.

6.6.2  Using the Publish Workflow to Publish Entries to Your 
Landing Page
By default, Vibe includes a workflow called Publish. This workflow can help you more easily 
manage what is displayed on your landing page.
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If you are referencing a folder from your landing page (as described in Section 6.6.1, “Pointing to 
the Folder Where the Entry Resides,” on page 66), and you have configured the landing page to 
display just one entry from the folder, you can use the Publish workflow to decide which entry you 
want to display on your landing page.

The most recent entry that you publish is the entry that is displayed on the landing page (published 
to the landing page).

“Enabling the Publish Workflow on Your Folder” on page 67
“Publishing a New Entry to Your Landing Page” on page 67

Enabling the Publish Workflow on Your Folder

1 Navigate to the folder where you want to enable the Publish workflow.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Allowed Workflows section, select Publish Workflow.
4 Click Apply > Close.

Publishing a New Entry to Your Landing Page

1 Open the entry that you want to display on your landing page.
2 In the Entry toolbar, click Workflow > Start Workflow: Publish Workflow.

The entry where you most recently started the Publish workflow is now displayed on your 
landing page, replacing the entry that was previously displayed.

6.7  Adding Accessories to Your Landing Page
You can add accessories to a landing page by modifying the view of the standard landing page, or by 
creating a new landing page view. You must be the Vibe administrator to modify the view of the 
standard landing page. If you are not the Vibe administrator, you must create a new landing page 
view.

Section 6.7.1, “Modifying the Default Landing Page,” on page 67
Section 6.7.2, “Creating a New Landing Page View,” on page 68

6.7.1  Modifying the Default Landing Page
You can add the Accessory Panel to the default Landing Page view. This means that all landing 
pages that are created in the Vibe site will contain the Accessory Panel.

You must be the Novell Vibe administrator or have administrative rights to modify the default 
Landing Page view.

1 Click the Administration icon , located in the upper right corner of the Vibe page.
The administration page is displayed.

2 Under System, click Form/View Designers.
The Form and View Designers page is launched.
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3 Expand Workspace view, then click Landing Page.
4 Click Workspace view > Add.
5 In the Standard Form Elements section, click Accessory Panel, then click OK.

The Accessory Panel has now been added to the standard Landing Page view, so users can add 
accessories to their landing pages.

6.7.2  Creating a New Landing Page View
You can create your own Landing Page view, then add the Accessory Panel element to the view. You 
do not need to be the Vibe administrator to create a new landing page view.

“Creating the New Landing Page Definition” on page 68
“Adding the Landing Page Layout Option” on page 68
“Enabling the New Landing Page” on page 69
“Modifying the Landing Page After You Have Created It” on page 69

Creating the New Landing Page Definition

1 Navigate to the workspace where you want to create the new Landing Page view.
2 Click Workspace > Form/View Designers in the Action toolbar.

The Form and View Designers page is displayed.
3 Click New > Workspace views.
4 Specify the following information:

Caption: Specify a name for the new landing page.
This is the name that appears in the Vibe interface for users to see when they use this 
workspace. (For example, Custom Landing Page.)
Name: Specify the internal name for the landing page.
The name that you enter in this field is not visible to users who use this workspace. (For 
example, custom_landing_page.)
Family: Select the workspace type that this view is most closely associated with.
Workspace Icons: Select the workspace icon that you want to represent the landing page.

5 Click OK.
The Designer page is launched.

6 Continue with “Adding the Landing Page Layout Option” on page 68.

Adding the Landing Page Layout Option

1 In the Designer page, click Workspace Add/Modify Form > Add.
2 In the Layout Options section, click Landing Page Layout.
3 Specify the following information:

Caption: Specify a name for the Landing Page Layout, or keep the default.
Name: Specify the internal name for the Landing Page Layout.

4 Click OK.
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5 Click Workspace view > Add.
6 In the Standard Form Elements section, click Landing Page Layout.
7 For the Caption and Data item name fields, retain the same information that you specified in 

Step 3.
8 Click OK > Close > Close.
9 Continue with “Enabling the New Landing Page” on page 69.

Enabling the New Landing Page

After you have created the new landing page view, you need to enable it on the workspace.

1 From the workspace where you want to enable the landing page, click Workspace > Configure.
The Configure Default Settings page is displayed.

2 In the Default View section, go to the Local Definitions subsection and select the landing page 
that you created.

3 Click Apply > Close.
The landing page is now displayed when you access the workspace.

4 Continue with “Modifying the Landing Page After You Have Created It” on page 69.

Modifying the Landing Page After You Have Created It

Now that you have created and enabled the new landing page, you can configure the landing page 
layout options, such as hiding the Navigation panel. This can give your landing page a more 
traditional landing page feel.

For information about how to modify the landing page layout options, see Section 6.2.1, “Choosing 
Layout Options for Your Landing Page,” on page 53.

6.8  Enabling Graphics to Be Used on a Landing 
Page
Before you can add a graphic to a landing page, as described in “Adding a Graphic” on page 59, you 
need to attach the graphic to the workspace.

1 Navigate to the landing page where you want to attach the graphic.
2 Click Workspace > Edit Workspace.
3 In the Attachments section, click Browse, then browse to and select the graphic that you want to 

add.
4 After the file is selected and is displayed in the Attachments field, click OK.

To delete a file from the workspace:

1 In the Current Attached Files section, select the file that you want to delete.
2 Click OK.
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6.9  Displaying YouTube Videos on a Landing 
Page
Novell Vibe enables you to display YouTube videos in various sections of a landing page.

Section 6.9.1, “Displaying Videos in the Branding Section of a Landing Page,” on page 70
Section 6.9.2, “Displaying Videos in the Main Landing Page Area,” on page 70

6.9.1  Displaying Videos in the Branding Section of a Landing 
Page
You can add a YouTube video to the Branding section of a landing page, as described in Chapter 5, 
“Branding a Folder or Workspace,” on page 49.

6.9.2  Displaying Videos in the Main Landing Page Area
You can display YouTube videos on a landing page by referencing a folder or folder entry that 
contains a YouTube video, as described in Section 6.2.2, “Adding Content to Your Landing Page,” 
on page 53.

 For information on how to create a folder entry that contains a YouTube video, see “Displaying 
YouTube Videos in a Folder Entry” in the Novell Vibe OnPrem 3 User Guide.

6.10  Creating a Landing Page for a Personal 
Workspace
You can create a landing page in a personal workspace only if your Novell Vibe administrator has 
enabled you to do so. If you are unable to create a landing page on your personal workspace as 
described in this section, consult your Vibe administrator.

If you are a Vibe administrator and you want to enable landing page creation for personal 
workspaces, see “Enabling Users to Create Landing Pages on Personal Workspaces” in the  Novell 
Vibe OnPrem 3 Administration Guide.

1 In your personal workspace, click Workspace > Configure in the Action toolbar.
The Configure Default Settings page is displayed.
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2 In the Default View section, select the landing page option that your administrator added.

3 Click Apply > Close.
4 Continue with Section 6.2, “Setting Up Your Landing Page,” on page 53 to complete the 

creation of your landing page.

6.11  Creating a Landing Page for a Folder
Displaying landing pages at the workspace level makes the workspace home page a quick portal to 
the most important information contained throughout the workspace. In addition to displaying 
landing pages at the workspace level, Novell Vibe also enables you to display landing pages at the 
folder level.

You might want to create a landing page for a folder if your folder contains many sub-folders, is 
frequently visited, and contains a lot of information. Because workspace landing pages are more 
common than folder landing pages, the process for creating a landing page on the folder is more 
complex than creating a landing page for a workspace.

By default, in order to create a landing page for a folder in Vibe, you need to create a new folder 
view. (For example, you might name your folder view “Landing Page.”) You need to populate this 
folder view with the Landing Page Layout layout option in the Folder Form, and the Landing Page 
Layout element in the Folder View. For information on how to create a landing page by creating a 
new folder view, see Chapter 8, “Creating Custom Folder Views,” on page 83.

After you create the new landing page folder view, continue setting up your landing page by 
following the information in Section 6.2, “Setting Up Your Landing Page,” on page 53.
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6.12  Downloading Existing Landing Pages
The Novell Vibe Library provides a collection of existing Vibe folder entry forms, workflows, and 
landing pages that have been designed to solve specific business problems. You can easily download 
the custom forms and workflows, then import them into your Vibe environment. You can further 
customize these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Library Web site (http://www.novell.com/products/teaming/
resource-library/).

2 Click the Workspaces tab.
3 Select the custom workspace that you want to use in your Vibe environment.
4 In the Attachment section, click the zip file to download it.
5 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Library Deployment Instructions 
(http://www.novell.com/communities/node/8359/deployment-instructions-boulder-teaming-2).
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7Creating Custom Workspace 
Views

Novell Vibe OnPrem enables you to create custom workspace views and to customize existing 
views. Workspace views define what is displayed on the home page of your workspace. When you 
create custom workspace views, you can configure workspaces to display optional features such as 
remote applications, attachments, and more. You can even create a custom workspace landing page.

To create a custom workspace view, you must complete the following sections:

Section 7.1, “Creating a New Custom Workspace View,” on page 73
Section 7.2, “Modifying an Existing Workspace View,” on page 77
Section 7.3, “Enabling the Workspace View,” on page 78
Section 7.4, “Populating Elements in the Workspace View,” on page 78
Section 7.5, “Understanding Elements,” on page 78
Section 7.6, “Understanding Layout Options,” on page 80

7.1  Creating a New Custom Workspace View
To create a new custom workspace, you use the Form and View Desiner to create a view, then you 
create a form with the elements and layout options that you want to display in the view. After the 
form is in place, you add the same elements and layout options to the view, then you can add 
optional view elements to create the final view.

You must have both a form and a view in order to display all the elements that you want in a 
workspace. The form and the view must have a common set of elements and layout options, but the 
view can have some additional elements that are not in the form.

Section 7.1.1, “Creating the View,” on page 74
Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on page 74
Section 7.1.3, “Adding Elements to the Workspace View,” on page 76
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7.1.1  Creating the View
1 Navigate to the workspace where you want to create the new view.
2 Click Workspace > Form/View Designers in the Action toolbar.

The Form and View Designers page is launched.
3 Click New > Workspace Views.

The Add a New Definition form is displayed.
4 Specify the following information in the Add a New Definition section:

Caption: Specify the name of the workspace view that you want to appear in the Novell Vibe 
interface. (For example, “Custom Workspace.”)
Name: Specify the internal name of the workspace view. This name is not visible to regular 
Vibe users. (For example, “custom_workspace.”)
Family: Select the workspace type that this view is most closely associated with.
Workspace Icons: Select the icon that you want to represent the workspace. The icon that you 
select is displayed with the name of the workspace in the Navigation panel.

5 Click OK.
6 Continue with Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on 

page 74.

7.1.2  Adding Elements to the Workspace Add/Modify Form
The workspace add/modify form is the form you see when you are creating or modifying the content 
of your workspace home page. This form needs to contain the elements and layout options that you 
want to display in your workspace home page. For example, you might want to display multiple 
remote applications and a two-column table.

After you add elements and layout options to the workspace form, you must then add those same 
elements and layout options to the workspace view in order for the elements and options to be 
displayed in your workspace. For information on how to add features to the workspace view, see 
Section 7.1.3, “Adding Elements to the Workspace View,” on page 76.

1 Under the custom workspace form that you created, expand Workspace Add/Modify Form.
If you are modifying an existing form, all of the elements and layout options that are currently 
applied to your form are displayed.
or
If you are creating a new form, only the default options are displayed.
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2 Add and modify the desired elements and layout options, as described in the following 
sections:

“Adding Elements to a Form” on page 75
“Modifying Elements in a Form” on page 75
“Adding Layout Options to a Form” on page 75

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Form

1 Click Workspace Add/Modify Form.
2 In the Workspace Add/Modify Form window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 7.5.1, “Workspace Form 
Elements,” on page 79.

4 Specify the appropriate information.
5 Click OK.

Modifying Elements in a Form

If you are modifying an existing form, you can change or delete existing elements.

1 Expand Form, then click the element that you want to modify.
2 In the window on the right side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.

Adding Layout Options to a Form

1 Click Workspace Add/Modify Form.
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2 In the Workspace Add/Modify Form window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.6, 
“Understanding Layout Options,” on page 80.

4 Specify the appropriate information.
5 Click OK.

7.1.3  Adding Elements to the Workspace View
The workspace view is how the information from your workspace add/modify form is displayed to 
users who view your workspace. Every form must have a corresponding view. This view needs to 
contain all of the elements and layout options that you want to display in your workspace home 
page; it is made up of elements from the form.

Vibe provides you with all of the tools necessary to create a workspace view that suits any of the 
purposes that you want to accomplish with your workspace.

Before you can add elements and layout options to the workspace view, you must first add the 
elements and layout options to the workspace form in order for them to be displayed in your 
workspace. (For information on how to add features to the workspace form, see Section 7.1.2, 
“Adding Elements to the Workspace Add/Modify Form,” on page 74.)

To add elements to the views

1 Under the custom entry form that you created, expand Workspace view.
If you are modifying an existing view, all of the elements and layout options that are currently 
applied to your view are displayed.
or
If you are creating a new view, only the default options are displayed.

2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to a View” on page 77
“Adding Layout Options to a View” on page 77
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Adding Elements to a View

1 Click Workspace view.
2 In the Workspace view window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add.

When you add elements to a view, you add elements that have already been added to the form; 
any form element that you create can be added as a view element.
For information on the types of elements that you can add that are specific to views, see 
Section 7.5.2, “Workspace View Elements,” on page 80.

4 Specify the appropriate information.
5 Click OK.

Adding Layout Options to a View

1 Click Workspace view.
2 In the Workspace view window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.6, 
“Understanding Layout Options,” on page 80.

4 Specify the appropriate information.
5 Click OK.

7.2  Modifying an Existing Workspace View
You can also createa custom workspaceby modifying an existing workspace view.

1 In the folder or workspace where the custom workspace view was created, click Workspace > 
Form/View Designers.
The Form and View Designers page is launched.
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2 Expand Workspace view, then click the custom workspace view that you want to modify.
3 Continue with Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on 

page 74.

7.3  Enabling the Workspace View
After you have created the workspace view, you need to enable it as the default view for the 
workspace.

1 Navigate to the workspace where you want to enable your custom view as the default view.
2 Click Workspace > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Default View section, select the custom view that you created.
4 Click Apply > Close.

7.4  Populating Elements in the Workspace View
After you create a workspace view, you need to populate and customize some of the elements that 
you included in the view. 

For example, if you added a Branding element, you need to create your brand to display in the 
workspace; if you added a Description element, you need to populate the element with a description 
of the workspace; if you added an Attachment element, you need to attach any files that you want to 
display in the workspace, and so forth.

1 After the workspace view has been created and enabled as the default workspace view, as 
described in Section 7.3, “Enabling the Workspace View,” on page 78, navigate to the 
workspace.

2 Click Workspace > Edit Workspace.
A page with all of the form elements that you added to the workspace view add/modify form is 
displayed. (If you want these elements to be displayed in the workspace, ensure that you have 
also added them to the view form of the workspace view.)

3 Populate the elements with the desired information.
For example, create your workspace brand, add a workspace description, and attach any files.

4 Click OK.

7.5  Understanding Elements
Elements make up the content of your workspace forms and views. 

When you are adding elements to a form, remember that you need to add that same element to the 
view in order for it to be displayed in the workspace.

You can add the following elements:

Section 7.5.1, “Workspace Form Elements,” on page 79
Section 7.5.2, “Workspace View Elements,” on page 80
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7.5.1  Workspace Form Elements
Attachment(s): Adds a field that enables you to browse for and upload files, making them 
accessible to those who view the workspace.

The files that you upload are displayed in the workspace home page.

Branding: Adds an HTML text editor that enables you to create a brand for the workspace.

This brand is displayed in the upper left corner of the workspace.

Checkbox: Adds a check box that can be selected or deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

Description: Adds an HTML text editor that enables you to specify a description of the workspace.

File Upload: Adds a field that enables users to browse for and upload files.

Group List: Adds an element that enables users to add groups.

Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

HTML Editor Text Area: Adds an HTML text area where you can compose messages, create 
links, upload pictures, and more. The information that you create in this HTML editor is displayed 
in your folder.

Icon: Enables the workspace owner to choose from a selection of icons to represent the workspace.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables you to browse for and upload pictures.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to display certain applications that have been configured by your 
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 139.

Selectbox: Enables you to display options that users can select.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field that enables you to specify a title for the workspace.

URL: Add a field that converts any text into a hyperlink. 
Creating Custom Workspace Views 79



80 Novell
User List: Adds a field that enables you to specify other Vibe users, using Type-to-Find 
functionality. When you specify a user’s name when you modify the workspace, as described in 
Section 8.4, “Populating Elements in the Folder View,” on page 88, Vibe displays the user’s name 
on the folder home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application through iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “Synchronizing Tasks and Calendar Folders to a 
Desktop Calendar Application” in the Novell Vibe OnPrem 3 User Guide.

7.5.2  Workspace View Elements
Any form element that you create can be added as a view element, if you want it to appear in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this 
panel to add community or personal accessories, depending on their individual rights.

For more information on accessories, see “Managing Accessories” in the Novell Vibe OnPrem 3 
User Guide.

Attachments: Displays all attachments.

Branding: Displays the workspace branding.

Entry Creation Date: Displays the date that the entry was created.

Entry Creator: Displays who created the entry.

Entry Creator and Creation Date: Displays who created the entry and when they created it.

Landing Page Layout: Adds a landing page creation form that enables you to create landing page 
elements to display in your workspace.

You must add the Landing Page Layout layout option in the workspace add/modify form before you 
can add it as a view element.

Title: On the workspace home page, displays the title that you specified for the workspace.

Workspace and Folder List: Displays a workspace tree that contains the workspace and all sub-
workspaces and sub-folders.

7.6  Understanding Layout Options
Layout options can enhance the presentation of your workspace forms and views. 

When you are adding layout options to a form, remember that you need to add that same layout 
options to the view in order for it to be displayed in the workspace.

You can add the following form layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.
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Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 103.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Fieldset: Adds a box that can contain other elements.

Use this option if your form is exceptionally long.

HTML: Adds HTML formatting.

Landing Page Layout: (For the View Definition, the Landing Page Layout is in the Elements 
section) Adds a landing page creation form that enables you to create landing page elements that you 
can populate when you modify your workspace.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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8
8Creating Custom Folder Views

Novell Vibe OnPrem enables you to design custom folder views. Folder views define what is 
displayed on the home page of your folder. When you design custom folder views, you can 
configure folders to display optional features such as remote applications, attachments, and more. 
You can even create a folder landing page.

To create a custom folder view, you must complete the following sections:

Section 8.1, “Creating a New Custom Folder View,” on page 83
Section 8.2, “Modifying an Existing Folder View,” on page 87
Section 8.3, “Enabling the Folder View,” on page 88
Section 8.4, “Populating Elements in the Folder View,” on page 88
Section 8.5, “Understanding Elements,” on page 88
Section 8.6, “Understanding Layout Options,” on page 90

8.1  Creating a New Custom Folder View
To create a new custom folder, you use the Form and View Desiner to create a view, then you create 
a form with the elements and layout options that you want to display in the view. After the form is in 
place, you add the same elements and layout options to the view, then you can add optional view 
elements to create the final view.

You must have both a form and a view in order to display all the elements that you want in a folder. 
The form and the view must have a common set of elements and layout options, but the view can 
have some additional elements that are not in the form.

Section 8.1.1, “Creating the View,” on page 83
Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 84
Section 8.1.3, “Adding Elements to the Folder View,” on page 86

8.1.1  Creating the View
1 Navigate to the folder or workspace where you want to create the new view.

If you create a new folder view at the workspace level, the folder view can be enabled on any 
folder within the workspace. If you create the folder view at the folder level, the folder view 
can be enabled only on that folder where the view was created.

2 If you are creating the new folder view at the folder level, click Folder > Form/View Designers 
in the Action toolbar.
or
If you are creating the new folder view at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.
The Form and View Designers page is displayed.

3 Click New > Folder Views.
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The Add a New Definition form is displayed.
4 Specify the following information in the Add a New Definition section:

Caption: Specify the name of the folder view that you want to appear in the Novell Vibe 
interface. (For example, “Custom Blog.”)
Name: Specify the internal name of the folder view. This name is not visible to regular Vibe 
users. (For example, “custom_blog.”)
Family: Select the folder type that this view is most closely associated with.
Create a File Entry on file drag/drop: Select this option if you want Vibe to create a new file 
entry when you drag and drop a file into the folder by using the Add Files to Folder feature, as 
described in “Adding a File by Dragging and Dropping” in the Novell Vibe OnPrem 3 User 
Guide.
If you do not select this option, the default entry type for the folder is created when you drag 
and drop a file into the folder using the Add Files to Folder feature, as described in “Dragging 
and Dropping Files” in the Novell Vibe OnPrem 3 User Guide. For example, in a Blog folder, a 
blog entry is created, and the file is added as an entry attachment.
If you are creating a new view for a Files folder, this option has no effect.
Folder Icons: Select the icon that you want to represent the folder. The icon that you select is 
displayed with the name of the folder in the Navigation panel.

5 Click OK.
6 Continue with Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 84.

8.1.2  Adding Elements to the Folder Add/Modify Form
The Folder Form section in the Form and View Designers tool lets you choose the features you want 
to include in your folder.

After you add elements and layout options to the folder form, you must then add those same 
elements and layout options to the folder view in order for them to be displayed in your folder. For 
information on how to add features to the folder view, see “Adding Elements to a Folder Form” on 
page 85.

Vibe provides you with all of the tools necessary to create a folder form that suits any of the 
purposes that you want to accomplish with your folder.

1 Expand the custom folder form that you previously defined.
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2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to a Folder Form” on page 85
“Modifying Elements in a Folder Form” on page 85
“Adding Layout Options to a Form” on page 85

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Folder Form

1 Click Folder Form.
2 In the Folder Form window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 8.5.1, “Folder Form 
Elements,” on page 88.

4 Specify the appropriate information.
5 Click OK.

Modifying Elements in a Folder Form

1 Expand Form, then click the element that you want to modify.
2 In the window on the right side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.

Adding Layout Options to a Form

1 Click Folder Form.
2 In the Folder Form window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.
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For information on the types of layout options that you can add, see Section 8.6, 
“Understanding Layout Options,” on page 90.

4 Specify the appropriate information.
5 Click OK.

8.1.3  Adding Elements to the Folder View
The folder view is how your folder form is displayed to other users. Every folder form must have a 
view associated with it. This view needs to contain all of the elements that you want to display in 
your folder.

Vibe provides you with all of the tools necessary to create a folder view that suits any of the 
purposes that you want to accomplish with your folder.

1 Expand the custom folder view that you previously defined, then expand Folder View.
If you are modifying an existing view, all of the elements and layout options that are currently 
applied to the view are displayed.
or
If you are creating a new view, only the default options are displayed.

2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to a Folder View” on page 86
“Adding Layout Options to a Folder View” on page 87

Adding Elements to a Folder View

1 Click Folder View.
2 In the Folder View Definition window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add to the view.

For information on the types of elements that you can add, see Section 8.5.2, “Folder View 
Elements,” on page 90.
 Vibe OnPrem 3 Advanced User Guide



Before you can add some of these elements to your Folder View, you must first add them to the 
Folder Form. For information on how to do this, see “Adding Elements to a Folder Form” on 
page 85.

4 Specify the appropriate information.
5 Click OK.

Adding Layout Options to a Folder View

1 Click Folder View.
2 In the Folder View window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 8.6, 
“Understanding Layout Options,” on page 90.

4 Specify the appropriate information.
5 Click OK.

8.2  Modifying an Existing Folder View
You can also create a custom folder by modifying an existing folder view.

1 In the folder or workspace where the custom folder view was previously defined, click Folder 
> Form/View Designers.
The Form and View Designers page is launched.

2 Expand Folder Views, then click the custom folder view that you want to modify.

3 Continue with Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 84.
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8.3  Enabling the Folder View
After you have defined and designed the folder view, you need to enable it to be viewed by those 
who will use the folder.

You can enable the folder view to be the default folder view for a folder, or to be an alternate folder 
view.

For information on how to do this, see Section 3.1, “Managing Folder Views,” on page 25.

8.4  Populating Elements in the Folder View
After you create and enable a folder view, you need to populate and customize some of the elements 
that you included in the view. 

For example, if you added a Branding element, you need to create your brand to display in the 
folder; if you added a Description element, you need to populate the element with a description of 
the folder; if you added an Attachment element, you need to attach any files that you want to display 
in the folder, and so forth.

1 Ensure that the folder view has been created and enabled as the default folder view, as 
described in Section 8.1, “Creating a New Custom Folder View,” on page 83 and Section 8.3, 
“Enabling the Folder View,” on page 88.

2 Navigate to the folder where you enabled the folder view.
3 Click Folder > Edit Folder in the Action toolbar.

A page with all of form elements that you added to the folder form is displayed. (If you want 
these elements to be displayed in the folder, ensure that you have also added them to the folder 
view, as described in Section 8.1.3, “Adding Elements to the Folder View,” on page 86.)

4 Populate the elements with the desired information.
For example, create your folder brand, add a folder description, attach any files, and so forth.

5 Click OK.

8.5  Understanding Elements
Elements make up the content of your forms and views. Some elements can be used only once. 

When you are adding elements, remember that when you add an element to a form, you need to add 
that same element to the view in order for it to be displayed in the folder.

You can add the following elements:

Section 8.5.1, “Folder Form Elements,” on page 88
Section 8.5.2, “Folder View Elements,” on page 90

8.5.1  Folder Form Elements
Attachments: Enables you to display uploaded files as an attachment.

Attachments include a thumbnail, and details about the document, such as file size and author.

Branding: Enables you to brand your folder.
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Checkbox: Adds a check box that can be selected or deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

Description: Adds an HTML text editor that enables you to provide a description of the folder.

File Upload: Enables you to upload files.

Group List: Adds an element that enables users to add groups.

Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

HTML Editor Text Area: Adds an HTML text editor where you can compose messages, create 
links, upload pictures, and more. The information that you create in this HTML editor is displayed 
in your folder.

Icon: Enables you to change the folder icon that is displayed in the Navigation panel.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables you to upload a picture to display in your folder.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to display certain applications that have been configured by your 
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 139.

Selectbox: Enables you to display options that users can select.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field that enables you to specify a title for the workspace.

URL: Add a field that converts any text into a hyperlink. 

User List: Adds a field that enables you to specify other Vibe users, using Type-to-Find 
functionality. When you specify a user’s name when you modify the workspace, as described in 
Section 8.4, “Populating Elements in the Folder View,” on page 88, Vibe displays the user’s name 
on the folder home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application through iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “Synchronizing Tasks and Calendar Folders to a 
Desktop Calendar Application” in the Novell Vibe OnPrem 3 User Guide.
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8.5.2  Folder View Elements
Any form element that you create can be added as a view element, if you want it to show up in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this 
panel to add community or personal accessories, depending on their individual rights.

For more information on Accessories, see “Managing Accessories” in the Novell Vibe OnPrem 3 
User Guide.

Discussion Folder: Displays folder entries in the Discussion folder view.

Entry Creation Date: Displays the date and time that an entry was created.

Entry Creator: Displays the creator of an entry.

Entry Creator and Creation Date: Displays who created the entry and when they created it.

Landing Page Layout: Adds a landing page creation form that enables you to create landing page 
elements to display in your folder.

You must add the Landing Page Layout layout option in the folder form before you can add it as a 
view element.

Title: Adds a field that enables you to specify a title for the workspace.

8.6  Understanding Layout Options
Layout options can enhance the presentation of your folder forms and views in Novell Vibe. 

When you are adding layout options to a form, remember that you need to add that same layout 
options to the view in order for it to be displayed in the folder.

You can add the following layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 103.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Use this option if your form is exceptionally long.

Fieldset: Adds a box that can contain other elements.

HTML: Adds HTML formatting.

Landing Page Layout: (For the View Definition, the Landing Page Layout is in the Elements 
section) Adds a landing page creation form that enables you to create landing page elements that you 
can populate when you modify your workspace.
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Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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9
9Designing Custom Folder Entry 
Forms

Folder Entry forms in Novell Vibe OnPrem can be customized to suit your precise business needs. 
You can create your own custom entry forms and views by using the Vibe Form and View Designers 
tool, or you can download existing custom entry forms from the Novell Vibe Library.

Section 9.1, “Downloading Existing Custom Forms and Workflows,” on page 93
Section 9.2, “Creating a Custom Folder Entry Form,” on page 93
Section 9.3, “Modifying an Existing Entry Form,” on page 99
Section 9.4, “Understanding Elements,” on page 100
Section 9.5, “Understanding Layout Options,” on page 102

9.1  Downloading Existing Custom Forms and 
Workflows
The Novell Vibe Library provides a collection of existing Novell Vibe folder entry forms and 
workflows that have been designed to solve specific business problems. You can easily download 
the custom forms and workflows, then import them into your Vibe environment. You can further 
customize these forms and workflows to suit your individual business needs.

1 Go to the Novell Vibe Library Web site (http://www.novell.com/products/teaming/resource-
library/).

2 Select the custom form or workflow that you want to use in your Vibe environment.
3 In the Attachment section, click the zip file to download it.
4 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Library Deployment Instructions 
(http://www.novell.com/communities/node/8359/deployment-instructions-boulder-teaming-2).

9.2  Creating a Custom Folder Entry Form
Novell Vibe enables you to create custom folder entry forms. For example, you can create a custom 
entry form for an expense report.
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To create a new custom workspace, you use the Form and View Desiner to create a view, then you 
create a form with the elements and layout options that you want to display in the view. After the 
form is in place, you add the same elements and layout options to the view, then you can add 
optional view elements to create the final view.

You must have both a form and a view in order to display all the elements that you want in a 
workspace. The form and the view must have a common set of elements and layout options, but the 
view can have some additional elements that are not in the form.

9.2.1  Creating the Folder Entry Form
1 Navigate to the folder or workspace where you want to create the custom entry form.

If you create the entry form in a folder, the form can be applied only to entries in that folder. If 
you create the entry form in a workspace, the form can be applied to entries in any folder in the 
workspace.

2 If you are creating the entry form at the folder level, click Folder > Form/View Designers in the 
Action toolbar.
or
If you are creating the entry form at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.
The Form and View Designers page is displayed.

3 Click New > Entry Definitions.
The Add a New Definition form is displayed.

4 Specify the following information in the Add a New Definition section:
 Vibe OnPrem 3 Advanced User Guide



Caption: Specify a name for the folder entry.
This is the name that appears in the Vibe interface. Users see it when they create an entry of this 
type. (For example, “Expense Report.”)
Name: Specify the internal name for the folder entry.
The name that you enter in this field is not visible to users who create this type of entry. (For 
example, “expense_report.”)
Family: Select the item type that is closest to the function of the item you are creating. Users 
can use the family type when performing filtered searches.
Allowed Comments/Reply Types: Select all of the comments or reply types that you want to 
allow on the entry.
When users comment on this type of entry, they can choose from the options that you specify in 
this section.
To select multiple options, hold the Ctrl key while selecting the comment or reply types.

5 Click OK.
6 Continue with Section 9.2.2, “Adding Elements to the Entry Form Definition,” on page 95.

9.2.2  Adding Elements to the Entry Form Definition
The entry form is what users see when they are creating a new entry. This form needs to contain all 
of the fields necessary for users to create this type of entry. For example, an Expense Report form 
needs to contain the expense code, the purpose for the expense, the cost of the expense, and so forth.

After you add elements and layout options to the entry form, you must then add all of the elements 
and layout options to the entry view in order for them to be displayed when users view the entry. 
(For information on how to add features to the entry view, see Section 9.2.3, “Adding Elements to 
the Entry View Definition,” on page 97.)

To add elements to the form:

1 Under the custom entry form that you created, expand Entry Form Definition, then expand 
Form.
All of the elements and layout options that are currently applied to your form are displayed.
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2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to a Form” on page 96
“Modifying Elements in a Form” on page 96
“Adding Layout Options to a Form” on page 96

Based on the modifications that you make to a form element or option, you might need to make the 
same modifications to the corresponding view element or option.

Adding Elements to a Form

1 Click Form.
2 In the Form window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.4.1, “Entry Form 
Elements,” on page 100.

4 Specify the appropriate information.
5 Click OK.

Modifying Elements in a Form

1 Expand Form, then click the element that you want to modify.
2 In the window on the right side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.

Adding Layout Options to a Form

1 Click Form.
2 In the Form window, on the right side of the page, click Add.
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3 In the Layout Options section, click the layout option that you want to add.
For information on the types of layout options that you can add, see Section 9.5, 
“Understanding Layout Options,” on page 102.

4 Specify the appropriate information.
5 Click OK.

9.2.3  Adding Elements to the Entry View Definition
The entry view is how the information from your entry form is displayed to users who view your 
entry. Every form must have a corresponding view. This view needs to contain all of the fields 
necessary for users to get the information they need when viewing the entry; it is made up of 
elements from the form.

Before you can add elements and layout options to the entry view, you must first add those same 
elements and layout options to the entry form in order for them to be displayed in your entry. (For 
information on how to add features to the entry form, see Section 9.2.2, “Adding Elements to the 
Entry Form Definition,” on page 95.)

To add elements to the view:

1 Under the custom entry form that you created, expand Entry View Definition.

2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to an Entry View Definition” on page 97
“Adding Layout Options to an Entry View Definition” on page 98

Adding Elements to an Entry View Definition

1 Click Entry View Definition.
2 In the Entry View Definition window, on the right side of the page, click Add.
3 In the Standard Form Elements section, click the element that you want to add.
Designing Custom Folder Entry Forms 97



98 Novell
For information on the types of elements that you can add, see Section 9.4.2, “Entry View 
Elements,” on page 101.

4 Specify the appropriate information.
5 Click OK.

Adding Layout Options to an Entry View Definition

1 Click Entry View Definition.
2 In the Entry View Definition window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.5, 
“Understanding Layout Options,” on page 102.

4 Specify the appropriate information.
5 Click OK.

9.2.4  Adding Elements to the Summary View
The summary view is used to display entries in a folder before the entries are opened.

To add elements to the summary view:

1 Under the custom entry form that you created, expand Summary View.

2 Add the desired elements and layout options, as described in the following sections:

“Adding Elements to a Summary View” on page 98
“Adding Layout Options to a Summary View” on page 99

Adding Elements to a Summary View

1 Click Summary View.
2 In the Summary View window, on the right side of the page, click Add.
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3 In the Standard Form Elements section, click the element that you want to add.
For information on the types of elements that you can add, see Section 9.4.2, “Entry View 
Elements,” on page 101.

4 Specify the appropriate information.
5 Click OK.

Adding Layout Options to a Summary View

1 Click Summary View.
2 In the Summary View window, on the right side of the page, click Add.
3 In the Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.5, 
“Understanding Layout Options,” on page 102.

4 Specify the appropriate information.
5 Click OK.

9.3  Modifying an Existing Entry Form
1 Navigate to the folder or workspace where the custom folder entry was created.
2 If the folder entry was created at the folder level, click Folder > Form/View Designers in the 

Action toolbar.
or
If the folder entry was created at the at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.
The Form and View Designers page is displayed.

3 Expand Entry Definitions, then click the custom entry that you want to modify.
4 Continue with Section 9.2.2, “Adding Elements to the Entry Form Definition,” on page 95.
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9.4  Understanding Elements
Elements make up the content of your forms and views. 

When you are adding elements, remember that when you add an element to a form, you need to add 
that same element to the view in order for it to be displayed in the custom form.

You can add the following elements:

Section 9.4.1, “Entry Form Elements,” on page 100
Section 9.4.2, “Entry View Elements,” on page 101

9.4.1  Entry Form Elements
Checkbox: Adds a check box that can be selected and deselected.

Date: Adds a field that launches a calendar applet when users click inside it.

Date and Time: Adds two fields. The first field launches a calendar applet, and the second field 
launches a time-selection applet when users click inside.

Event: Adds fields that enable users to specify the start time and end time of an event.

File Upload: Adds a field that enables users to browse for and upload files.

Form Buttons: Adds the OK and Cancel buttons.

Group List: Adds a type-to-find field that enables users to find and select Vibe groups.

HTML Editor Text Area: Adds an HTML text area where users can compose messages, create 
links, upload pictures, and more.

Hidden Field: Adds a hidden element. When you design the custom form, you can use this element 
to add boilerplate text to every entry that is created. This text is “hidden” because it does not appear 
on the entry form when users are creating an entry; however, the text does appear on the entry view 
after the entry is created.

Icon: Enables the workspace owner to choose an icon to represent the workspace.

Number: Adds a field that requires users to enter a number. Alphabetic characters are rejected.

Picture: Adds a field that enables users to browse for and upload pictures.

Places: Adds a workspace tree that enables users to browse to and select folders.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enables you to choose a remote application to display.

Remote applications must be created and enabled for use by the Vibe administrator.

Selectbox: Enables you to display options that users can select.

Send E-Mail When Entry is Submitted: Adds an option that enables users to automatically send 
an e-mail to other Vibe users, after the entry is submitted.

Subscribe to This Entry: Adds an option that enables users to subscribe to the entry.
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Survey: Adds options that enable users to create a survey.

Team List: Adds a field that enables users to specify teams.

Text: Adds a field where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds a field where users can enter a title for the entry.

URL: Add a field that converts any text into a hyperlink. 

User List: Adds a field that enables users to use the type-to-find functionality to specify other Vibe 
users.

User List Selectbox: Adds a list of users. This list is taken from the user element that is defined at 
the folder level.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to 
another application by using iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “Synchronizing Tasks and Calendar Folders to a 
Desktop Calendar Application” in the Novell Vibe OnPrem 3 User Guide.

9.4.2  Entry View Elements
Any form element that you create can be added as a view element, if you want it to appear in the 
view. 

The following elements are specific to views; they cannot be added to a form.

Attachments: Displays all attachments.

Comments: Displays all comments.

Comments and Attachments Tabs: Displays the Comments and Attachments tabs. Also, where 
applicable, it displays the Entry History and File Versions tabs.

Description: Displays the entry description.

Entry Creation Date: (Not available with a Summary View) Displays the date that the entry was 
created.

Entry Creator: (Not available with a Summary View) Displays who created the entry.

Entry Creator and Creation Date: (Not available with a Summary View) Displays who created 
the entry and when they created it.

Entry Workflow: Displays the workflow process, the state of the workflow process, and any 
actions to be performed on the workflow.

Remote Application: (Not available with a Summary View) Enables you to add custom 
applications that are running on a separate server.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on 
page 139.
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Replies: All replies to an entry are listed here. You can move this section to another location in the 
entry view by moving this element.

Title: Displays the title of the entry.

9.5  Understanding Layout Options
Layout options can enhance the presentation of your forms and views. 

When you are adding layout options, remember that when you add layout options to a form, you 
need to add the same layout options to the view in order for it to be displayed in the custom form.

You can add the following layout options:

Box: Places a box around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in 
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 103.

Divider: Displays a horizontal line between elements.

Expandable Area: Displays an expandable tree element.

Use this option if your form is exceptionally long.

Fieldset: Adds a box that can contain other elements.

HTML: Adds HTML formatting.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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10Using Custom JSP Files to 
Enhance Your Vibe Pages

Novell Vibe OnPrem supports the use of custom JavaServer Pages (JSPs) that can help you modify 
the behavior of certain areas in your Vibe site. For example, your Vibe administrator might enable a 
custom JSP file that enhances the functionality of Vibe landing pages by enabling users to 
participate in a survey directly from a workspace landing page.

Before you can leverage the functionality of custom JSP files, your Vibe administrator must first 
make the files available. Your Vibe administrator will inform you about the names of the files and 
what they can be used for.

Some areas of Vibe, such as landing pages, enable you to add custom JSP files by default. Other 
areas, such as folder and workspace forms and views, first require you to do some additional steps, 
as described in the following sections:

Section 10.1, “Applying JSP Files to a Landing Page,” on page 103
Section 10.2, “Enabling Vibe Forms and Views to Reference JSP Files,” on page 103

10.1  Applying JSP Files to a Landing Page
Landing pages can enhance the presentation of your workspaces and folders and increase the 
accessibility of the information they contain. For more information about landing pages, see 
Chapter 6, “Creating and Managing Landing Pages,” on page 51.

By default, JSP files can be applied to your Novell Vibe landing page. For information on how to 
reference a JSP file from a landing page, see “Adding a Custom JSP” on page 63.

10.2  Enabling Vibe Forms and Views to 
Reference JSP Files

Section 10.2.1, “Applying JSP Files to a Folder Entry Form and View,” on page 103
Section 10.2.2, “Applying JSP Files to a Folder or Workspace View,” on page 104

10.2.1  Applying JSP Files to a Folder Entry Form and View
Folder entry forms are used to add folder entries to all types of Novell Vibe folders. Folder entry 
views are used to display folder entries in all types of Vibe folders. You can create your own folder 
entry forms and views, or modify existing forms and views. For more information, see Chapter 9, 
“Designing Custom Folder Entry Forms,” on page 93.

To enable a folder entry form and view to reference a custom JSP file:

1 Create a new custom folder entry form and view, as described in Section 8.1, “Creating a New 
Custom Folder View,” on page 83.
or
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Modify an existing folder entry form and view, as described in Section 9.3, “Modifying an 
Existing Entry Form,” on page 99.
Only Vibe administrators have the ability to modify default folder entry forms.

2 Add a JSP layout option and element to the folder entry form, as described in Section 8.1.2, 
“Adding Elements to the Folder Add/Modify Form,” on page 84.

3 Specify the following information:
Caption: Specify a name for the custom JSP.
Data Name: Specify an internal name for the custom JSP.
Custom Form JSP: Specify the filename of the custom JSP file.
You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
make JSP files available to be used in the Vibe site.

4 Click OK.

10.2.2  Applying JSP Files to a Folder or Workspace View
Vibe enables you to create custom folder and workspace views. Folder and workspace views define 
what is displayed on the home page of your folder or workspace. When you create custom folder or 
workspace views, you can display optional features such as remote applications, attachments, and 
you can also reference JSP files. For more information, see Chapter 8, “Creating Custom Folder 
Views,” on page 83, and Chapter 7, “Creating Custom Workspace Views,” on page 73.

To enable a folder or workspace view to reference a custom JSP file:

1 Create a new custom folder or workspace view, as described in Section 7.1, “Creating a New 
Custom Workspace View,” on page 73.
or
 Modify an existing folder or workspace view, as described in Section 7.2, “Modifying an 
Existing Workspace View,” on page 77.
Only Vibe administrators have the ability to modify default folder and workspace views.
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2 Add a JSP layout option and element to the folder or workspace view, as described in 
Section 8.1.3, “Adding Elements to the Folder View,” on page 86 or Section 7.1.3, “Adding 
Elements to the Workspace View,” on page 76, depending on whether you are working with a 
folder or workspace view.

3 Specify the following information:
Caption: Specify a name for the custom JSP.
Data Name: Specify an internal name of the custom JSP.
Custom Form JSP: Specify the filename of the custom JSP file.
You must obtain this filename from your Vibe administrator. Only your Vibe administrator can 
make JSP files available to be used in the Vibe site.

4 Click OK.
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11Creating and Managing Workflows

Novell Vibe OnPrem enables you to create custom workflows to streamline important business 
processes. Vibe Administrators can create workflows and implement them across the entire site, and 
individual folder and workspace owners can create workflows to be used in their respective folders 
and workspaces.

After you have created a workflow, you can perform the management functions that are described in 
this section. You can enable workflows to automatically start when certain types of entries are 
created in the folder, when users comment on or reply to an entry, or you can configure them to be 
manually started by users who view the entry.

Examples of workflows include approving documents, ordering supplies, hiring new employees, 
requesting paid time off, and getting expense reimbursements.

Section 11.1, “Creating a Simple Workflow,” on page 107
Section 11.2, “Creating an Advanced Workflow,” on page 113
Section 11.3, “Visually Representing a Workflow,” on page 128
Section 11.4, “Adding Access Controls to a Workflow,” on page 129
Section 11.5, “Downloading Existing Custom Forms and Workflows,” on page 134
Section 11.6, “Workflows Included with Vibe,” on page 134
Section 11.7, “Enabling Workflows,” on page 135
Section 11.8, “Testing A Workflow,” on page 137
Section 11.9, “Importing and Exporting a Workflow,” on page 137

11.1  Creating a Simple Workflow
If you have a straightforward business process that you think might benefit from a workflow, you 
can create a simple workflow to help automate that process, and you don’t need in-depth workflow 
training to do it.

For example, you might want to create a workflow that automates the review process of articles for 
the company magazine. To create a simple workflow such as this, complete the following sections:

Section 11.1.1, “Creating the Workflow Definition,” on page 107
Section 11.1.2, “Adding Workflow States,” on page 108
Section 11.1.3, “Adding Workflow Start and End States,” on page 109
Section 11.1.4, “Adding Manual Transitions,” on page 110
Section 11.1.5, “Sending E-Mail Notifications,” on page 112
Section 11.1.6, “Enabling Your Workflow for Use,” on page 113

11.1.1  Creating the Workflow Definition
1 Navigate to the workspace or folder where you want to create the workflow.
Creating and Managing Workflows 107



108 Novell
You can create workflows at the workspace level or at the folder level. If you create a workflow 
at the workspace level, that workflow can be applied to all sub-folders and sub-workspaces. If 
you create a workflow at the folder level, that workflow can be applied only to that folder, and 
to the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designers in the 
Action toolbar.
or
If you are creating the workflow at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.
The Form and View Designers page is displayed.

3 In the Form and View Designers page, click New > Workflow Processes.
The Add a New Definition form is displayed.

4 Specify the following information:
Caption: Specify a name for the workflow process.
This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Production.”)
Name: Specify the internal name for the workflow process.
The name that you enter in this field is not visible to users who use this workflow. (For 
example, “article_production.”)

5 Click OK.
6 Continue with Section 11.1.2, “Adding Workflow States,” on page 108.

11.1.2  Adding Workflow States
Workflow states are the phases that a workflow goes through as it completes the business process. 

For example, the Article Production workflow contains five states: Article Composition, Peer 
Review, Edit, Manager Approval, Publish.

1 In the Designer page, expand the workflow definition that you created in Section 11.1.1, 
“Creating the Workflow Definition,” on page 107.

2 Click Workflow Process.
3 Click Add.
4 Click State.
5 Specify the following information:
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Caption: Specify a name for the workflow state.
This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Composition.”)
Name: Specify the internal name for the workflow state.
The name that you enter in this field is an internal-use database name. Names for elements in a 
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For 
the rest, you can use alphanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores (_).
Description: Describe the function of the state.

6 Click OK.
7 Repeat Step 2 through Step 6 to add additional workflow states.

The new states are added to the workflow and appear in the Workflow Preview section at the 
bottom part of the window.
For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.

8 Continue with Section 11.2.3, “Adding Workflow Start and End States,” on page 116 for 
information on how you can define start and end states for your workflow.

11.1.3  Adding Workflow Start and End States
Vibe enables you to add a Start and End state to your workflow. This is important, because without 
an End state, a workflow does not officially stop unless you manually stop it. Adding an End state to 
a workflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.
2 In the Workflow process window, specify the following information:

Initial State: Select the Start state of the workflow process.
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End State: Select the End (final) state of the workflow process.
You can select multiple End states by holding the Ctrl key while clicking additional states.
Background Actions Will Run in the Context Of: Select either Entry Owner or Folder 
Owner.

3 Click OK.
In the Workflow Preview section, the Start state is marked with yellow, and the End state is 
marked with red.
For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.

4 Continue with Section 11.1.4, “Adding Manual Transitions,” on page 110 for information on 
how you can create transitions that move an entry from one workflow state to the next.

11.1.4  Adding Manual Transitions
After you have defined the workflow states, you need to create transitions that move an entry from 
one state to the next. The easiest kind of transitions to implement are manual transitions. 

Manual transitions provide a drop-down list in the entry that allows the user to choose when to 
transition the entry. The workflow creator decides which workflow states the user can select in the 
drop-down list.

For example, from the “Article Composition” state, the workflow creator might allow the user to 
transition the entry to either the “Peer Review” or the “Edit” state.

To create manual transitions from one workflow state to the next workflow state:

1 Expand Workflow Process, then expand the workflow state where you want to transition the 
entry from.
For this example, expand the “Article Composition” state.
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2 Click Transitions, then click Add in the Transitions box in the right section of the Designer 
page.

3 Click Manual Transition.
For information regarding the other transition types available, see Section 11.2.4, “Adding 
Transitions,” on page 117.

4 In the To State select box, select the next state in the workflow.
This is the state that users will be allowed to transition the entry to.

5 Click OK.
Repeat Step 2 through Step 5 if you want to allow users to select from multiple states.

6 Repeat this procedure for all other states in the workflow.
In the Workflow Preview section, you see a diagram representing all of your workflow states 
(circles) and transitions (arrows).
For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.
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7 Continue with Section 11.1.5, “Sending E-Mail Notifications,” on page 112.

11.1.5  Sending E-Mail Notifications
Now that you have added your workflow states and specified how the entry will transition through 
those states, you need to set up notifications that inform Vibe users when they need to take action on 
the entry as it moves into a state corresponding with their area of expertise.

For example, Julio composes an article for the company magazine. After he composes the article, he 
transitions the entry to the next workflow state, Peer Review. Anne, Julio’s co-worker, then receives 
an e-mail message notifying her that an article is ready for her to review. After Anne reviews the 
article, she transitions it to the next workflow state, Edit, and so forth.

1 Expand the workflow definition, then click the workflow state where you want the notification 
to be sent.
For example, click Peer Review.

2 Click Add.
3 Click On Entry.
4 In the On Entry box, click OK.
5 Click On Entry. (This is located underneath the workflow state where you just created it.)

In the On Entry box, you can select from many options. These are actions that you can choose 
to perform when the entry enters this workflow state, such as moving the entry to another 
location, copying the entry, or sending notifications. For this basic workflow example, simply 
select to send e-mail notifications. 
For information about all of the options that you can choose to perform when an entry enters a 
workflow state, see Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 121.

6 Click Add > Notifications.
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7 In the Notifications box, specify the following information:
Entry Creator: Select this option if you want to send a notification to the user who created the 
entry.
Team: Select this option if you want to send a notification to the entire team.
Users: Specify individual users to whom you want to send a notification.
Groups: Specify groups to whom you want to send a notification.
Select an Entry Type: Use the drop-down list to select the type of entry that most closely 
represents the type of entry that is going through the workflow.
Text to be Put in the Notification Subject Line: Specify the text that you want to appear in 
the subject line of the notification that is sent.
For example, Peer Review Needed.
Append the Entry Title: (Optional) Select this option if you want the entry title to appear 
after the text in the subject line.
Text to be Put in the Notification Body: Specify text that you want to appear in the main 
body of the e-mail notification. You can also select Append the Entry Body if you want the 
main body of the entry to display with the e-mail notification message.
Any text formatting that you use in this field needs to be done in the HTML format. Following 
are some examples of HTML formatting:

<i></i> for italics
<b></b> for bold
<br> for a break (return/enter)
<p></p> for a new paragraph
<a href=“www.example.com”></a> for links to URLs

Append the Entry Body: (Optional) Select this option if you want the main body of the entry 
to display with the e-mail notification message.

8 Click OK.
9 Repeat this process for every workflow state that needs an e-mail notification message.

11.1.6  Enabling Your Workflow for Use
Now that you have created your workflow, you need to enable it. For information on how to do this, 
see Section 11.7, “Enabling Workflows,” on page 135.

11.2  Creating an Advanced Workflow
This section expands the workflow design presented in Section 11.1, “Creating a Simple Workflow,” 
on page 107. 

For example, you might want to create a workflow that automates the expense reporting process for 
your department.
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Figure 11-1   Advanced Workflow Example

To create this and other advanced workflows, complete the following sections:

Section 11.2.1, “Creating the Workflow Definition,” on page 114
Section 11.2.2, “Adding Workflow States,” on page 115
Section 11.2.3, “Adding Workflow Start and End States,” on page 116
Section 11.2.4, “Adding Transitions,” on page 117
Section 11.2.5, “Setting Up Transition Types,” on page 119
Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 121
Section 11.2.7, “Setting Up On-Entry and On-Exit Events,” on page 122
Section 11.2.8, “Adding a Parallel Workflow Thread,” on page 124
Section 11.2.9, “Chaining Workflows,” on page 125
Section 11.2.10, “Adding a Question to a Workflow,” on page 125
Section 11.2.11, “Enabling Your Workflow for Use,” on page 127

11.2.1  Creating the Workflow Definition
1 Navigate to the workspace or folder where you want to create the workflow.

You can create workflows at the workspace level or at the folder level. If you create a workflow 
at the workspace level, that workflow can be applied to any folder or workspace included in the 
workspace. If you create a workflow at the folder level, that workflow can be applied only to 
that folder, and to the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designers in the 
Action toolbar.
or
If you are creating the workflow at the workspace level, click Workspace > Form/View 
Designers in the Action toolbar.
The Form and View Designers page is displayed.

3 In the Form and View Designers page, click New > Workflow Processes.
The Add a New Definition form is displayed.
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4 Specify the following information:
Caption: Specify a name for the workflow process.
This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Expense Report Workflow.”)
Name: Specify the internal name for the workflow process.
The name that you enter in this field is not visible to users who use this workflow. (For 
example, “expense_report_workflow.”)

5 Click OK.
6 After you define a workflow, you need to add states to your workflow. For information on how 

to do this, continue with Section 11.2.2, “Adding Workflow States,” on page 115.

11.2.2  Adding Workflow States
Workflow states are the phases that a workflow goes through as it completes the business process. 

For example, the Expense Report workflow contains six states: Submit Expense Report, Finance 
Department, Needs Attention, Report Processed, Statistics Department, and Records Department.

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 114.

2 Click Workflow Process.
3 Click Add.
4 Click State.
5 Specify the following information:

Caption: Specify a name for the workflow state.
This is the name that appears in the Vibe interface. Users see it when they use this workflow. 
(For example, “Article Composition.”)
You can use alphanumeric characters (a-z, A-Z, 0-9), dashes (-), underscores (_), and spaces.
Name: Specify the internal name for the workflow state.
The name that you enter in this field is an internal-use database name. Names for elements in a 
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For 
the rest, you can use alphanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores (_).
Description: Describe the function of the state.

6 Click OK.
7 Repeat Step 2 through Step 6 to add additional workflow states.
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The new states are added to the workflow and appear in the Workflow Preview section located 
in the bottom part of the window.
For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.

8 After you have added states to your workflow, you need to define the Start and End states. For 
information on how to do this, see Section 11.2.3, “Adding Workflow Start and End States,” on 
page 116.

11.2.3  Adding Workflow Start and End States
Vibe enables you to add Start and End states to your workflow. This is important, because without 
an End state, a workflow does not officially stop unless you manually stop it. Adding an End state to 
a workflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.
2 In the Workflow process window, click Modify.
3 Specify the following information:

Initial State: Select the Start state of the workflow process.
End State: Select the End (final) state of the workflow process.
You can select multiple End states by holding the Ctrl key while clicking additional states.
Background Actions Will Run in the Context Of: Select either Entry Owner or Folder 
Owner.

4 Click OK.
In the Workflow Preview section, Start states are marked with yellow, and End states are 
marked with red.
For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.
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5 Continue with Section 11.2.4, “Adding Transitions,” on page 117. for information on how to 
create transitions that move an entry from one state to the next.

11.2.4  Adding Transitions
After you have defined the workflow states, you need to create transitions that move an entry from 
one workflow state to the next.

1 Expand Workflow Process, then expand the workflow state that you want to transition the entry 
from.
For this example, expand the “Submit Expense Report” state.

2 Click Transitions, then click Add in the Transitions box in the right section of the Designer 
page.

3 Click the type of transition that you want to add.
Custom Transition: Use this transition if you want to integrate an external process with a Vibe 
workflow. To do this, consult with your Vibe administrator.
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For example, you might want to synchronize a Vibe workflow with an external workflow. You 
can write some custom Java code and use a custom transition to accomplish this. 
Immediate Transition: The entry is immediately transitioned.
Manual Transition: Provides a drop-down list in the entry that allows the user to choose when 
to transition the entry. The workflow creator decides which workflow states the user can select 
in the drop-down list.
Transition After Time Elapsed: The entry is transitioned to the next workflow state after a 
specified amount of time.
Transition on Comment or Reply: The entry is transitioned to the next workflow state after a 
user makes a comment or a reply on the entry.
Transition on Entry Data Values: The entry is transitioned to a new state based on the value 
that a user specifies for a custom element in the entry.
For example:

If you want to assign an entry to a specific state based on a value the user selects, you 
define a custom element with multiple values from which a user can make a selection 
(from a drop-down list on the form). Map each of these values to specific states in the 
initial workflow state by using the Transition on Entry Data Values option. This option is 
useful for assigning help tickets in a help desk, assigning entries to the appropriate review 
contact, and so on.
If you want to transition an entry at a specific time, you can transition the entry based on a 
custom date element.

Transition on Modify: The entry is transitioned to a new state when it is modified.
This can be useful for review purposes.
Transition on Response: Allows you to transition an entry to a new state based on a response 
to a question in the entry. Map each possible answer to a workflow question to one of these 
transitions by using the Data name for each Workflow response. 
For specific instructions on how to do this, see Section 11.2.10, “Adding a Question to a 
Workflow,” on page 125.
Transition on a Variable: You can make decisions based on the value of a variable that you 
set. For example, you could have a process that sends e-mail notifications when it enters a state. 
The process re-enters that same state later in the process, but you do not want to send the 
notifications more than once. Set up that first state so that it sends notifications only if the “sent 
notifications” variable is not true.
Wait for Parallel Thread(s) to End: Allows you to transition an entry to a new state when 
one or more specified parallel workflow threads end.

4 Specify setup options.
After you select a transition type in Step 3, you must set up the transition. Each transition type 
requires you to specify different setup options.
For specific information regarding the information that you need to specify for the individual 
fields, see “Setting Up Transition Types” on page 119.

5 Click OK.
6 Repeat Step 1 through Step 5 for all other states in the workflow.

In the Workflow Preview section, you see a diagram representing all of your workflow states 
(circles) and transitions (arrows).
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For more information on the Workflow Preview section, see Section 11.3, “Visually 
Representing a Workflow,” on page 128.

7 After you have set up how entries transition from one workflow state to another in your 
workflow, you can set up events to occur when the entry enters or exits particular workflow 
states. For information on how to do this, as well as the kinds of entry and exit events that you 
can set up, see Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 121.

11.2.5  Setting Up Transition Types
When you choose a specific type of transition, you might need to provide specific information 
regarding the type of transition that you selected.

Following are the types of transitions that you can choose from, and information describing the 
fields that you must complete in order to set up each type of transition:

“Custom Transition” on page 119
“Immediate Transition” on page 120
“Manual Transition” on page 120
“Transition After Time Elapsed” on page 120
“Transition on Comment or Reply” on page 120
“Transition on Entry Data Values” on page 120
“Transition on Modify” on page 120
“Transition on Response” on page 120
“Transition on a Variable” on page 121
“Wait for Parallel Thread(s) to End” on page 121

Custom Transition

Condition Class Name: Specify the Java filename where your Vibe administrator created the 
custom transition.

Consult with your Vibe administrator to get the name of this file.
Creating and Managing Workflows 119



120 Novell
To State: Select the state where you want to transition the entry.

Immediate Transition

To State: Select the state where you want to immediately transition the entry.

Manual Transition

To State: Select the state where you want to allow users to transition the entry.

After you create the transition, repeat Step 2 on page 117 through Step 5 on page 118 if you want to 
allow users to select from multiple states.

Transition After Time Elapsed

Numbers entered in the following fields must be whole values. Decimal points and fractions are not 
valid.

Days: Specify how many days to wait before the transition.

Hours: Specify how many hours to wait before the transition.

Minutes: Specify how many minutes to wait before the transition.

To State: Select the state where you want to transition the entry after the elapsed time that you 
specified.

Transition on Comment or Reply

To State: Select the state where you want to transition the entry after a user comments on or replies 
to the entry.

Transition on Entry Data Values

Match Entry Data Values: Select Match Any if only one condition needs to be met for the entry to 
transition. Select Match All if all conditions must be met before the entry transitions.

To State: Select the state where you want to transition the entry.

Transition on Modify

To State: Select the state where you want to transition the entry when the entry is modified.

Transition on Response

Workflow Question: Specify the Data Name for the workflow question that you have previously 
defined.

For information on how to create a workflow question, see “Creating the Workflow Question” on 
page 126.

Workflow Response: Specify the Data Name for the workflow response that you have previously 
defined.

For information on how to create a workflow response, see “Creating Answers to the Workflow 
Question” on page 126.
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To State: Select the state where you want to transition the entry after a user responds to the 
workflow question.

Transition on a Variable

Variable Name: Specify the name of the workflow variable that you want to be read to activate the 
transition.

You must have already created a workflow variable. You create a workflow variable as an On Entry 
or On Exit event, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on 
page 121.

Variable Value: Specify the value of the workflow variable that you want to be read to activate the 
transition.

You must have already created a workflow variable. You create a workflow variable as an On Entry 
or On Exit event, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on 
page 121.

To State: Select the state where you want to transition the entry.

Wait for Parallel Thread(s) to End

Parallel Thread Name: Select the parallel thread that you want to wait for.

Transition to State: Select the state where you want to transition the entry after all selected threads 
have ended.

11.2.6  Adding On-Entry or On-Exit Events
You can take action when a process enters or exits a workflow state. For example, when an entry 
enters (or exits) a workflow state, you can send a notification, begin or end a parallel process, set a 
variable, and more.

1 Navigate to and click the workflow state where you want to set up an event to occur when the 
entry enters or exits the state.

2 Click Add.
3 Click On Entry or On Exit, depending on whether you want the event to occur when the entry 

enters or exits the state.
4 In the On Entry (or On Exit) box, click OK.
5 Click On Entry or On Exit, depending on whether you are adding an On Entry or On Exit event. 

(This is located underneath the workflow state where you just created it.)
6 Click Add.
7 Click the type of event that you want to add.

Copy Entry: Allows you to copy an entry to a new location in Vibe when it enters or exits a 
specific state.
Custom Action: Use the custom action if you want to integrate an external process with a Vibe 
workflow. To do this, consult with your Vibe administrator.
Move Entry: Allows you to move an entry to a new location in Vibe when it enters or exits a 
specific state.
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Notifications: Allows you to notify specific users or groups about an entry when it enters or 
exits the state.
Remote Application: Remote applications communicate with a third-party online application, 
and send information from that third-party application back into Vibe. You can enable a remote 
application to start when entries enter or exit a workflow state.
Remote applications need to be set up and configured by your Vibe administrator before you 
can add them.
Start a Parallel Workflow Thread: Allows you to start a parallel workflow when an entry 
enters or exits a specific state. Parallel workflows are useful if two or more processes need to 
occur simultaneously. Only when the parallel thread is finished can the main workflow thread 
proceed.
Before you can start a parallel workflow thread, you first need to create it. For information on 
how to create a parallel workflow thread, see Section 11.2.8, “Adding a Parallel Workflow 
Thread,” on page 124.
Start a Workflow Process: Vibe enables you to chain workflows together. When you are 
creating a workflow (or modifying an existing workflow), you can start an existing workflow 
process on the workflow you are creating (or modifying). This can speed up the workflow 
creation process by helping you make use of existing workflows.
Starting an existing workflow process is not the same as starting a parallel workflow thread. 
Unlike a parallel workflow thread, when you chain workflows together by starting an existing 
workflow process, there is no way to share variables or states between the two workflows; in 
other words, there is no physical connection between the two workflows.
Stop a Workflow Thread: Allows you to stop a parallel workflow when an entry enters or 
exits a specific state.
Workflow Variable: Defines a variable to be used when transitioning a workflow.
This workflow variable is referenced with the Transition On a Variable transition, as described 
in Section 11.2.4, “Adding Transitions,” on page 117.

8 Set up the event you selected in Step 7. Each event type requires you to specify different setup 
options.
For information on what to specify for the individual fields, see Section 11.2.7, “Setting Up 
On-Entry and On-Exit Events,” on page 122.

9 Click OK.
10 Repeat this procedure for all other states in the workflow where you want to set up on-entry or 

on-exit events.
11 Set up access controls on the workflow. For information on how to do this, see Section 11.4, 

“Adding Access Controls to a Workflow,” on page 129.

11.2.7  Setting Up On-Entry and On-Exit Events
After you add an event to a workflow, you need to provide information to set up the event.

“Copy Entry” on page 123
“Custom Action” on page 123
“Move Entry” on page 123
“Notifications” on page 123
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“Remote Applications” on page 124
“Start a Parallel Workflow Thread” on page 124
“Start a Workflow Process” on page 124
“Stop a Workflow Thread” on page 124
“Workflow Variable” on page 124

Copy Entry

Select the Destination Folder: Select the folder where you want to copy the entry to.

Selected Folder: Displays the destination folder that you selected.

Custom Action

Action Class Name: Specify the name of the custom action that your Vibe administrator has set up.

Work with your Vibe administrator for information on what you should put in this field.

Move Entry

Select the Destination Folder: Select the folder where you want to move the entry to.

Selected Folder: Displays the destination folder that you selected.

Notifications

Entry Creator: Select this option if you want to send a notification to the user who created the 
entry.

Team: Select this option if you want to send a notification to the entire team.

Users: Specify individual users to whom you want to send a notification.

Groups: Specify groups to whom you want to send a notification.

Select an Entry Type: Use the drop-down list to select the type of entry that most closely 
represents the type of entry that is going through the workflow.

Text to be Put in the Notification Subject Line: Specify the text that you want to appear in the 
subject line of the notification that is sent.

For example, Peer Review Needed.

Append the Entry Title: (Optional) Select this option if you want the entry title to appear after the 
text in the subject line.

Text to be Put in the Notification Body: Specify text that you want to appear in the main body of 
the e-mail notification. You can also select Append the Entry Body if you want the main body of the 
entry to display with the e-mail notification message.

Any text formatting that you use in this field needs to be done in the HTML format. Following are 
some examples of HTML formatting:

<i></i> for italics
<b></b> for bold
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<br> for a break (return/enter)
<p></p> for a new paragraph
<a href=“www.example.com”></a> for links to URLs

Append the Entry Body: (Optional) Select this option if you want the main body of the entry to 
display with the e-mail notification message.

Remote Applications

Remote Application: From the drop-down list, select the remote application.

Remote applications need to be set up and enabled by your Vibe administrator before you can use 
them. For more information about remote applications, see Chapter 12, “Managing Remote 
Applications,” on page 139.

Variable Name: Specify the name of the variable to contain the results that are returned by the 
remote application.

Execute Action in the Context Of: Select who you want the remote application to be in relation to: 
Active User, Entry Owner, or Folder Owner.

Start a Parallel Workflow Thread

Parallel Thread Name: Select the parallel workflow thread that you want to start.

You must have already created the parallel workflow thread in order for it to be displayed in this list.

For information on how to create a parallel workflow thread, see Section 11.2.8, “Adding a Parallel 
Workflow Thread,” on page 124.

Start a Workflow Process

Workflow Process: From the drop-down list, select the workflow process that you want to start.

Stop a Workflow Thread

Parallel Thread Name: Select the workflow thread that you want to stop.

Workflow Variable

Variable Value: Specify the name of the workflow variable.

Variable Name: Specify the value of the workflow variable. This is the name that is referenced 
internally.

11.2.8  Adding a Parallel Workflow Thread
Vibe workflows support parallel workflow threads, which enable you to start a second workflow 
inside of an existing workflow. Parallel workflows are useful if two or more processes need to occur 
simultaneously. The main workflow is dependent on the parallel workflow thread; only when the 
parallel thread is finished can the main workflow thread proceed.
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To create a parallel workflow thread:

1 Click Workflow Process.
2 Click Add > Parallel Workflow Thread.
3 Specify the following information:

Caption: Specify a name for the parallel workflow thread.
This is the name that appears in the Vibe interface, that users see when they use this workflow 
thread.
Data Name: Specify the internal name for the parallel workflow thread.
The name that you enter in this field is not visible to users who use this workflow thread.
Start State: Select the first state in the parallel workflow thread.
End State: Select the last state in the parallel workflow thread.

4 Click OK.
The parallel workflow thread is created.

For information on how to start and stop a parallel workflow thread after you have created it, see 
Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 121.

11.2.9  Chaining Workflows
Vibe enables you to chain workflows together by starting a workflow process inside of a workflow 
that you are creating (or modifying). This can speed up the workflow creation process by helping 
you make use of existing workflows.

Starting an existing workflow process is not the same as starting a parallel workflow thread. Unlike 
a parallel workflow thread, when you chain workflows together by starting an existing workflow 
process, there is no way to share variables or states between the two workflows; in other words, 
there is no physical connection between the two workflows.

You chain workflows by adding an On Entry or On Exit option to the workflow state where you 
want to add the existing workflow process. Use the On Entry or On Exit option to add the existing 
workflow process, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on 
page 121.

11.2.10  Adding a Question to a Workflow
Workflow questions can enhance the ease and usability of workflows. For example, imagine a Time-
Off Request workflow where a manager can respond to a request by simply selecting Yes or No in 
the workflow. 

In the following example, if the manager selects Yes, the workflow is transferred to the next state of 
the workflow, HR Approval. If the manager selects No, the request is denied and the workflow is 
ended.
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Figure 11-2   Workflow Question Layout

“Creating the Workflow Question” on page 126
“Creating Answers to the Workflow Question” on page 126
“Creating Transitions” on page 127
“Setting Access Controls on a Workflow Question” on page 127

Creating the Workflow Question

1 Click the workflow state where you want to add the workflow question.
A workflow question can be specific to a single state (each state can have only one associated 
question), or you can define a global question, which you can then associate with any number 
of states. Global questions are useful when multiple states require the same question and 
answer set.

2 Click Add > Workflow Question.
3 Specify the following information:

Question Text: Specify the question that you want to appear in the workflow.
For example, Approve time-off request?
Data Name: Specify the internal name for the workflow question.
This name must be unique because it is the name that you use to refer to the workflow question 
in future steps. For example, approve_timeoff_request.

4 Click OK.
5 Continue with “Creating Answers to the Workflow Question” on page 126.

Creating Answers to the Workflow Question

1 Click Workflow Question.
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This is the question that you created in “Creating the Workflow Question” on page 126.

2 Click Add > Workflow Response.
3 Specify the following information:

Response Text: Specify a single response option.
For example, Yes.
Data Name: Specify the internal name for the workflow response.
For example, yes.

4 Click OK.
5 Repeat Step 1 through Step 4 to create multiple answers to the same workflow question.

Users using this workflow can choose from the answers that you create.

Creating Transitions

Now that you have created the workflow question and workflow answers, you need to create 
transitions that correspond to the answers that you created. This kind of transition is called 
“Transition on Response.” For information on how to create a “Transition on Response” transition, 
see Section 11.2.4, “Adding Transitions,” on page 117.

Setting Access Controls on a Workflow Question

If you want to add access controls to this workflow question, you must use the Transition Out of 
This State access control setting. For more information, see Section 11.4, “Adding Access Controls 
to a Workflow,” on page 129.

11.2.11  Enabling Your Workflow for Use
Now that you have created your workflow, you need to enable it. For information on how to do this, 
see Section 11.7, “Enabling Workflows,” on page 135.
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11.3  Visually Representing a Workflow
Novell Vibe enables you to view a visual representation of your workflow, making the creation 
process easier by allowing you to envision the workflow in every step of its development.

As you create your workflow in the Designer section, the changes you make are automatically added 
to the Workflow Preview section below.

Figure 11-3   Workflow Preview Section

You can modify the workflow layout in the Workflow Preview section. You must save the layout 
after you have modified it.

Section 11.3.1, “Modifying a Workflow Layout,” on page 128
Section 11.3.2, “Saving a Workflow Layout,” on page 128

11.3.1  Modifying a Workflow Layout
You can easily modify the visual representation of a workflow. Modifying the workflow layout can 
make it easier to understand how a workflow process works because it can enable you to better 
visualize the process.

1 In the Workflow Preview section, click a workflow state and drag the state to the desired 
location.
Transition arrows automatically adjust to the new locations of the workflow states.

11.3.2  Saving a Workflow Layout
By default, every time you make a change in the Designer section when you create a workflow, any 
changes that you previously made in the Workflow Preview section are reverted to the state when 
you last saved.
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To save your layout in the Workflow Preview section:

1 Click Save Layout after you have modified your workflow layout.
Now, when you make changes in the Designer section, the changes that you previously made to 
your workflow layout in the Workflow Preview section are retained.

11.4  Adding Access Controls to a Workflow
Novell Vibe enables you to set access controls on workflows that you create. You can set access 
controls on an entire workflow, or on the individual states of a workflow.

Section 11.4.1, “Setting Access Controls on an Entire Workflow,” on page 129
Section 11.4.2, “Setting Access Controls on Individual States of a Workflow,” on page 131

11.4.1  Setting Access Controls on an Entire Workflow
1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 

“Creating the Workflow Definition,” on page 114.

2 Click Workflow Process.
3 Click Add > Access controls.
4 Click OK.
5 Expand Workflow Process, then click Access controls.
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6 Click Add.
7 Click the access control setting that you want to add.

Delete Access: Enables you to grant specific users rights to delete entries as they transition 
through the workflow process.
Modify Access: Enables you to grant specific users rights to modify entries as they transition 
through the workflow process.
Modify Specified Fields: Enables you to grant rights to individual users or groups that allow 
the specified users or groups to modify specific fields within an entry as the entry transitions 
through the workflow.
Read Access: Enables you to grant specific users rights to read entries as they transition 
through the workflow process.
Transition Into This State: Enables you to grant specific users rights to transition entries into 
any state in the workflow.
Transition Out of This State: Enables you to grant specific users rights to transition entries 
out of any state in the workflow.
This is the access control setting that determines who can see a workflow question. If you are 
adding a workflow question to your workflow or to an individual state, as described in 
Section 11.2.10, “Adding a Question to a Workflow,” on page 125, and you want to add access 
controls to determine who sees the question, you must use this access control setting.

8 Define the access control setting that you added in Step 7 by specifying the following 
information in the provided form:
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Folder Default Access: Select this option to grant access to all users who have access to the 
folder.
Entry Creator: Select this option to grant access to the user who created the entry.
Team: Select this option to grant access to the team.
Users: Specify individual users to whom you want to grant access.
Groups: Specify groups to whom you want to grant access.
Select an Entry Type: Select the type of entry that most closely represents the type of entry 
that is going through the workflow.
Select Elements within the Entry: Enables you to select elements that are contained in the 
entry. Users associated with that element are granted access.
For example, if you select Task Entry in the Select an Entry Type drop-down list, the options 
that you can select in the Select Elements within the Entry are Assigned to, Assigned to Groups, 
Assigned to Teams.

9 Click OK.

11.4.2  Setting Access Controls on Individual States of a 
Workflow

1 In the Designer page, expand the workflow definition that you created in Section 11.2.1, 
“Creating the Workflow Definition,” on page 114.
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2 Expand Workflow Process, then click the state where you want to add the access controls.

3 Click Add > Access controls.
4 Click OK.
5 Expand the state where you just added the access controls, then click Access controls.
6 Click Add.
7 Click the access control setting that you want to add.

Delete Access: Enables you to grant specific users rights to delete entries when they are in this 
workflow state.
Modify Access: Enables you to grant specific users rights to modify entries when they are in 
this workflow state.
Modify Specified Fields: Enables you to grant specific users rights to modify specific fields 
within an entry as they transition through the workflow.
Read Access: Enables you to grant specific users rights to read entries when they are in this 
workflow state.
Transition Into This State: Enables you to grant specific users rights to transition entries into 
this state.
Transition Out of This State: Enables you to grant specific users rights to transition entries 
out of this state.
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8 Define the access control setting that you added in Step 7 by specifying the following 
information in the provided form:
Folder Default Access: Select this option to grant access to users who have access to the 
folder.
Entry Creator: Select this option to grant access to the user who created the entry.
Team: Select this option to grant access to the team.
Users: Specify individual users to whom you want to grant access.
Groups: Specify groups to whom you want to grant access.
Select an Entry Type: Select the type of entry that most closely represents the type of entry 
that is going through the workflow.
Select Elements within the Entry: Select the fields that are contained within the selected 
entry type that you want to allow specific users or groups to modify.
Only calendar entry types and task entry types allow you to grant access control rights to 
individual elements within the entry. Furthermore, access control rights can only be granted for 
the User List, Group List, and List elements. (For Calendars, this is the Attendee, Attendee 
Groups, and Attendee Teams fields. For tasks, this is the Assigned to, Assigned to Groups, and 
Assigned to Teams fields.)

9 Click OK.
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11.5  Downloading Existing Custom Forms and 
Workflows
The Novell Vibe Library provides a collection of existing Vibe folder entry forms and workflows 
that have been designed to solve specific business problems. You can easily download the custom 
forms and workflows, then import them into your Vibe environment. You can further customize 
these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Library Web site (http://www.novell.com/products/teaming/
resource-library/).

2 In the Forms and Workflows tab, select the custom form or workflow that you want to use in 
your Vibe environment.

3 In the Attachment section, click the zip file to download it.
4 Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Library Deployment Instructions 
(http://www.novell.com/communities/node/8359/deployment-instructions-boulder-teaming-2).

11.6  Workflows Included with Vibe
Novell Vibe includes three predefined workflows. One is available for you to enable and use; the 
others are used within Vibe.

Section 11.6.1, “Available Workflows,” on page 134
Section 11.6.2, “Internal Workflows,” on page 135

11.6.1  Available Workflows
Vibe currently includes the Publish workflow, which is functional as soon as you enable it, as 
described in Section 11.7, “Enabling Workflows,” on page 135.

You can use the Publish workflow in the following ways:

Publish Entries to a Landing Page: You can use the Publish workflow to publish entries to a 
landing page, without manually modifying the contents of the landing page.

For more information, see Section 6.6, “Automatically Displaying the Newest Folder Entries on 
Your Landing Page,” on page 65.

Keep Entries Private: You can use the Publish workflow to keep entries private until you are ready 
to publish them for other Vibe users to read.

For example, you can associate the Publish workflow with a certain entry type in a folder (see 
Section 11.7.1, “Enabling Workflows to Start When an Entry Is Created,” on page 136 for more 
information). When you create an entry in the folder, the entry is created as Private. When you are 
ready for other Vibe users to view the entry, you can change the workflow status to Publish. 

To transition the workflow status of an entry from Private to Publish:

1 Open the entry, and in the Transition to field, select Publish in the drop-down list.
2 Click OK.
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To make the workflow status of the entry Private again:

1 Open the entry where you want to change the workflow status.
2 In the Entry toolbar, click Workflow > Stop Workflow: Publish Workflow, then click OK when 

you are asked if you really want to stop the workflow.
3 In the Entry toolbar, click Workflow > Start Workflow: Publish Workflow, then click OK when 

you are asked if you really want to start the workflow.
The workflow status of the entry is now Private.

11.6.2  Internal Workflows
Vibe includes two workflows that are used internally.

“Using the Task Workflow” on page 135
“Using the Calendar Workflow” on page 135

Using the Task Workflow

Vibe uses the Task workflow internally to allow all users who are assigned to a particular task to 
make modifications to the task, if they are not members of the workspace where the task resides.

This workflow should not be manually added to any workspace or folder.

Using the Calendar Workflow

Vibe uses the Calendar workflow internally to allow all users who are attendees in an event to make 
modifications to the calendar event, if they are not members of the workspace where the event 
resides.

This workflow should not be manually added to any workspace or folder.

11.7  Enabling Workflows
After a workflow is created, you can enable the workflow to automatically start when certain types 
of entries are created in the folder, or when users comment on or reply to entries. Or, you can enable 
users to manually start workflows when they view the entry.

Before you can enable a workflow, the workflow must first be created. For information on how to 
create a workflow, see either Section 11.1, “Creating a Simple Workflow,” on page 107 or 
Section 11.2, “Creating an Advanced Workflow,” on page 113, depending on the type of workflow 
that you want to create.

You can enable workflows only in folders for which you have appropriate rights. When you enable a 
workflow in a folder, it is automatically enabled on all sub-folders and sub-workspaces, and can be 
applied to all entries that are created in that folder and its sub-folders.

Section 11.7.1, “Enabling Workflows to Start When an Entry Is Created,” on page 136
Section 11.7.2, “Enabling Workflows to Start When Users Comment on or Reply to an Entry,” 
on page 136
Section 11.7.3, “Allowing Users to Manually Start Workflows,” on page 137
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11.7.1  Enabling Workflows to Start When an Entry Is Created
You can enable a workflow to automatically start on all entries that are created in a specific folder, 
whenever an entry is created. This is called “associating workflows with entries.”

1 Navigate to the folder where you want to enable the workflow.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Workflows Associations section, in the Entry Types section, click the drop-down list next 

to the entry type that you want to associate the workflow with, then select the desired 
workflow.
To add workflows to this drop-down list, you need to create them. After workflows have been 
created at this folder level, or at a higher workspace level, they appear in this list. For 
information on how to create workflows, see either Section 11.1, “Creating a Simple 
Workflow,” on page 107 or Section 11.2, “Creating an Advanced Workflow,” on page 113, 
depending on the type of workflow that you want to create.

4 Click Apply > Close.
Now, when this type of entry is created in this folder, Vibe automatically starts the workflow by 
placing the entry in the initial state of the workflow process that you specified.

When you enable a folder to support multiple entry types, you can associate workflows to the 
specific types of entries. For example, if you have a folder that supports both file entries and 
calendar entries, you can have one kind of workflow start when you create a file entry, and another 
kind of workflow start when you create a Calendar entry. For information on how to enable multiple 
entry types in a single folder, see Section 3.2.1, “Enabling Alternate Folder Entry Types,” on 
page 26.

11.7.2  Enabling Workflows to Start When Users Comment on or 
Reply to an Entry
You can enable a workflow to automatically start when users comment on or reply to an entry. This 
is called “associating workflows with comments or replies.”

1 Navigate to the folder where you want to enable the workflow.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Workflows Associations section, in the Comment or Reply Types section, click the drop-

down list next to the comment or reply type that you want to associate the workflow with, then 
select the desired workflow.
To add workflows to this drop-down list, you need to create them. After workflows have been 
created at this folder level, or at a higher workspace level, they appear in this list. For 
information on how to create workflows, see either Section 11.1, “Creating a Simple 
Workflow,” on page 107 or Section 11.2, “Creating an Advanced Workflow,” on page 113, 
depending on the type of workflow that you want to create.
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4 Click Apply > Close.
Now, when this type of comment or reply is made to an entry in this folder, Vibe automatically 
starts the workflow by placing the entry in the initial state of the workflow process that you 
specified.

11.7.3  Allowing Users to Manually Start Workflows
You can allow users to decide if they want to start a workflow on an entry, and if they do, at what 
point they want to start the workflow. Also, you can give users the option to choose among multiple 
workflows for each entry.

1 Navigate to the folder where you want to enable users to start the workflows.
2 Click Folder > Configure in the Action toolbar.

The Configure Default Settings page is displayed.
3 In the Allowed Workflows section, select the workflows that you want to allow users to choose 

from.
The Local Definitions section in the Allowed Workflows section displays all of the workflows 
that you have created locally. The other workflows listed in the Allowed Workflows section 
were either created by your Vibe administrator, by another user at a higher level in the 
workspace tree, or are included with the Vibe product.

4 Click Apply > Close.
Now, when users create entries in this folder, they can start and stop workflows as they desire. 
For information on how to start and stop a workflow, see “Using Workflows” in the Novell Vibe 
OnPrem 3 User Guide.

11.8  Testing A Workflow
To test a workflow, simply create the workflow in a testing workspace and ensure that it works 
according to your specifications. When the workspace is ready to be deployed in a production 
environment, export the workflow, then import it into the production workspace where you want to 
deploy it.

For information on how to import and export a workflow, see Section 11.9, “Importing and 
Exporting a Workflow,” on page 137.

11.9  Importing and Exporting a Workflow
Novell Vibe enables you to import and export workflows into and out of Vibe.

Section 11.9.1, “Importing a Workflow,” on page 137
Section 11.9.2, “Exporting a Workflow,” on page 138

11.9.1  Importing a Workflow
1 Navigate to the workspace where you want to import the workflow.
2 Click Workspace > Form/View Designers in the Action toolbar.
3 Click Import.
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The Import Definitions page is displayed.
4 Click Browse.
5 Browse for and select the workflow that you want to import.
6 Click OK > Close.

11.9.2  Exporting a Workflow
1 Navigate to the workspace where you created the workflow.
2 Click Workspace > Form/View Designers.
3 Click Export.

The Export Definitions page is launched.
4 Expand Workflow Processes, then select the workflow that you want to export.
5 Click OK.
6 Select the location where you want to save the workflow, then save it.
 Vibe OnPrem 3 Advanced User Guide



12
12Managing Remote Applications

Remote applications communicate with a third-party, online application, and send information from 
the third-party application back into Novell Vibe OnPrem. 

For example, your Vibe administrator could create a remote application for Twitter that displays all 
of your Twitter entries in Vibe. 

Remote applications are vastly customizable, and are set up by your Vibe administrator. Talk with 
your Vibe administrator if you have a request for a new remote application.

This section describes how to set up remote applications after they have already been created and 
enabled by your Vibe administrator. 

Section 12.1, “Adding Remote Applications to Views and Forms,” on page 139
Section 12.2, “Setting Up a Remote Application,” on page 140
Section 12.3, “Setting Up Multiple Remote Applications on a Single Page,” on page 142
Section 12.4, “Managing Access Controls for Remote Applications,” on page 143

12.1  Adding Remote Applications to Views and 
Forms
Novell Vibe enables you to add a Remote Application element to a folder or workspace view or a 
custom form. The Remote Application element is a drop-down list that enables users of the view or 
form to select from a list of remote applications. This is useful if the current view or form does not 
allow you to select a remote application to run; it is also useful if you want to run multiple remote 
applications in a single view or form. (For specific information on configuring a view or form to run 
multiple remote applications, see Section 12.3, “Setting Up Multiple Remote Applications on a 
Single Page,” on page 142.)

Unless you are the Vibe administrator, you can perform the following procedure only on custom 
views and forms for which you have appropriate rights. You can create custom views and forms for 
workspaces, folders, or entries, as described in Chapter 7, “Creating Custom Workspace Views,” on 
page 73, Chapter 8, “Creating Custom Folder Views,” on page 83, and Chapter 9, “Designing 
Custom Folder Entry Forms,” on page 93.

To add a Remote Application element to a view or form:

1 Navigate to the workspace or folder where you want to add the Remote Application element.
If you want to add the Remote Application element to a form, navigate to the workspace or 
folder where the form was created.

2 Click Workspace > Form/View Designers if the form was created at the workspace level.
or
Click Folder > Form/View Designers if the form was created at the folder level.
The Form and View Designers page is displayed.
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3 Click the entry definition, folder view, or workspace view where you want to add the Remote 
Application element.

4 Add the Remote Application element to the desired folder view, workspace view, or entry 
definition, as described in the following sections:
Folder View: Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 84.
Workspace View: Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on 
page 74.
Entry Definition (Form): Section 9.2.2, “Adding Elements to the Entry Form Definition,” on 
page 95.

12.2  Setting Up a Remote Application
Section 12.2.1, “Setting Up a Remote Application in a Workspace,” on page 140
Section 12.2.2, “Setting Up a Remote Application as an Accessory,” on page 140

12.2.1  Setting Up a Remote Application in a Workspace
1 Navigate to the workspace or folder where you want to display the remote application.
2 Click Workspace > Edit Workspace, or Folder > Edit Folder.
3 In the Remote Application section, click the drop-down list and select the remote application 

that you want to enable.
4 Click OK.

The remote application is displayed at the top of the folder or workspace.

12.2.2  Setting Up a Remote Application as an Accessory
Novell Vibe allows you to set up remote applications as accessories. You might want to do this if 
you want to view more than one remote application on a single Vibe page.
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This section describes how to create an accessory that references a remote application.

1 Navigate to the page where you want to create the Remote Application accessory.
2 Locate the Accessory Panel, then click Accessory Panel.

3 Click Add an Accessory.

4 Select the scope of the accessory you want to create, then select Remote Application.
5 Click OK.
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6 Specify a title for the accessory, then use the Remote Application drop-down menu to select the 
remote application that you want to add.

7 Click Apply > Close.
The new accessory is displayed.

12.3  Setting Up Multiple Remote Applications on 
a Single Page
You can use either of the following methods to set up multiple remote applications on a single 
Workspace or Folder.

Section 12.3.1, “Launching a Remote Application as an Accessory,” on page 142
Section 12.3.2, “Creating a New Workspace or Folder View That Supports Multiple Remote 
Applications,” on page 142

12.3.1  Launching a Remote Application as an Accessory
If you want to view more than one remote application on a single Novell Vibe page, you can set up 
one remote application in your workspace, and then you can view subsequent remote applications as 
accessories.

For more information on viewing remote applications as accessories, see Section 12.2.2, “Setting 
Up a Remote Application as an Accessory,” on page 140.

12.3.2  Creating a New Workspace or Folder View That 
Supports Multiple Remote Applications
If you don’t want your remote application to be displayed as an accessory, but you still want to 
enable multiple remote applications on a single page, you can accomplish this by creating a new 
view for the workspace or folder where you want the remote applications to be displayed, and then 
configuring the workspace or folder to support the new view.

“Creating the New View” on page 142
“Configuring the Workspace or Folder to Support the New View” on page 143
“Using the New View to Enable a Remote Application” on page 143

Creating the New View

1 In the Workspace or Folder where you want to enable additional remote applications, click 
Workspace > Form/View Designers or Folder > Form/View Designers.
The Form and View Designers page is launched.

2 Click New > Folder Views or Workspace Views, depending on whether you are working in a 
workspace or folder.

3 Provide a caption and a name for the new definition. 
4 Select the type of workspace for which you want to create the new definition.
5 Click OK.
6 Click the Workspace Add/Modify Form link.
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7 In the box on the right side of the page, click Add.
8 In the Form Elements section, click Remote Application.
9 Provide a caption and a name for the new remote application field that you’re creating.

The text that you enter in the Caption field is what the remote application field is called in the 
workspace or folder form.

10 Click OK.
11 Click Close to exit the Form and View Designer.

Configuring the Workspace or Folder to Support the New View

1 Navigate to the workspace or folder where you want to implement the new definition that you 
created in “Creating the New View” on page 142.

2 Click Workspace > Configure or Folder > Configure.
3 In the Default View section, select the new definition that you created in “Creating the New 

View” on page 142.
4 Click Apply > Close.

Using the New View to Enable a Remote Application

Now that you have created the new definition and configured the workspace or folder to support it, 
you need to enable the additional remote application.

To enable the additional remote application, see Section 12.2, “Setting Up a Remote Application,” 
on page 140.

12.4  Managing Access Controls for Remote 
Applications
Because not all remote applications can be completely trusted, it is often a good idea to limit the 
privileges of the remote application. Because Novell Vibe administrators are responsible for creating 
and enabling the remote application for the Vibe site, they are also responsible for setting up access 
controls on the remote application.

Before you modify the access control settings of remote applications for a specific workspace or 
folder, you should consult with your Vibe administrator to ensure that what you plan to do is safe.

When an application is restricted to a specific role, the application can use Web services to perform 
only those tasks that are allowed for that role. For example, the Participant role can create new 
entries, modify entries that the user created, add comments to entries, and so on. Participants cannot 
perform system administration tasks and cannot modify other users’ entries.

To limit the remote application to privileges assigned to a specific role:

1 Navigate to the folder or workspace where you want to set the access control settings on the 
remote application.

2 Click Workspace > Access Control or Folder > Access Control.
3 On the Configure Access Control page, click Add an Application.
Managing Remote Applications 143



144 Novell
4 In the Add an Application field, use type-to-find to specify and select the application that you 
want to add.

5 Close the Add an Application panel by clicking the X in the upper right corner.
6 In the access control table, select the check box that is located in the row of the remote 

application that you just added, and the column of the role that you want to assign to the 
application.

7 Click Save Changes > Close.

The application that you added is now restricted to those operations allowed for the role that you 
selected. For example, if you assigned the Participant role to the remote application, then the 
inheritance of workspace and folder access controls means that it is very likely that most workspaces 
and folders inherit this setting. Assuming that all places inherited this setting, the most powerful role 
the remote application can assume within the installation is that of a Participant.

If you are not sure what access control settings to assign to a particular remote application, consult 
with your Vibe administrator.

If your Vibe administrator has enabled multiple applications for your site, some of these applications 
might be grouped together in an Application Group. Application Groups are similar to groups that 
contain usernames. Application groups contain the names of registered applications. After your Vibe 
administrator defines application groups, you as a workspace and folder owner can assign access-
control roles to groups of applications instead of assigning roles to one application at a time.
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13Managing Your Data Quota

Because administrators can set a quota on the amount of data individual users can add to the Novell 
Vibe OnPrem site, you can view your current data usage, so you know when you are approaching 
your allotted data quota. If you meet your allotted quota, Vibe enables you to purge files and 
attachments that you have previously deleted. 

Deleted files and attachments count toward your data quota until they are purged. Workspaces, 
folders, and entries that do not contain files and attachments do not count toward your data quota.

Section 13.1, “Viewing Your Data Quota,” on page 145
Section 13.2, “Adding Files and Attachments to the Vibe Site When You Are Over Your 
Quota,” on page 146
Section 13.3, “E-Mailing Files and Attachments to the Vibe Site When You Are Over Your 
Quota,” on page 146
Section 13.4, “Using Mirrored Folders When You Are Restricted by a Data Quota,” on 
page 147
Section 13.5, “Adding Files Through WebDAV When You Are Restricted by a Data Quota,” on 
page 147
Section 13.6, “Working with File Versions When You Are Restricted by a Data Quota,” on 
page 147
Section 13.7, “Making Disk Space Available by Purging Deleted Items,” on page 147

13.1  Viewing Your Data Quota
If your administrator has set a data quota and if you are an active contributor to your Novell Vibe 
site, you might want to periodically view your current data quota to ensure that you are not 
approaching the limit.

To view your current data quota and how much you are currently using:

1 Navigate to the home page of your personal workspace.
2 Click the Profile link, located next to your name.
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3 Your data quota is displayed in the upper right corner of the Profile page, along with how much 
of the quota you are currently using.

If you have exceeded your allotted data quota, you should purge the items that you have previously 
deleted, as discussed in Section 13.7, “Making Disk Space Available by Purging Deleted Items,” on 
page 147.

13.2  Adding Files and Attachments to the Vibe 
Site When You Are Over Your Quota
If you have exceeded your data quota but you still need to add files and attachments to the Novell 
Vibe site, you need to decrease your disk usage by purging files and attachments that you have 
previously deleted.

For information on how to purge deleted items, see Section 13.7, “Making Disk Space Available by 
Purging Deleted Items,” on page 147.

13.3  E-Mailing Files and Attachments to the Vibe 
Site When You Are Over Your Quota
Novell Vibe enables you to add files and entry attachments to the Vibe site via e-mail, as described 
in “Adding Entries to a Folder Via E-Mail” in the Novell Vibe OnPrem 3 User Guide. However, if 
you have met your data quota, you are unable to e-mail entries to Vibe if they include attachments.
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If you have exceeded your allotted data quota, you should purge the items that you have previously 
deleted, as discussed in Section 13.7, “Making Disk Space Available by Purging Deleted Items,” on 
page 147.

13.4  Using Mirrored Folders When You Are 
Restricted by a Data Quota
Files stored in mirrored file folders do not count against your data quota because they are not 
uploaded into the Novell Vibe site.

For more information on mirrored folders, see Section 3.5, “Working with Mirrored Folders,” on 
page 30.

13.5  Adding Files Through WebDAV When You 
Are Restricted by a Data Quota
When you add files to the Novell Vibe site through WebDAV, the files still count against your data 
quota, just as if you had added the files through the regular Vibe interface.

13.6  Working with File Versions When You Are 
Restricted by a Data Quota
Novell Vibe enables you to create multiple versions of the same file, as described in “Using Version 
Control with Files” in the Novell Vibe OnPrem 3 User Guide.

When you edit a document in Vibe, Vibe creates a new version of the file. This new version counts 
against the data quota of the user who edited the file; it does not count against the quota of the user 
who originally posted the file.

You can manage your data quota by deleting previous versions of a file that you no longer need. For 
information about how to delete prevsious file versions, see “Deleting Existing Versions of a File” in 
the Novell Vibe OnPrem 3 User Guide.

IMPORTANT: When you use OpenOffice to edit a document in Vibe, a new version of the 
document is created each time you click Save. Because each version of a document counts against 
your data quota, you should save the document only once if you are using OpenOffice as an editor.

When you use Microsoft Office, Vibe creates only one version when you save the document. 
Clicking Save multiple times does not create multiple versions, as is the case when you edit 
documents with OpenOffice.

13.7  Making Disk Space Available by Purging 
Deleted Items
Files and attachments that have been deleted but not yet purged still count toward your data quota. 
Workspaces, folders, and entries that do not contain files and attachments do not count toward your 
data quota. If you have reached your allotted data quota, you need to purge deleted files and 
attachments.

You can purge any item that you have rights to delete.
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NOTE: Purged items cannot be recovered. When you purge items from the Vibe site, remember the 
following:

Purging an entry also purges all attached files, comments, and replies.
Purging a folder also purges all entries and sub-folders that are associated with that folder.
Purging a workspace also purges all folders, sub-folders, and entries that are associated with 
that workspace.

1 Navigate to the folder or workspace where the deleted item that you now want to purge 
previously resided.
For example, if you want to purge a file entry that was in your personal Files folder, navigate to 
the Files folder in your personal workspace.
If you want to see everything that has been deleted in the Vibe site, navigate to the highest level 
workspace. (By default this is the Home Workspace directory.)

2 Click the Trash icon , located in the Navigation panel.
The Trash page displays all workspaces, folders, and entries that have been deleted in or below 
the current workspace or folder.

3 Select the file entry or any other type of entry that contains an attachment that you want to 
purge.

4 Click Purge > OK.
The item is purged from the Vibe site.
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14Restoring Deleted Items

Novell Vibe OnPrem enables you to undelete a workspace, folder, or entry that you previously 
deleted, restoring it to its previous location. When you undelete an entry, all associated attachments, 
comments, and replies are also undeleted.

You cannot undelete an item that has been purged.

Section 14.1, “Rights Associated with Undeletion,” on page 149
Section 14.2, “Undeleting Workspaces, Folders, and Entries,” on page 149
Section 14.3, “Undeleting Mirrored Files,” on page 150
Section 14.4, “Undeleting Items That Contain Workflows,” on page 150
Section 14.5, “Locating Deleted Items,” on page 150

14.1  Rights Associated with Undeletion
As a general rule, if you have rights to delete an item in Novell Vibe, you also have rights to 
undelete that item.

Remember the following when undeleting:

You can undelete an item that another user deleted, if you have appropriate rights.
If you have rights to undelete an entry, but do not have rights to undelete the folder that 
contains the entry, you cannot undelete the entry.
If you have rights to undelete a folder, but do not have rights to undelete the workspace that 
contains the folder, you cannot undelete the folder.
When you undelete a folder, the contents of the folder are not automatically undeleted. You 
need to undelete the contents of the folder separately.
When you undelete an entry in a deleted folder, the folder is automatically undeleted. However, 
if you do not have rights to undelete the folder, you cannot undelete the entry.

14.2  Undeleting Workspaces, Folders, and 
Entries
If you have the appropriate rights, you can undelete any workspace, folder, or entry and restore it to 
its previous location.

1 Navigate to the folder or workspace where the deleted workspace, folder, or entry previously 
resided.
For example, if you want to restore a Blog folder that was in your personal workspace, navigate 
to your personal workspace.
If you want to see everything that has been deleted in the Novell Vibe site, navigate to the 
highest level workspace. (By default this is the Home Workspace directory.)

2 Click the Trash icon , located in the Navigation panel.
Restoring Deleted Items 149



150 Novell
The Trash page displays all workspaces, folders, and entries that have been deleted in or below 
the current workspace or folder.

3 Select the workspace, folder, or entry that you want to undelete.
4 Click Restore.

The workspace, folder, or entry is restored to its previous location.

14.3  Undeleting Mirrored Files
Undeleting files that have been deleted through a mirrored folder is not supported in Novell Vibe. 
Files that are deleted through a mirrored folder cannot be recovered.

14.4  Undeleting Items That Contain Workflows
When you undelete a workspace or folder where a workflow has been created, the workflow is also 
restored with the workspace or folder. 

When you undelete a folder entry where a workflow has been enabled, the entry is restored with the 
workflow still enabled. The entry is in the same workflow state as it was when it was deleted.

14.5  Locating Deleted Items
If you cannot find an item in your Novell Vibe site that you know was there previously, it has 
probably been deleted.

To locate the deleted item, you can do either of the following:

Perform a search for the deleted item, as described in “Searching for Deleted Items” in the 
Novell Vibe OnPrem 3 User Guide.
Navigate to the folder or workspace where the item previously resided, and click the Trash icon 

 located in the Navigation panel, as described in Section 14.2, “Undeleting Workspaces, 
Folders, and Entries,” on page 149.
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15Using Vibe on Your Mobile Phone

Mobile access to the Novell Vibe OnPrem site can be deactivated by your Vibe administrator. If you 
are unable to access the Vibe mobile interface as described in this section, consult your Vibe 
administrator.

Section 15.1, “Supported Mobile Devices,” on page 151
Section 15.2, “Browser Requirements,” on page 151
Section 15.3, “Getting Started,” on page 151
Section 15.4, “Supported Features,” on page 153
Section 15.5, “Features that Are Not Supported in the Vibe Mobile Interface,” on page 159
Section 15.6, “Security Considerations,” on page 160
Section 15.7, “Troubleshooting Your Mobile Device,” on page 160

15.1  Supported Mobile Devices
The Novell Vibe mobile interface is supported on the following mobile devices:

iPhone
BlackBerry
Any other mobile device that provides an HTTP/HTML-based interface

Ensure that your device’s browser meets the requirements that are discussed in Section 15.2, 
“Browser Requirements,” on page 151.

15.2  Browser Requirements
To use Novell Vibe from a mobile device, your device’s browser must support: 

HTML 4
JavaScript

15.3  Getting Started
Use the following information to help you access Novell Vibe from your mobile device, and learn 
basic navigation:

Section 15.3.1, “Accessing the Vibe Mobile Interface,” on page 151
Section 15.3.2, “Navigating to the Home Page of the Mobile Interface,” on page 152

15.3.1  Accessing the Vibe Mobile Interface
1 On your mobile device, launch a Web browser such as Mozilla Firefox or Internet Explorer.
2 Specify the URL of your corporation’s Vibe site.

For example, http://host:port.
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Vibe automatically detects that you are using a mobile device, and directs you to the Vibe 
mobile interface.
If Vibe displays the regular Vibe interface instead of the mobile interface, add /mobile to the 
end of the Vibe URL, as discussed in “Your Browser Does Not Automatically Direct You to the 
Mobile Interface” in “Troubleshooting” in the Novell Vibe OnPrem 3 User Guide.

3 Specify your username and password, then select Sign In.
The mobile home page is displayed.

15.3.2  Navigating to the Home Page of the Mobile Interface
Regardless of where you are in the Vibe mobile interface, you can easily navigate to the home page.

1 Select Home in the Navigation toolbar at the top of the mobile interface.
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The home page is displayed.

15.4  Supported Features
Section 15.4.1, “Searching the Mobile Interface,” on page 153
Section 15.4.2, “Viewing Your Teams,” on page 155
Section 15.4.3, “Viewing Your Favorite Places,” on page 155
Section 15.4.4, “Viewing Your Recent Places,” on page 155
Section 15.4.5, “Viewing File Entries and Attachments,” on page 155
Section 15.4.6, “Viewing YouTube Videos,” on page 155
Section 15.4.7, “Viewing What’s New,” on page 156
Section 15.4.8, “Viewing What’s Unread,” on page 156
Section 15.4.9, “Viewing the Workspace Tree,” on page 157
Section 15.4.10, “Calling Vibe Users with One Click (iPhone Only),” on page 157
Section 15.4.11, “Sending E-Mail,” on page 157
Section 15.4.12, “Following People and Places of Interest,” on page 158
Section 15.4.13, “Transitioning Entries from One Workflow State to Another,” on page 159
Section 15.4.14, “Using Folders,” on page 159

15.4.1  Searching the Mobile Interface
The Novell Vibe mobile interface enables you to search for people, places, entries, and attachments.

Advanced Search is not supported in the mobile interface. However, you can save an advanced 
search when you access Vibe from your workstation, then use it on your mobile device.

“Performing a Basic Search” on page 154
“Using a Saved Search” on page 154
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Performing a Basic Search

To perform a basic search in the Vibe mobile interface:

1 Select Search in the Navigation toolbar at the top of the mobile interface.
The Search drop-down menu is displayed.

2 In the drop-down list, select the category for which you want to search.
For example, you can search for People, Places, or All.

3 Select whether you want to search the entire Vibe site, or only the workspace that you currently 
are in.

4 Specify the words or phrases that you want to search for, then select OK.
The Search results page is displayed.

Using a Saved Search

Vibe enables you to perform saved searches that you have previously created and saved when 
accessing the Vibe site from your workstation.

TIP: Even though the Vibe mobile interface does not have an Advanced search, you can create and 
save an Advanced search when you access the Vibe site from your workstation. You can then use the 
saved search on your mobile device.

For information on how to create a saved search, see “Saving and Reusing Searches” in the Novell 
Vibe OnPrem 3 User Guide.

For information on how to save an Advanced Search when accessing the Vibe site from your 
workstation, see “Using Advanced Search” in the Novell Vibe OnPrem 3 User Guide.

To access and use a saved search from the Vibe mobile interface:

1 Select Search in the Navigation toolbar at the top of the mobile interface.
2 In the Saved Searches section, select the saved search that you want to run.

The Search Results page displays the results for your saved search.
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15.4.2  Viewing Your Teams
You can quickly view all the teams of which you are a member.

1 On the home page, select My Teams.

15.4.3  Viewing Your Favorite Places
You can quickly view your favorite places. 

1 On the home page, select My Favorites.

To add or delete favorites, you must access the Vibe site from your workstation. For more 
information, see “Managing Your Favorite Places” in the Novell Vibe OnPrem 3 User Guide.

15.4.4  Viewing Your Recent Places
The Vibe mobile interface enables you to quickly view workspaces and folders that you have visited 
since you last logged in to the current Vibe session.

1 Select Actions > Recent Places.

15.4.5  Viewing File Entries and Attachments
The Vibe mobile interface enables you to view file entries as well as documents that have been 
attached to entries.

1 Navigate to and select the entry that contains the document that you want to view.
2 In the Attachments section, select View next to the document that you want to view.

TIP: If your mobile device is capable of viewing the file in its native format, you can simply click 
the file link to view the file.

For example, when you use an iPhone, you can click the file link to view Microsoft Word files, PDF 
files, and Microsoft Excel files.

15.4.6  Viewing YouTube Videos
The Vibe mobile interface enables you to view YouTube videos that are posted in your Vibe site. 
However, you cannot use a mobile device to view YouTube videos that are posted in the Branding or 
Description sections of workspaces or folders; the video must be posted within a folder entry.

Your BlackBerry or other mobile device might not be properly set up to view YouTube videos. If 
you are having difficulty viewing YouTube videos from your mobile device, follow the instructions 
in “You Are Unable to View YouTube Videos from Your Mobile Device” in the Novell Vibe 
OnPrem 3 User Guide.

To view a YouTube video from the Vibe mobile interface:

1 Navigate to the entry that contains the YouTube video that you want to view.
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2 Click the YouTube icon .
You are directed to the mobile YouTube site to view the video.

To post YouTube videos, you must access the Vibe site from your workstation. For more 
information, see “Displaying YouTube Videos in a Folder Entry” in the Novell Vibe OnPrem 3 User 
Guide.

15.4.7  Viewing What’s New
The Vibe mobile interface enables you to see new entries that have been added to the Vibe site.

“Viewing What’s New in a Folder” on page 156
“Viewing What’s New in Your Teams” on page 156
“Viewing What’s New in Your Followed Places” on page 156
“Viewing What’s New Across the Entire Site” on page 156
“Viewing the Newest Micro-Blog Entries of People You’re Following” on page 156

Viewing What’s New in a Folder

1 Navigate to the folder where you want to see new items.
2 Select Actions > New in This Folder.

Viewing What’s New in Your Teams

1 Navigate to the team workspace where you want to see new items.
2 Select Actions > New in This Workspace.

Viewing What’s New in Your Followed Places

1 From the What’s New drop-down list on the home page, select Places being Followed.

Viewing What’s New Across the Entire Site

1 From the What’s New drop-down list on the home page, select Site Wide.

Viewing the Newest Micro-Blog Entries of People You’re Following

1 From the What’s New drop-down list on the home page, select Micro-Blogs.

15.4.8  Viewing What’s Unread
The Vibe mobile interface enables you to see new entries that have been added to the Vibe site.

“Viewing What’s Unread in a Folder” on page 156
“Viewing What’s Unread in Your Teams” on page 157

Viewing What’s Unread in a Folder

1 Navigate to the folder where you want to see new items.
2 Select Actions > Unread in This Folder.
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Viewing What’s Unread in Your Teams

1 Navigate to the team workspace where you want to see new items.
2 Select Actions > Unread in This Workspace.

15.4.9  Viewing the Workspace Tree
The Vibe mobile interface enables you to view the Workspace tree, so you can see the hierarchy of 
where you currently are and quickly navigate to a different workspace or folder.

1 Select the Tree icon .
The Workspace tree is displayed.

15.4.10  Calling Vibe Users with One Click (iPhone Only)
When you use Vibe from your iPhone, you can call other Vibe users with just one click.

1 Navigate to the personal workspace of the user whom you want to call.
You can navigate to a user’s personal workspace by selecting the user’s linked name that 
appears next to any entry that user has posted. Or, you can search for the user as described in 
Section 15.4.1, “Searching the Mobile Interface,” on page 153.

2 Select the user’s linked phone number.
A call is made to the user.

15.4.11  Sending E-Mail
The Vibe mobile interface enables you to quickly send e-mail to other Vibe users.

1 Navigate to the personal workspace of the user to whom you want to send an e-mail.
You can navigate to a user’s personal workspace by selecting the user’s linked name that 
appears next to any entry that user has posted. Or, you can search for the user as described in 
Section 15.4.1, “Searching the Mobile Interface,” on page 153.
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2 Select the user’s linked e-mail address.

15.4.12  Following People and Places of Interest
The Vibe mobile interface enables you to follow places or people. You can easily see activity 
generated in the specific place that you are following, or by the specific person that you are 
following.

“Configuring Vibe to Follow Workspaces, Folders, and People” on page 158
“Viewing Your Followed Workspaces, Folders, and People of Interest” on page 158
“Unfollowing Workspaces, Folders, or People” on page 159

Configuring Vibe to Follow Workspaces, Folders, and People

1 Navigate to the workspace or folder that you want to follow. If you want to follow a person, 
navigate to the user’s personal workspace.

2 Select Actions > Follow this Folder, Follow this Workspace, or Follow this Person, depending 
on what you want to follow.

Viewing Your Followed Workspaces, Folders, and People of Interest

If you are currently following a workspace, folder, or person, Vibe enables you to easily see activity 
generated in the specific place that you are following, or by the specific person that you are 
following.

1 Navigate to the home page of the Vibe mobile interface.
For information on how to do this, see Section 15.3.2, “Navigating to the Home Page of the 
Mobile Interface,” on page 152.

2 In the What’s New drop-down list, select Places being Followed.
Vibe lists all of the new entries that have been posted to the folders and workspaces that you are 
following, and lists the entries that have been contributed by the people you are following.
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Unfollowing Workspaces, Folders, or People

If you are currently following someone or some place in Vibe, you can unfollow that person or place 
in the Vibe mobile interface.

1 Navigate to the workspace or folder that you want to stop following. If you want to stop 
following a Vibe user, navigate to that user’s personal workspace.

2 Select Actions > Stop Following this Workspace, Stop Following this Folder, or Stop Following 
this Person, depending on what you want to stop following.

15.4.13  Transitioning Entries from One Workflow State to 
Another
The Vibe mobile interface enables you to transition entries from one workflow state to another.

For information on how to create a workflow, see Chapter 11, “Creating and Managing Workflows,” 
on page 107.

To transition entries to another workflow state in the Vibe mobile interface:

1 Navigate to and select the entry that you want to transition to a new workflow state.
2 In the Workflow section, select the new workflow state in the drop-down list, then select OK.

15.4.14  Using Folders
The Vibe mobile interface enables you to use most types of Vibe folders. However, not all folder 
types support the full functionality that is available when accessing the Vibe site from your 
workstation. For more information, see Section 15.5, “Features that Are Not Supported in the Vibe 
Mobile Interface,” on page 159.

15.5  Features that Are Not Supported in the Vibe 
Mobile Interface
The following Novell Vibe features are not supported when you access Vibe from the mobile 
interface. If you want to use any of these features, you must access Vibe from your workstation:

“Using Advanced Search” in the Novell Vibe OnPrem 3 User Guide
“Viewing and Revisiting Recent Entries” in the Novell Vibe OnPrem 3 User Guide
“Adding a Favorite Place” and “Editing Your Favorite Places” in the Novell Vibe OnPrem 3 
User Guide
 “Working with Surveys Folders” in the Novell Vibe OnPrem 3 User Guide
You can use the Vibe mobile interface to view Surveys folders and see the titles of the 
individual surveys that the folders contain, but you cannot view the survey itself or participate 
in it.
“Viewing Your Tasks in a Full Interactive View” in the Novell Vibe OnPrem 3 User Guide
“Deleting a Folder Entry” in the Novell Vibe OnPrem 3 User Guide
Chapter 5, “Branding a Folder or Workspace,” on page 49
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You cannot use the Vibe mobile interface to brand a workspace or folder, or view branding that 
has already been created on a workspace or folder.
“Editing Files” in the Novell Vibe OnPrem 3 User Guide
“Attaching Files to a Folder Entry” in the Novell Vibe OnPrem 3 User Guide

15.6  Security Considerations
When you access Novell Vibe from your mobile device, you enjoy the same security as when you 
access Vibe from your workstation. Security features include:

Secure access via SSL.
All previously established access control settings are preserved in the mobile interface.
However, you cannot set new access control settings in the mobile interface. For information 
on how to set new access control settings when you access the Vibe site from your workstation, 
see Chapter 4, “Controlling Access,” on page 39.

15.7  Troubleshooting Your Mobile Device
If you encounter difficulties when accessing Novell Vibe from your mobile device, see 
“Troubleshooting Your Mobile Device” in the Novell Vibe OnPrem 3 User Guide.
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16Using Novell Vibe with Novell 
GroupWise

You can configure your Novell GroupWise client to work with Novell Vibe OnPrem in various 
ways.

Section 16.1, “Displaying Live Vibe Feeds in GroupWise,” on page 161
Section 16.2, “Accessing Vibe from a GroupWise Web Panel,” on page 161
Section 16.3, “Accessing Vibe through the Novell Vibe Folder,” on page 161

16.1  Displaying Live Vibe Feeds in GroupWise
You can display your Novell Vibe feed in the GroupWise client. This enables you to keep up with 
the latest Vibe additions without leaving GroupWise.

For information on how to do this, see:

 “Creating a New Panel” in “Getting Organized” in the GroupWise 8 Windows Client User 
Guide
“Creating a New Panel” in “Getting Organized” in the GroupWise 8 Linux/Mac Client User 
GuideGroupWise 8 Linux Client HelpGroupWise 8 Mac Client Help

16.2  Accessing Vibe from a GroupWise Web 
Panel
You can set up Novell Vibe to display inside a GroupWise Web panel, so you can access Vibe 
without leaving the GroupWise interface.

For information on how to access Vibe from a GroupWise Web panel, see “Accessing Vibe from a 
GroupWise Web Panel” in the GroupWise 8 Windows Client User Guide.

16.3  Accessing Vibe through the Novell Vibe 
Folder
For information on how to access Novell Vibe through the Novell Vibe folder, see “Accessing Vibe 
through the Novell Vibe OnPrem Folder or the Novell Teaming Folder” in the GroupWise 8 
Windows Client User Guide.

NOTE: Before you can access Vibe through GroupWise as discussed in this section, your 
GroupWise administrator must set up the integration, as described in “Enabling GroupWise/Vibe 
Integration for GroupWise Windows Client Users” in “Configuring GroupWise for Use with Novell 
Vibe OnPrem” in the GroupWise 8 Interoperability Guide.
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A
AWhat’s New in Vibe 3

In Novell Vibe OnPrem 3 you’ll find new features, a fresh user interface, and significant updates. 

The following list is an overview of the new features in Vibe for advanced users.

Section A.1, “Improved Folder and Workspace Branding,” on page 163
Section A.2, “Entry-Level Access Controls,” on page 163
Section A.3, “Presence Integrations with Novell Messenger,” on page 163
Section A.4, “Integrations with Novell Conferencing,” on page 163

A.1  Improved Folder and Workspace Branding
Adding a personal brand to your workspace or folder is easier than ever before with Novell Vibe 3. 
For information about how you can quickly create a personal brand, see Chapter 5, “Branding a 
Folder or Workspace,” on page 49.

A.2  Entry-Level Access Controls
You can now set access controls on individual entries that differ from those set on the parent folder. 
For more information, see Section 4.2.2, “Controlling Access to Entries,” on page 46.

A.3  Presence Integrations with Novell 
Messenger
Novell Vibe 3 provides tight integrations with Novell Messenger, which allows you to see in Vibe 
who is currently online. Presence icons  are located next to users’ names in folder entries. Click 
a user’s Presence icon to see information about that user, view the user’s micro-blog or workspace, 
follow the user, and more. 

A.4  Integrations with Novell Conferencing
Novell Vibe 3 provides tight integrations with Novell Conferencing, which allows you to start an 
instant meeting with other Vibe users, directly from the Vibe interface. For more information, see 
“Using Novell Conferencing with Novell Vibe” in the Novell Vibe OnPrem 3 User Guide.
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