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Error: "8201- access to file has been denied"

(Last modified: 27Sep2004)

This document (10016619) is provided subject to the disclaimer at the end of this document.

fact

Novell GroupWise 5.5

Novell GroupWise 6.5

NetWare

GWPOA.NLM

symptom

POA reporting 8201 errors on message and user databases

Error: "8201- access to file has been denied" 

Choosing OK lets them into GroupWise

Error: User <user id> not found

Poor GroupWise Client performance

fact

Error occurs when user is logging into GroupWise

New users do not show up in address book

New users cannot access their mailbox

There is a Deny Write under Monitor - File Open/Lock Activity - WPHOST.DB

cause

When Monitor shows a DENY WRITE=1 the file is locked and GroupWise cannot write to it. The displayed connection to the file must be resolved in order to alleviate the 8201 errors

In other words, as long as a GroupWise file displays a Deny Write=1, GroupWise does not have access to write to the file. Since GroupWise does not place Deny Write statuses on our files, whatever application is causing the Deny Write needs to "let go" of the file in question. In some situations, this may mean downing the file server. The most common causes of a Deny Write=1 are usually caused by either backup software, or virus protect software. The Macintosh Stuff-it program can also cause a Deny Write on the WPHOST.DB

In another situation the problem was due to the backup program.  This customer was using Veritas 4.5 as their backup solution.  They didn't realize it at the first, but the companies backup teams backups were failing.  Due to the failure the backup team was trying to backup the databases during the day (in the mornings).  The backup program was locking the groupwise databases when trying to back them up.

fix

Make sure backup software is not running during production hours.  Sometimes Open File Agents can lock onto databases so make sure they are not running during production hours.  The GWTSA might be better solution. 

Antivirus software are another culprit.  Unload the antivirus software and see if the problem stops.  Consult some Novell Partners to see if they have better solutions to allow GroupWise messages to be scanned for Viruses.  https://www.novell.com/products/groupwise/partners/

Determine what is putting the deny write on the WPHOST.DB.  

NOTE- This can also occur when the USERxx.DB file is being accessed.  For instance, a backup program could have the file locked.

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10016619
  • Solution ID: 1.0.11922598.2321705
  • Creation Date: 15Sep1999
  • Modified Date: 27Sep2004
    • NovellGroupware

      NetWare

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