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How to restore a NFS volume that abends a server after a power outage.

(Last modified: 30May2002)

This document (10052145) is provided subject to the disclaimer at the end of this document.

goal

How to restore a NFS volume that abends a server after a power outage.

fact

Novell NetWare 4.11 SP 8

Novell NFS 2.3

RAID 5

All volumes including SYS are hosted on an external fibre channel drive array.

V_NFS.NLM

LOCKD.NLM

UNISTART.NCF

VREPAIR was run manually on the NFS volumes without V_NFS.NLM

symptom

Server abends when loading LOCKD.NLM.

Server runs VREPAIR automatically on all volumes

Server does not abend when mounting the corrupted NFS volume AFTER running UNISTART.NCF

The server abends in PKERNEL.NLM ever time all volumes are mounted and UNISTART.NCF is launched

When UNISTART.NCF loads LOCKD.NLM the server abends.

The only way to reboot the server after an abend is to perform a power cycle.  Other methods of downing a server such as entering the debugger, or using Ctrl+Alt+Shift+Esc are not effective.

cause

Power outage on the external drive array corrupted the NetWare NFS volume.  The CPU did not lose power but when the drive array came back on line the server abended.

fix

Note that running VREPAIR.NLM with V_NFS.NLM until no errors are reported does not stop the abends.
The following solution only works with a good backup of the volume.
1. Delete the corrupted NetWare volume.
2. Create a new NetWare volume in the vacant space on the NetWare partition.
3. Load NFS.NAM if it is not loaded already.
4. Apply the NFS name space to the new volume with the following command:
add namespace NFS to <volumename>.  This needs to be entered once only.
5. Restore the backup volume information onto the new volume.
6. Reboot the server.
The server now mounts all volumes and runs UNISTART.NCF without abending.

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10052145
  • Solution ID: NOVL7494
  • Creation Date: 21Apr2000
  • Modified Date: 30May2002
    • NovellNetware

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