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Unable to upload or download file with NetStorage.

(Last modified: 11Jun2003)

This document (10070833) is provided subject to the disclaimer at the end of this document.

fact

Novell NetWare 6.0

Novell NetStorage 1.0

symptom

Unable to upload or download file with NetStorage.

Error: "Bad Request" when trying to upload files via NetStorage.

Browser hangs when trying to download files via NetStorage.

"IO error: Connection Refused: Connection Refused"

note

Before reviewing the causes of this problem it is important to note that the cause depends on when the error message is received. If the process (such as upload or download) has already started and then you receive the error message the cause(s) 1 and 2 will be applicable. If you are just selecting the option (such as upload or download) and you immediately receive the error message upon choosing the option then cause 3 will apply.

cause

(1) This is caused from changing the port for Apache.  There is a NetStorage file (SETTINGS.PROPERTIES) that is dependent on the Apache port.

(2) This is caused when the SETTINGS.PROPERTIES file is configured to use protocol https and port 51443 and the Tomcat code level is before NetWare 6 Support Pack 2. If the Tomcat code level is before SP2 then Tomcat was not enabled for SSL, therefore you cannot use an SSL port.

(3) This is also caused by not having the SETTINGS.PROPERTIES configured properly while trying to access NetStorage through NAT.

fix

(1) Go to SYS:/WEBAPPS/NETSTORAGE/WEB-INF/CLASSES and edit the file SETTINGS.PROPERTIES. In there you will find the following entry:

ServerPort = 51080

** NOTE ** The port may very according to how Apache was installed.  During the installation of NetStorage the port is pulled from the PORTRESOLVERINSTALLED.PROPERTIES file found in the SYS:/NI/UPDATE/DATA directory.  It is pulled from the Apache.port=51080 entry within that file. If the port is changed for Apache without changing the SERVERPORT entry found in the SETTINGS.PROPERTIES file, then NetStorage will be on the wrong port because it runs on Apache.  Simply change the SERVERPORT parameter to match the entry for Apache found in the ADMINSERV.CONF file. This file is the main Apache file for NetWare 6 and can be found in the SYS:/APACHE/CONF directory.  The entries you are looking for are as follows:

Port 80
Listen 192.168.0.1:80

After changing the SERVERPORT parameter to reflect the same port found in the ADMINSERV.CONF file you will need to bring down Tomcat and Apache on the server and then reload them.  At the server console prompt type the following:

JAVA -EXIT
NVXADMDN
TOMCAT33
NVXADMUP

** IMPORTANT ** Make sure that Tomcat and Apache are fully unloaded before trying to start them again. You will also need to clear your cache on your browser.  Also, make sure that you change the PORTRESOLVERINSTALLED.PROPERTIES to reflect the proper ports.  If this is not done and NetStorage is reinstalled, then it will pick up the old port again.

(2) The reason https/443 does not work in SETTINGS.PROPERTIES is because by default Tomcat is not configured for stand-alone SSL before NetWare 6 Support Pack 2. (This can be configured with some effort on Tomcat, but is not needed.) Therefore, NetStorage is looking for protocol http and port 51080.  The SETTINGS.PROPERTIES file specifically determines how the NetStorage servlets talk to the server. Since the communication between NetStorage and the server is *internal*, and does not hit the wire, there is no need to encrypt this data. (Besides, it would only provide additional overhead and slow the process down.)

(3) If NetStorage is behind Network Address Translation (NAT) then it may be necessary to configure the SETTINGS.PROPERTIES with the Private IP address. Below shows an example of the SETTINGS.PROPERTIES before and after the change.

SETTINGS.PROPERTIES before the change:

ServerProtocol = http://
ServerPort = 80

SETTINGS.PROPERTIES after the change:

ServerProtocol = http://
ServerPort = 80
ServerName = 10.0.0.1

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10070833
  • Solution ID: NOVL79272
  • Creation Date: 09May2002
  • Modified Date: 11Jun2003
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