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iChain 2.1 Activation Request Wizard fails to submit request

(Last modified: 13Feb2003)

This document (10072813) is provided subject to the disclaimer at the end of this document.

fact

iChain 2.1

symptom

iChain 2.1 Activation Request Wizard fails to submit request

Message "The system has not responded yet for the iChain Activation Request. Do you want to continue waiting?" appears over and over again.

cause

I. The license activation process requires a minimum configuration in the iChain browser-based administration utility.  Specifically, enough information to identify and contact the ISO object and the LDAP/Authorization server.

II. The activation process goes well with the request until the iChain 2.1 proxy server tries to contact the iChain 2.1 Authorization server via LDAP request. In that LDAP request the proxy is looking for the ISO object in the Authorization Server tree. Specifically in that ISO object the proxy is looking for the following attribute: iChainActivationRequestFile. When the authorization server responds back via LDAP, it sends information about that ISO object WITHOUT the needed attribute. Then the proxy fails. So, the problem is that the ISO object does not appear to have the needed attribute in the ISO object for the proxy to proceed with the registration process.

fix

I.Minimum Confiuration required prior to license activation.
1. Enable the Mini FTP Server in the browser-based iChain Administration Utility under the Configure > FTP.       
2.  Configure the LDAP/Authorization Server information in the browser-based iChain Administration Utility under the Configure > Access Control tab, including: iChain Service Object LDAP Name (requires the ISO object has been configured in eDir.  Use LDAP syntax: ex. cn=iso_object,o=novell), LDAP Server Address, LDAP Port, LDAP Proxy User (Use LDAP syntax: ex. cn=admin,o=novell), and Password. The Proxy User must have sufficient rights.  When in doubt, use Admin, but only for troubleshooting purposes.  Do NOT leave the Proxy User as admin.  When required fields are complete, click on "APPLY".  Wait until the change completes, then click on "Refresh ACLCHECK".
3.   Make sure that the LDAP server has it's server name and and IP address in the HOSTS file.


II.  Schema or snapin issues.
1. Schema did not get extended properly.
On the Authorization Server load DSBROWSE and browse Schema Root for attributes. There must be an iChainActivationRequestFile attribute. If it is not there, the schema must be re-extended. Use the latest Authorization Server code for iChain 2.1 for re-extending the schema.  Download the .iso image for the CD from http://www.novell.com/products/ichain/.    Re-install the snapins from this build.  After verifying the correct snapins have been installed, if it still fails, try deleting or creating a new iChain Service Object (ISO) in ConsoleOne.  Configure the Access Control Tab to use the new ISO.  Try the activation request again. 

2. If the needed attribute is under Schema Root, then browse the tree in DSBROWSE and find an ISO object. Look at its attributes. There must be an  iChainActivationRequestFile attribute. If it is not there, then you are using incorrect snap-ins for ConsoleOne that cannot add the needed attribute during the activation process. ConsoleOne must add the needed attribute after a customer ID was introduced and Next button was pressed. The attribute should be seen in the ISO object.

3. If you see the needed attribute in the ISO object, then most likely the iChain proxy server's Access Control Tab configuration is incorrect.

III. Try re-booting the LDAP server, let it come all the way up, then re-start the iChain server.

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10072813
  • Solution ID: NOVL81139
  • Creation Date: 23Jul2002
  • Modified Date: 13Feb2003
    • NovellConnectivity Products

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