Novell Home

My Favorites

Close

Please to see your favorites.

How to take a coredump on Nterprise Branch Office Servers.

(Last modified: 29Apr2003)

This document (10077009) is provided subject to the disclaimer at the end of this document.

goal

How to take a coredump on Nterprise Branch Office Servers.

fact

Novell Nterprise Branch Office 1.0 Server

cause

The DOS partition image size is roughly 50 meg.  This size is too small to hold diagnostic coredumps.

fix

On the Branch Office Console type the following:

Set admin debug password = <enter password here> [ENTER]

Set admin debug enable = yes

Apply [ENTER]

These three commands automatically load DBNET6.NLM and RDBHOST.NLM.

DBNET6.NLM is required to put a coredump on a remote machine.

RDBHOST is required if you will do live debugging with RDB.EXE.

Choose one of the following methods to transfer the coredump.

1) To a server:

Have IMGHOST.NLM loaded on a remote server where you plan to send the coredump.

2) Run IMGHOST.EXE on a workstation where you plan to send the coredump.

Unlock the Branch Office Console by doing the following:

login [ENTER]

supervisor [ENTER]

<type the supervisor password> [ENTER]

unlock [ENTER]

Accept the disclaimer with YES [ENTER]

The console will display "Debug mode ON"

Now toggle to the console [ALT] [ESC] or [CTRL] [ALT] [ESC] and select the system console.

Set auto restart after abend = 0 [ENTER] Also put this line in the AUTOEXEC.NCF so it will continue to be active at a later time if the server is bounced.

When the server abends, select the option to take a coredump.

Select Full w/o cache

Select "No" on compress coredump.

Select "NETWORK -- Dump Across network to remote host."

Enter either the IP address of the workstation running IMGHOST.EXE or the server running IMGHOST.NLM.

Troubleshooting:

Some LAN drivers can stop communicating when DBNET6.NLM is loaded. If this happens, try update to the latest LAN drivers from the hardware vendor or swap out the NIC and follow the Branch Office Documentation for LAN card changes.

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10077009
  • Solution ID: NOVL84303
  • Creation Date: 22Nov2002
  • Modified Date: 29Apr2003
    • NovellNetware

Did this document solve your problem? Provide Feedback