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Install of iManager 2 fails on NetWare.

(Last modified: 08Jan2004)

This document (10088441) is provided subject to the disclaimer at the end of this document.

fact

Novell iManager 2.0.1

Novell iManager 2

Novell NetWare 6.5

Novell NetWare 6

symptom

Install of iManager 2 fails on NetWare.

iManager 2 install fails on NetWare.

Error: "A fatal error has occurred. This program will terminate. You may check sys:\ni\data\ni.log for more details after you dismiss this dialog. null"

Error: "Installation of Novell iManager2.0 failed. You will need to install this product separately. The error was null."

Error: "Installation of iManager 2.0.1 install for NetWare 6.5 completed with 1 error(s)."

cause

The installation of iManager 2 on NetWare 6.5 or iManager 2.0.1 on NetWare 6 or NetWare 6.5 has certain dependencies in order to complete.  For iManager 2 or 2.0.1 to successfully install the following is required to be functioning properly.

1. A properly functioning Java JVM environment.

2. eDirectory working with properly configured server certificates for the server iManager is being installed on.

3. LDAP configured and working over SSL port 636.  This requires proper server certificates.  See TID 10066259  or  TID 10075010 for information on how to verify LDAP is working properly in secure mode.

4. Apache and Tomcat are configured and running properly.  See TID 10087091  for information on verifying Tomcat has the proper certificate for secure operation in NetWare 6.5.

A common cause for the iManager 2 or 2.0.1 install to fail is missing or corrupt server certificates or LDAP is not working properly over SSL port 636. 

There is a known issue with the NIS install on NetWare 6 and 6.5 when installing iManager 2.0.1.  The iManager install will get a point where you must provide login credentials.  If the user name is entered in full dot notation with a leading dot the install will fail.  For example, entering .admin.novell will cause the install to fail.  When logging in only input the user name as admin and then enter the context in the box below that.  A product defect has been entered for this.

fix

When entering login credentials during the 2.0.1 install do not enter a leading dot before the admin name.

Verify the server certificates by doing the following.

1. In the same context as the server object make sure the certificates SSL CertificateIP and SSL CertificateDNS exist.

2. If they do not exist then try and create them.  If you cannot create the certificates then there is most likely an issue with Certificate Authority, WO object, or tree key.

3. If these certificate objects do exist, view the properties of the certificates and try to validate them from the Certificates tab in ConsoleOne or iManager.

Verify that LDAP is configured for SSL by checking the following.

1. In NetWare Remote Manager or TCPCON check to see if port 636 is bound.  If it is not then LDAP SSL is not configured properly.

2. View the properties of the LDAP server object and verify that on the Connections page a valid Server Certificate is configured.

3. On the same Connections page verify that the Enable Encrypted Port box is checked and the 636 is entered there.

4. On the LDAP group object for the LDAP server object verify that Require TLS for Simple Binds with Password is checked.  This is required.

5. Unload and load NLDAP.NLM and make sure NTLS.NLM autoloads.  The NTLS.NLM will only autoload on Netware 6 if you load NLDAP.

After the install has finished examine the following install log files on the server for detailed information on any errors that occurred.

SYS:\NI\DATA\NI.LOG

SYS:\NI\DATA\NIOUTPUT.TXT

cause

Sometimes the installation of iManager 2.0.0 or 2.0.1 does not complete the configuration phase.  You can determine if this is your problem by checking the properties of the sys:\tomcat\4\webapps\nps directory. There should be approximately 17,000 to 19,000 files total beneath that directory, and about a  dozen .html files in that directory itself, including iManager.html.  If these are missing, then you need to run the configuration applet.

fix

To run the iManager configuration applet:

1- Open a browser and go to nps/servlet/configure">http://<serveripaddress>/nps/servlet/configure

2-Accept the certificate.

3-Click start.

4-Fill in your admin user credentials (i.e. cn=admin, o=mycompany) and the password, and click next.

5-Make sure platform.xar is selected, and click next.

6-Accept the license agreement and click next.

7-Choose typical and click next.

8-Click configure.

9-Restart tomcat and apache again (tc4stop will stop tomcat, and tomcat4 will restart it, ap2webrs will restart apache).  Be sure to wait for tomcat to completely unloaded before reloading in.  Also Tomcat takes a while to load.  Check the logger screen for this message:  "INFO: JK2: ajp13 listening on /0.0.0.0:9010" which indicates Tomcat has completed loading.

10-To access iManager in a browser go to http://serveripaddress/nps/iManager.html

 

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10088441
  • Solution ID: NOVL93706
  • Creation Date: 31Oct2003
  • Modified Date: 08Jan2004
    • NovellManagement Products

      NetWare

      eDirectory

      Security Components

      Web Services

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