Novell Home

My Favorites

Close

Please to see your favorites.

iFolder 2.1 for Linux does not work with a distribution installed Apache

(Last modified: 12Nov2003)

This document (10088721) is provided subject to the disclaimer at the end of this document.

fact

Novell iFolder 2.1 for Linux

Apache2 for Linux

symptom

iFolder 2.1 for Linux does not work with a distribution installed Apache

iFolder 2.1 for Linux requires Apache 2.0.43

cause

The iFolder 2.1 module for Apache is compiled for Apache 2.0.43, this means that Apache will fail to start, if there already is an Apache installed on the server which is not version 2.0.44.

fix

To solve the issue do:
1) Uninstall the pre-installed Apache
2) In the iFolder software package there is a binary distribution of Apache 2.0.43
2.1) cd <iFolder installation software>
2.2) cd apache2-linux
2.3) tar zxfv httpd-2.0.43-i686-pc-linux-gnu.tar.gz
2.4) cd httpd-2.0.43
2.5) ./install-bindist.sh - this will install Apache2 in /usr/local/apache2
3) cd /usr/local/apache2/conf
3.1) vi httpd.conf - make sure that 'ServerName' and other required parameters are correct (see Apache documentation for more information http://httpd.apache.org/docs-2.0/)
3.1) add "include /usr/local/ifolder/Server/httpd_ifolder_unix.conf" to the end of httpd.conf to include the iFolder module, and settings.
4) start Apache: /usr/local/apache2/bin/apachectl start | startssl

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10088721
  • Solution ID: NOVL93868
  • Creation Date: 12Nov2003
  • Modified Date: 12Nov2003
    • NovellWeb Services

Did this document solve your problem? Provide Feedback