Novell Home

My Favorites

Close

Please to see your favorites.

How to reconstruct a GroupWise archive.

(Last modified: 04Feb2004)

This document (10090951) is provided subject to the disclaimer at the end of this document.

goal

How to reconstruct a GroupWise archive.

fact

GroupWise 6

GroupWise 6.5

GroupWise Client

Archive

fix

You can reconstruct a Archive if you have a good MSG.DB and the correct BLOBs associated with that MSG.DB.  If you do not have a good MSG.DB and the associated BLOB files you will need to restore the Archive from backup.

Steps:

Prerequisites:
You need to know the current path to the Archive, the FID for the user.  The path can be obtained from within the GroupWise Client as the owner of the Archive by going to Tools > Options > Environment > File Locations.  The FID (File ID) can be obtained in ConsoleOne in the Properties of User (GroupWise Account) who owns the Archive.

1.  Have the user exit the GroupWise Client on the workstation containing the Archive.
2.  Made a copy of the current OFXXXARC (XXX represents the FID for the user) directory.  This is done to preserve the good MSG.DB and associated BLOB files.
3.  Remove the current NGWGUARD.* files, USER.DB, MSG.DB, INDEX directory, and NGWCHECK.DB from within the OFXXXARC directory.
4.  Start the GroupWise Client as the owner of the Archive.  Have the user send themself a message.  Click on File > Open Archive - this will create the NGWGUARD.DB, NGWGUARD.DC, and USER.DB.  Click on File > Open Archive to go back to the normal Mailbox.  Highlight the mail item you sent to yourself, right click and choose Archive (GW6) or Move to Archive (GW65).  This will create a new MSG.DB. Exit the GroupWise Client.
5.  Start Windows Explorer and go to the OFXXXARC directory.  You will now see new database files (USER.DB, MSG.DB, NGWGUARD.DB, NGWGUARD.DC with current date and time stamps).  Delete the new MSG.DB, copy in the good MSG.DB (from Step 2).
6.  Start the standalone GWCHECK > for Database Type choose Archive, In Database Path specify the path to the OFXXXARC (C:\archive\ofqqqarc), change the Action to Re-Create User Database, Click on Run.  What this will do is scan the good MSG.DB for any messages, re-create the user database, and put all the Mail Items in the Cabinet folder.  Since all the Mail Items are under the Cabinet folder you will need to drag the items back to the correct folders for organizational purposes.

If the above does not work the MSG.DB is most likely corrupted and/or the BLOBs belong to a different MSG.DB.  You will need to go to backup and restore a good copy of the Archive before the problem.

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

  • Document ID:
  • 10090951
  • Solution ID: NOVL95312
  • Creation Date: 04Feb2004
  • Modified Date: 04Feb2004
    • NovellGroupware

Did this document solve your problem? Provide Feedback