Novell Home

My Favorites

Close

Please to see your favorites.

SLED10 : Installing ConsoleOne

This document (3275374) is provided subject to the disclaimer at the end of this document.

Environment


Novell ConsoleOne 1.3.6
Novell SUSE Linux Enterprise Desktop 10

Situation

When installing ConsoleOne from the "c1-install" install script, the following errors occur:

Error: Failed dependencies
NLDAPsdk conflicts with novell-NLDAPsdk-dyn-3.4.1-0.5.i586
%% ERROR: Failed to add NLDAPsdk (NLDAPsdk) package.
%% Installation of packages failed, not all packages were installed.

Conflicts occur with some packages that are included in the ConsoleOne download and SUSE Linux Enterprise Desktop 10. Because of this, ConsoleOne will not install using the c1-install.sh script provided.



Resolution

Fix #1:

The ConsoleOne install script provided with the ConsoleOne download does not work properly. Install ConsoleOne using the script provided in document ID 2974328 from http://support.novell.com.

Fix #2:

Note : Depending on the installation, there may be additional conflicts. Specifically, if the authentication mechanism for eDirectory was selected during startup, an additional conflict between NLDAPbase-8.7.3-34 and novell-NLDAPbase-dyn-3.4.1-0.2 will occur. Any packages depending on these additional conflicts will force either installing the new RPM's or using the --nodeps parameter when manually installing RPM's that depend on these if not specified in this document.
  1. Extract the ConsoleOne archive.
  2. Change into the "Linux" directory that the archive extraction creates :
    cd Linux
  3. Run the c1-install.sh script - which will fail after installing three RPM's. If desired to install these first three RPM's manually, install the following RPM's (in order shown here) :
    nici-2.6.4-0.05.i386.rpm
    NDSbase-8.7.3.7-38.i386.rpm
    NDScommon-8.7.3-34.i386.rpm
    Use the command :
    rpm -i [PACKAGE_NAME]
    For example :
    rpm -i nici-2.6.4-0.05.i386.rpm
  4. DoNOTinstall NLDAPsdk-8.7.3-34.i386.rpm, as this conflicts with an existing package :
    jlewis4:/home/jlewis/netware/files/tmp/Linux # rpm -i NLDAPsdk-8.7.3-34.i386.rpm
    error: Failed dependencies:
    NLDAPsdk conflicts with novell-NLDAPsdk-dyn-3.4.1-0.5.i586
  5. Install the remaining needed RPM's using a --nodeps parameter (for example :
    rpm -i --nodeps NLDAPbase-8.7.3-34.i386.rpm
    ). The following RPM's should be installed following the order shown (or RPM dependencies will occur) :
    NLDAPbase-8.7.3-34.i386.rpm
    NOVLpkia-2.7.0-6.i386.rpm
    NOVLpkis-2.7.0-6.i386.rpm
    NOVLlmgnt-8.7.3-34.i386.rpm
    NOVLxis-8.7.3-34.i386.rpm
    NOVLice-8.7.3-34.i386.rpm
    NOVLsas-8.7.3-34.i386.rpm
    NOVLc1-1.3.6-1.i386.rpm
  6. Copy the ConsoleOneIcon.png file to /usr/ConsoleOne/bin/ using the command :
    cp ConsoleOneIcon.png /usr/ConsoleOne/bin/
  7. Create the "desktop" option by copying the consoleone.desktop file to /usr/share/applications/ :
    cp consoleone.desktop /usr/share/applications/
  8. If the menu does not refresh with the ConsoleOne icon, log out and log back in.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:3275374
  • Creation Date:18-SEP-06
  • Modified Date:26-APR-12
    • NovellConsoleOne
    • SUSESUSE Linux Enterprise Desktop

Did this document solve your problem? Provide Feedback