Novell Home

My Favorites

Close

Please to see your favorites.

LDAP is not installed correctly in 2 NIC server using -B switch with ndsconfig

This document (7000921) is provided subject to the disclaimer at the end of this document.

Environment

Novell eDirectory 8.8 for Linux

Situation

In a server running SLES 10 SP1 with eDirectory 8.8.2 (with or without FTF2), if you
use the -B switch to limit NCP to only one NIC, while still configuring it to have
LDAP respond on both NICs, LDAP says it is configured properly, but it does not run
correctly.

Using this commandline:
# ndsconfig new -t AUTH-TREE -n o=n -a cn=admin.o=n -w a -i -S ham9 -L 389 -l 636
-P eth0,eth1 -B eth0@524 -e


the install claims success, but LDAP does not work.

Resolution

Using this commandline (just omit the -B switch and variable):
# ndsconfig new -t AUTH-TREE -n o=n -a cn=admin.o=n -w a -i -S ham9 -L 389 -l 636
-P eth0,eth1 -e


the install claims success, and LDAP does work on both interfaces. Interestingly,
ndsconfig prompts for which of the two addresses (or both) to use for NCP, and
selecting one does work correctly, which is what the -B switch (omitted from this
command line) was supposed to do.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7000921
  • Creation Date:11-JUL-08
  • Modified Date:26-APR-12
    • NetIQeDirectory

Did this document solve your problem? Provide Feedback