Novell Home

My Favorites

Close

Please to see your favorites.

NICI segfault when installing eDirectory 8.8.2 on an AMD Quad-core processor

This document (7000979) is provided subject to the disclaimer at the end of this document.

Environment

Novell eDirectory 8.8.2 for Linux
Novell eDirectory 8.7.3 for Linux

Situation

Error seen during install of eDirectory 8.7.3 SP9 and eDirectory 8.8 SP2 on a AMD Quad-core processor

Starting eDirectory may cause Segmentation fault while bringing up NLDAP. To narrow down if you are facing the same issue as in this TID, try to start the /var/opt/novell/nici/primenici script and see if the following error is displayed

Initializing NICI ... /var/tmp/rpm-tmp.92999: line 23: 11786 Segmentation fault
/var/opt/novell/nici/primenici
error: %post(nici-2.7.3-0.01.i386) scriptlet failed, exit status 139
 
This issue has also been seen after moving a VMWare image to new hardware running a AMD Quad Core processor. 

Resolution

This issue has been resolved in the following releases:

  • eDirectory 8.8 SP3 (standalone eDirectory)
  • OES2 SP1 (OES2 installs)

Until you can get fully patched to the versions above, you can download the whole eDirectory 8.8.3 install or whole OES2 SP1 install and extract and install the nici rpm for the platform you are running.

Should you need the patch for eDirectory 8.7.3, please contact Novell Technical Services.



Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7000979
  • Creation Date:18-JUL-08
  • Modified Date:26-APR-12
    • NetIQeDirectory
      NICI

Did this document solve your problem? Provide Feedback