Environment
Novell ZENworks Patch Management 11
Novell ZENworks Configuration Management 11.1 Patch Management
Novell ZENworks Configuration Management 11.2 Patch Management
Novell ZENworks Configuration Management 11.1 Patch Management
Novell ZENworks Configuration Management 11.2 Patch Management
Situation
No patches show as installed or applicable for the device in
ZENworks Control Center
0 Byte scan results do get uploaded to the collection server
Error 27 logged for each patch in %zenworks_home%\zpm\debug.log
0 Byte scan results do get uploaded to the collection server
Error 27 logged for each patch in %zenworks_home%\zpm\debug.log
Resolution
This is fixed in version 11.2.2 - see KB 7010757 "ZENworks
Configuration Management 11.2.2 - update information and list of
fixes" which can be found at
https://support.microfocus.com/kb/doc.php?id=7010757
Workaround:
Delete the folder %zenworks_home%\zpm\workdir. It will get automatically recreated when required.
Workaround:
Delete the folder %zenworks_home%\zpm\workdir. It will get automatically recreated when required.
Cause
The file system rights, set on the %zenworks_home%\zpm\workdir
folder, got tampered with on the managed device.
Additional Information
Since ZPM 11.2.2 the workdir folder
gets automatically cleaned up and recreated as needed.