My Favorites


Please to see your favorites.

Security Vulnerability - GroupWise 8 Internet Agent TZID (VCALENDAR) Variable Parsing

This document (7007638) is provided subject to the disclaimer at the end of this document.


Novell GroupWise 8
Novell GroupWise 8 Internet Agent
Affected versions: GroupWise 8.0x, 8.01x, 8.02, 8.02HP1
Previous versions (such as GroupWise 7.x) of GroupWise are likely also vulnerable but are no longer supported. Customers on earlier versions of GroupWise should, at a minimum, upgrade their GWIAs and associated Domains to version 8.02HP2 in order to secure their system.


The GroupWise Internet Agent (GWIA) has a vulnerability in the way that it parses the TZID variable within a received VCALENDAR message, which could potentially allow an unauthenticated remote attacker to execute arbitrary code on vulnerable installations of GWIA.  This vulnerability affects GWIA running on all supported server OS platforms (Windows, SuSE Linux, & NetWare).

This vulnerability was discovered and reported by Anonymous working with TippingPoint's Zero Day Initiative (http://www.zerodayinitiative.com), ZDI-CAN-967

Novell bug 657818, CVE-2010-4325


To resolve this security issue, update GWIA to version 8.02 Hot Patch 2 (or later).

Bug Number



This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7007638
  • Creation Date:21-JAN-11
  • Modified Date:26-APR-12
    • NovellGroupWise

Did this document solve your problem? Provide Feedback