Novell Home

My Favorites

Close

Please to see your favorites.

Dependency error when adding SLE Mono Extension as add-on to SLES 11 SP1/SP2

This document (7007708) is provided subject to the disclaimer at the end of this document.

Environment


SUSE Linux Enterprise Mono Extension
SUSE Linux Enterprise Server 11 Service Pack 1
SUSE Linux Enterprise Server 11 Service Pack 2

Situation

When adding SUSE Linux Enterprise Mono Extension to a SUSE Linux Enterprise Server 11 Service Pack 1 or Service Pack 2 system via the "yast2 add-on module", you get the following error message:

nothing provides product(SUSE_SLE) = 11 needed by sle-mono-release-cd-11.0.2.4-1.7.x86_64
    [ ] break sle-mono-release-cd by ignoring some of its dependencies
    [ ] do not install product:sle-mono-11.0.2.4-0.x86_64
nothing provides product(SUSE_SLE) = 11 needed by sle-mono-release-cd-11.0.2.4-1.7.x86_64
    [ ] do not install sle-mono-release-11.0.2.4-1.7.x86_64
    [ ] break sle-mono-release-cd by ignoring some of its dependencies

Resolution

Prior to installing the Mono Extension it is recommended to de-install all mono packages on the SLES 11 SP2 system, e.g. via 'yast2 sw_single'. You can check, if mono packages are installed by running the following command:

   rpm -qa | grep -i mono


Then you can use "yast2 add-on" to add the Extension to your system.

When the above conflict message is displayed in YaST, choose the following option:

[ ] break sle-mono-release-cd by ignoring some of its dependencies

This does not have any effect on the functionality of the SLE Mono Extension.

You will then be prompted to register the add-on product. This will ensure that respective update catalogs will be assigned to the system, so that you have access to the newer mono version 2.6.7 packages. You can update the packages via "yast2 online_update" or via "zypper patch".

Finally check, if all mono packages are installed from the mono extension and not from the SLES base system: execute the command "zypper se -s mono | grep ^i".

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7007708
  • Creation Date:23-MAY-12
  • Modified Date:24-MAY-12
    • SUSESUSE Linux Enterprise Mono Extension
      SUSE Linux Enterprise Server

Did this document solve your problem? Provide Feedback