Novell Home

My Favorites

Close

Please to see your favorites.

Security Vulnerability: GroupWise Internet Agent (GWIA) LDAP integer overflow vulnerability

This document (7010770) is provided subject to the disclaimer at the end of this document.

Environment

The GroupWise Internet Agent (GWIA) is vulnerable to an integer overflow exploit in the way it processes LDAP requests, which could potentially allow an unauthenticated remote attacker to execute arbitrary code on vulnerable installations of GWIA.

Situation

GroupWise 8.0x up to and including 8.02HP3
GroupWise 2012

Resolution

To resolve this vulnerability, apply GroupWise 8.0 Support Pack 3 (or later) or 2012 Support Pack 1.

Customers can also secure their system by disabling the LDAP service on their GroupWise Internet Agent (under the properties of the GWIA object, click the LDAP tab and uncheck the box for "Enable LDAP service")
 
Previous versions of GroupWise are likely also vulnerable but are no longer supported. Customers on earlier versions of GroupWise should, at a minimum, upgrade their GWIA servers and associated Domains to version 8.0 Support Pack 3 or 2012 SP1 in order to secure their system.

This vulnerability was discovered and reported by Francis Provencher working with TippingPoint's Zero Day Initiative (http://www.zerodayinitiative.com), ZDI-CAN-1347

Novell bug 740041, CVE-2012-0417

Status

Security Alert

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7010770
  • Creation Date:11-SEP-12
  • Modified Date:28-NOV-12
    • NovellGroupWise

Did this document solve your problem? Provide Feedback