Novell Home

My Favorites

Close

Please to see your favorites.

Update designer gives Update Failed Eclipse error if old version of designer had been installed

This document (7010998) is provided subject to the disclaimer at the end of this document.

Environment

NetIQ Designer
NetIQ Identity Manager

Situation

Trying to update designer gives error Update Failed Reason: org.eclipse.core.runtime.CoreException: Cannot install featurecom.novell.idm.feature.patch 4.0.0.201105191647

Resolution

Uninstall Designer (which did not clean out all the files) then manually remove the .eclipse directory and the C:\Program
Files (x86)\Novell\Designer directory.  Then reinstall designer and the check for updates now works.

Cause

Prior versions of Designer installed the eclipse files in a .eclipse directory.
Installing a new version of designer on top of that does not clear out the old
directory before laying down the new one.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7010998
  • Creation Date:24-OCT-12
  • Modified Date:24-OCT-12
    • NetIQDesigner
      Identity Manager

Did this document solve your problem? Provide Feedback