Novell Home

My Favorites

Close

Please to see your favorites.

VPC Service fails to start with Java 7

This document (7011358) is provided subject to the disclaimer at the end of this document.

Environment

NetIQ VigilEnt Policy Center 5.6 SP3
NetIQ VigilEnt Policy Center 5.6 SP4
Sun Java 7 Update 5 thru Sun Java 7 Update 7

Situation

After installing VPC 5.6 SP3 or VPC 5.6 SP4 and then installing Java 7 the Vigilent Policy Service fails to start.

Resolution

If you are running VPC 5.6 SP3 and Java 7 and the VPC Service fails to start, you should install VPC 5.6 SP4 or later.

 

If you are running VPC 5.6 SP4 or later and then install Java 7 and the VPC Service fails to start, you will need to do the following:

 

1.       Copy the msvcr100.dll file FROM the <path to Java 7 Program Files>\Bin folder TO the <path to VPC Program Files>\Server\Bin folder.

 

2.       Start the VPC Service.

Cause

There are known compatiblity issues between Java 7 and Apache Tomcat 5.5 Server. VPC uses Tomcat for the web server to host the VPC User and Admin sites.

Additional Information

This issue does not occur on Windows Server 2012, and VPC 5.6 SP4.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7011358
  • Creation Date:13-NOV-12
  • Modified Date:26-FEB-13
    • NetIQVigilEnt Policy Center

Did this document solve your problem? Provide Feedback