iManager internal error communicating to target server when creating iPrint object
This document (7011415) is provided subject to the disclaimer at the end of this document.
Environment
Situation
When attempting to create or manage an iPrint object in iManager, the following error is returned:
There was an internal error while communicating to target iPrint server. Check /var/log/apache2/error_log
Resolution
Remove the BaseDN definition within the iprint_ssl.conf file and restart Apache. The steps are:
- Open the /etc/opt/novell/iprint/httpd/conf/iprint_ssl.conf file
-
Find the AuthLDAPURL line.
-
Remove the O=<WhateverOrganization> as follows:
- Original Syntax:
AuthLDAPURL"ldaps://[IPorDNSofPrintServer]/[LDAPSearchBase]???(objectClass=user)" - Solution Syntax:
AuthLDAPURL "ldaps://[IPorDNSofPrintServer]/???(objectClass=user)" - Original Example:
AuthLDAPURL"ldaps://iprintserver.company.com/O=ABC-CORP???(objectClass=user)" - Solution Example:
AuthLDAPURL "ldaps://iprintserver.company.com/???(objectClass=user)"
- Original Syntax:
-
Restart Apache to make that take effect.
-
rcapache2 restart
-
Cause
Disclaimer
This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:7011415
- Creation Date:21-NOV-12
- Modified Date:29-NOV-12
- NovelliPrint
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