Unable to login to AC Console "Login error underlying connection was closed"

  • 7011710
  • 25-Jan-2013
  • 06-Mar-2013

Environment

NetIQ Analysis Center 2.7.x

Situation

After launching Analysis Center Console, you are unable to login and get error message "Login error underlying connection was closed"

Resolution

To resolve this issue, please complete the following steps:
  1. Ensure the DCOM Security is configured correctly as described in the Cause section.
  2. Open IIS Manager.
  3. In the Connections pane, expand the server node and click Application Pools.
  4. On the Application Pools page, select ACAppPool, and then click Advanced Settings in the Actions pane.
  5. For the Identity property, click the ... button to open the Application Pool Identity dialog box.
  6. Use a custom identity, select the Custom account option and click Set to open the Set Credentials dialog box. Then type the custom account name in the User name text box, type a password in the Password text box, retype the password in the Confirm password text box, and then click OK.
  7. Click OK to dismiss the Application Pool Identity dialog box.
  8. If you are still unable to login, launch the Windows Event Viewer and check the System Event Logs for errors. Most of the errors will be self explanatory.

If this issue not resolved after performing the above steps, you will have to reinstall the Internet Information Manager and the AC Web Service component.

Cause

This issue can occur if DCOM is misconfigured or if the ACAppPool is down.
 
The following are steps to confirm DCOM Security configuration is configured correctly.
 
From the Start menu, click Run and type Dcomcnfg.exe.
  1. In Component Services, click Console root, expand Component Services, expand Computers, and then click My Computer. On the Action menu, click Properties.
  2. In the My Computer Properties dialog box, on the COM Security tab, in the Launch and Activation Permissions section, click Edit Limits.
  3. In the Launch Permissions dialog box, click Add.
  4. In the Select User, Computers, or Groups dialog box, in the Enter the object names to select (examples): box, type domain\userID or SYSTEM and click OK.
  5. In the Permissions for domain\userID or SYSTEM section, select the check box to allow Remote Activation, Local Launch, Local Activation and Remote Launch.
  6. Click OK twice, and then close Computer Management.