Unable to view Events in the Appmanager Operator Console

  • 7011910
  • 11-Mar-2013
  • 11-Mar-2013

Environment

NetIQ AppManager Enterprise 8.0.x
NetIQ AppManager Enterprise 7.0.x

Situation

When users log into the AppManager Operator Console, they are unable to see any events in the console's Events tab.

Resolution

You can use either the Control Center Console or the Operator Web Console in order to view and manage events.  Your goal should be to close and delete most of the events (after corrective action has been taken) in order to bring the number of total event down.  This is the recommended method of correcting this issue. However, as this is a manual process, it will take time depending on the number of events that need to be manually processed and deleted.

You will then need to run the 'NetIQ Daily QDB' task in SQL Management Studio.  Once this is completed, close the Operator Console and re-open... the remaining Events should be visible.  If not, please process and close more Events.

In some cases, you may find that processing and closing this number of Events via the above method is not possible.  In such cases, it should be possible to clean up undesired Events via SQL Query.  Should you find that you cannot process and close your Events using the above method, contact NetIQ Technical Support and reference this article.

Cause

The issue is  caused by the number of open, acknowledged and closed events exceeding the amount of memory that the Operator Console is allotted for the display of Events.  While the actual number of Events is different for every environment, typically this issue occurs when you have in excess of 500,000 events to display.

You should be able to manage the events in either the Control Center Console or the AppManager Web Operator Console.

Additional Information

It is recommended that you access the Operator Console or the other Consoles on a frequent basis to manage the events.  
You could also set preferences for grooming the events. 
To update the Operator Console preference, launch the console and select File | Preferences | Repository |  Event | Event Options
Under events options you have the following choices.
  • Move events to archive tables when event stays closed for X Days.
  • Purge archived events in repository when event has been kept for X days.
  • Automatically close event when severity is greater than 0-40.
  • Re-open the acknowledged event during event collapsing.
  • Increment event count only without changing status during event collapsing.
  • Remove associated events when delete jobs.
  • Don't display "AppManager Proxy Events" as objects in the tree view.