Novell Home

My Favorites

Close

Please to see your favorites.

XEN VM upgrade to OES11/SLES11 from OES2SP3/SLES10SP4 freezes at the "Test Internet Connection" screen

This document (7011959) is provided subject to the disclaimer at the end of this document.

Environment


Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 1
Novell Open Enterprise Server 11 (OES 11) Linux Support Pack 2
SUSE Linux Enterprise Server 11 SP1 XEN Host
Novell Open Enterprise Server 2 SP3 / SUSE Linux Enterprise Server 10 SP4 guest

Situation

During a vm-install --upgrade of a SLES10 SP4-OES2 guest to OES11 the installtion process / VM freezes as soon as the "Test Internet Connection" screen displays.

If the VM is forced off and restarted, it tries to resume the upgrade at that point and freezes.  (The DomU appears to be frozen as soon as the screen is displayed. You can't move the mouse pointer or provide input via the keyboard--so you can't press the 'Next' button.  In the reported case, we got a ping response when trying to ping the DomU eth0. When we attempted to ssh, we got a connection refused error, and xm top from Dom0 showed little or no CPU utilization on the DomU.) 


Resolution

If TID 7003097 has been applied to an OES2SP3 server prior to updating, you need to update to OES11SP1.

Cause

Beginning with SLE 11 it was no longer possible to access display:0 using vnc without some additional changes to the system. It appears that the failed upgrade is a result of implementing the changes described in this TID:

TID 7003097 - Enabling VNC Server on startup of the X server with SLE 11


SLE11SP1 has appearently a bug in the vnc module, but this is fixed with an
updated package. This is what I see in Xorg.0.log, the same happens for me in a
fresh sles11sp1 installation without updates:

...
(II) LoadModule: "vnc"
(II) Loading /usr/lib64/xorg/modules//extensions/libvnc.so
(II) Module vnc: vendor="xf4vnc Project, see http://xf4vnc.sf.net (based on modular X.org)"
        compiled for 1.6.5, module version = 1.1.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.0
(EE) module ABI major version (1) doesn't match the server's version (2)
(II) UnloadModule: "vnc"
(II) Unloading /usr/lib64/xorg/modules//extensions/libvnc.so
(EE) Failed to load module "vnc" (module requirement mismatch, 0)
...

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7011959
  • Creation Date:14-MAR-13
  • Modified Date:29-APR-13
    • NovellOpen Enterprise Server

Did this document solve your problem? Provide Feedback