BlackBerry 10 device does not delete mail from mailbox

  • 7012006
  • 22-Mar-2013
  • 10-Dec-2013

Environment

SUSE Linux Enterprise Server 11
Novell GroupWise 2012
Novell GroupWise 8

Situation

Deleting mail item from bb10 device does not sync with GroupWise
Delete on z10 device does not delete from Mailbox
Contact/Calendar/Mail sync otherwise works fine both ways

Resolution

At the time of writing this TID, BlackBerry does not have a resolution time frame available; however, there is a posted workaround on the device. See KB 33560&sliceId=2&cmd=displayKC&docType=kc&noCount=true&ViewedDocsListHelper=com.kanisa.apps.common.BaseViewedDocsListHelperImpl" target="_blank">Email messages deleted from BlackBerry 10 smartphone are not moved to a Trash or Deleted Items folder and instead are permanently removed.

From ConsoleOne, change configuration to allow purge of items before backup for specific users or entire Post Office, Domain:
  1. Check specific User's configuration:
    • Right-click User object | GroupWise Utilities | Client Options | Environment | Cleanup
    • Uncheck "Do not purge items until they are backed up"
    • Select the 'Retention' tab and uncheck 'Enable Message Retention Service'
  2. If checkbox is greyed out for User, then settings are locked by either the Post Office or Domain:
    • Right-click PO object | GroupWise Utilities | Client Options | Environment | Cleanup and the 'Retention' tab
    • Verify settings are unlocked (icon on the right) for the setting to be set for individual users.
  3. If checkbox is greyed out for Post Office, then settings are locked by the Domain:
    • Right-click Domain object | GroupWise Utilities | Client Options | Environment | Cleanup and the 'Retention' tab
    • Verify setting is unlocked (icon on the right) for the setting to be set for individual users.
      Note: Unchecking on Domain level will affect all users this context.
  4. If settings were originally locked for a specific user, go back and repeat Step 1
  5. Restart Post Office Agent (POA) after few minutes
  6. Restart DataSync by typing "rcdatasync restart" and press Enter

Cause

Most devices do a move into the Trash. Z10 device does a purge, and since items cannot be purged until backed up, the event never is processed. By the time a backup is performed, the delete request has already gone through. Consequently, the mail item is never deleted.

Additional Information

There is no error in the POA log indicating the purge request failed, this has been reported to Engineering.
Environment Options: Cleanup
Environment Options: Retention