System Update Agent settings page does not open in ZCC

  • 7012033
  • 26-Mar-2013
  • 05-Jan-2015

Environment

Novell ZENworks Configuration Management 11.3 ZENworks Control Center - ZCC
Novell ZENworks Configuration Management 11.2 ZENworks Control Center - ZCC
Novell ZENworks Configuration Management 11.3 System Update
Novell ZENworks Configuration Management 11.2 System Update
Novell ZENworks Asset Management 11.3
Novell ZENworks Asset Management 11.2
Novell ZENworks Endpoint Security Management 11.3
Novell ZENworks Endpoint Security Management 11.2
Novell ZENworks Patch Management 11.3
Novell ZENworks Patch Management 11.2

Situation

The system update agent configuration has been edit to include a custom message
The message text contains the & ampersand sign

The system update agent configuration page does not open in ZENworks Control Center any more.

Error in ZCC:
"...
19 Mar 2013 14:14:10 Exception occurred java.lang.NullPointerException at com.novell.zenworks.admin.pages.settings.SystemUpdateAgentSettings.getUnconfiguredMessages(SystemUpdateAgentSettings.java:532) at com.novell.zenworks.admin.pages.settings.SystemUpdateAgentSettings.prerender(SystemUpdateAgentSettings.java:218)
..."

Resolution

This is fixed in version 11.3.1 - see KB 7014213 "ZENworks Configuration Management 11.3.1 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7015288

Workaround:
Avoid the & ampersand sign in custom System Update Agent messages. Once the issue occurred, it can be worked around by removing the & ampersand from any custom message.

The system update agent custom messages are stored in the zSystemSetting table with an entry where the Name column value is SYSTEMUPDATE. The respective row has the custom message information in the Data column. The Data field contains different XML tags for each custom message. The XML tags corresponds to the respective message type like <AWAITING_PERMISSION>...</AWAITING_PERMISSION>.

The text within the tags need to be changed to not contain the & ampersand sign.

Please contact Novell Support if further assistance is required.

Cause

The & ampersand sign gets interpreted as a control character instead of normal text.

Additional Information

More information about editing System Update Agent configuration is available at Configuring the System Update Behavior of the ZENworks Adaptive Agent