Unable to login to WebAdmin as admin (base search)

  • 7012047
  • 29-Mar-2013
  • 10-Dec-2013

Environment


Novell Data Synchronizer Mobility Pack

Situation

Can't login to DataSync WebAdmin
User tries to login to DataSync WebAdmin and receives "Invalid User name and password"
Logs show LDAP error 32 'no such object':
Authentication or LDAP server failure: NO_SUCH_OBJECT

Resolution

Although there are many reasons why a user may not be able to login (i.e. using GroupWise password rather than user's eDirectory/LDAP password), the steps below identify one potential cause. See TID 7012048 for other authentication issues.

The error above is generally returned when the target DN of the operation cannot be located (i.e. user cannot be found). Check Global Settings and verify the LDAP base search isn't too low in the tree:
  1. Login to DataSync WebAdmin: http://www.mymobileserver.com:8120
  2. Select 'Manage Global Settings' from the top right menu (3rd from the right)
  3. Verify user exists in the LDAP Base User DNs listed containers.
  4. To search in an additional container for users, specify the container context in the text entry field under LDAP Base User DNs, then click '+' to add the container to the list of containers to search.
    Note: Subcontainers are also searched, so you do not need to add them separately.

Verify the LDAP user has correct credentials and proper rights.

  1. From a terminal window type: cat /etc/datasync/configengine/configengine.xml and press [Enter]
    Look for the following items in between the <ldap> tags:
    <login>
            <dn>cn=admin,o=novell</dn>
            <password>novell</password>
    </login>
  2. Please follow the steps outlined in TID 7006841 to verify the rights for the LDAP admin are correct.

Cause

LDAP base search is too low in the tree for the specified user to be found. The user cannot be found because the user object does not exist in the specified search container or subcontainers.

Additional Information