Deployment Package Check-In fails with HTTP 403 error

  • 7012157
  • 17-Apr-2013
  • 17-Apr-2013

Environment

NetIQ AppManager Enterprise 8.0.x
NetIQ AppManager Enterprise 7.0.x

Situation

When attempting to check Deployment Packages into the Control Center Console, you receive the following error:

HTTP status 403: The client does not have sufficient access rights to the requested server object.

Resolution

If you are using an HTTP/URL filtering tool, such as the URLScan ISAPI filtering tool, please try to disable or remove this tool to verify whether the Deployment Web Service becomes operable without those restrictions in place.

If you find that your filtering tool was preventing the Deployment Web Service from functioning correctly, you will need to either refrain from using such filters on the Web Deployment Server, or disable/uninstall the filter altogether.

Cause

An attempt to secure the IIS Server hosting the Deployment Web Service and Deployment App Pool may include the use of filters such as a URLScan ISAPI filter, which can be used to restrict the king of HTTP requests that a web server can process.  As a result, such filtering tools can prevent some or all URLs from connecting.

The use of filters such as the URLScan ISAPI filter will in many cases prevent the Web Deployment Server from functioning as designed, rendering the Deployment Service inoperable, and preventing Control Center Administrators from being able to check items such as Deployment Packages into the Control Center Console.