IDM RBPM 4.0.2 - JBoss fails to authenticate to MSSQL - Unauthenticated caller:null

  • 7012462
  • 23-May-2013
  • 23-Oct-2013

Environment


NetIQ Identity Manager Roles Based Provisioning Module 4.0.2
NetIQ Identity Manager 4.0.2

Situation

Newly installed Identity Manager Role Based Provisioning 4.0.2.  
Jboss running on Linux server, MSSQL 2008 Database running on Windows 2008 R2 server.
JBoss installed and User Application installed.   However, the tables were created successfully in the MSSQL database.

JBoss is getting a error logging into the MSSQL database. 
Login credentials for the database can be found in jboss/server/IDMProv/conf/login-config.xml
The password is encrypted, it cannot be decrypted, but it can be changed or verified by encrypting the password again.
See the See the JBoss AS 5.1.x section at https://community.jboss.org/wiki/EncryptingDataSourcePasswords


2013-05-21 23:49:32,217 ERROR [org.jboss.messaging.util.ExceptionUtil] (main) org.jboss.jms.server.plugin.JDBCJMSUserManagerService@1e5296 startService
java.lang.SecurityException: Unauthenticated caller:null
    at org.jboss.security.integration.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:687)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:495)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)
    ......
2013-05-21 23:49:32,218 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Start: name=jboss.messaging:service=JMSUserManager state=Create mode=Manual requiredState=Installed
java.lang.SecurityException: Unauthenticated caller:null
    at org.jboss.security.integration.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:687)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:495)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)
    .....
2013-05-21 23:49:32,236 ERROR [org.jboss.messaging.util.ExceptionUtil] (main) org.jboss.messaging.core.jmx.JDBCPersistenceManagerService@5e6ce1 startService
java.lang.SecurityException: Unauthenticated caller:null
    at org.jboss.security.integration.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:687)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:495)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)
    .....
2013-05-21 23:49:32,237 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (main) Error installing to Start: name=jboss.messaging:service=PersistenceManager state=Create mode=Manual requiredState=Installed
java.lang.SecurityException: Unauthenticated caller:null
    at org.jboss.security.integration.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:687)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:495)
    at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)
    d.run(Unknown Source)

Resolution

Changing the password to a different password (without numbers in it) allowed the authentication from JBoss to the database to be successful.
 
Additional Note:
The Unauthenticated caller:null can be seen anytime there is a login failure with User Application or Reporting.    This is due to invalid, or missing credentials in the login-config.xml.  
 
An example of additional issue that was seen if you have User Application and Reporting running on the same server, and reinstall user application but not reporting.   When attempting to start reporting, the Unauthenticated caller:null is thrown in the log, due to missing credentials for reporting.    A reinstall of reporting, corrected the issue.

Cause

The password being used is not being decrypted the same as it was encrypted.  So the authentication fails.