My Favorites


Please to see your favorites.

SLE 10 SPx Activation returns Invalid certificate received from server

This document (7012549) is provided subject to the disclaimer at the end of this document.


SUSE Linux Enterprise Server 10 Service Pack 4
SUSE Linux Enterprise Desktop 10 Service Pack 4
SUSE Linux Enterprise Server 10 Service Pack 3 (SLES 10 SP3)
SUSE Linux Enterprise Server 10 Service Pack 2 (SLES 10 SP2)
SUSE Linux Enterprise Server 10 Service Pack 1 (SLES 10 SP1)
SUSE Linux Enterprise Desktop 10 Service Pack 3 (SLED 10 SP3)
SUSE Linux Enterprise Desktop 10 Service Pack 2 (SLED 10 SP2)
SUSE Linux Enterprise Desktop 10 Service Pack 1 (SLED 10 SP1)


When attempting to register a SLE 10 SPx system, the following error is returned:

ERROR: Could not add 'https://nu.novell.com': Failed to download XML metadata: Download failed: (https://nu.novell.com/repo/repoindex.xml) Invalid certificate received form server.

The error is encountered either during registration during install under details in the error popup or when performing a suse_register from the command line during the rug refresh stage.


If the error is encountered during installation select "back", select the "Configure Later" radio button, and finish the installation.

Once the installation is complete use the following steps to resolve the issue:

1. Open a terminal window and login as root
2. Run the following command:

suse_register -d 3 -a email=<your email address> -a regcode-sles=<your sles registration code> -L /tmp/register.txt

NOTE:  remove the >< when entering the information.  If OES is also installed on the system add the following after the sles registration code:

-a regcode-oes=<your oes registration code>

2. The error will still occur when the rug refresh stage is performed by the registration.  However, this will enable the YaST2 Online Updates component.  That can be used to update several rpms doing the following:

- Open YaST2 --> Software --> Online Updates
- Either fully patch the server or at the very least install the following rpms:
- Open a terminal, login as root, and run the following:

suse_register -r -d 3

- The suse_register refresh should now run without errors and rug ca should now show the SLEx10-SP4-Updates and SLEx10-SP4-Pool catalogs.

NOTE: The updates listed in this TID will only work on SLES 10 SP4.  All previous versions of SLES 10 (ie SP1, SP2, and SP3) will need to be updated using yast2 online_updates as rug will no longer work.

Note:  The patches listed above can also be downloaded via the patch finder. 

Here are the specific SLES 10 SP4 x86_64 links:

zmd: http://download.novell.com/Download?buildid=aFdHwz9Bemc~
compat-openssl: http://download.novell.com/Download?buildid=cy6o5xYvo78~
openssl: http://download.novell.com/Download?buildid=tPPAwigg0F4~
openssl-certs: http://download.novell.com/Download?buildid=skZqrMD23yc~
libxml2: http://download.novell.com/Download?buildid=OmhhPSE8KGE~
bytefx-data-mysql: http://download.novell.com/Download?buildid=aW4dL80F5h4~

The bytefx-data-mysql fix only requires the mono-core, mono-core-32bit, mono-data, mono-web, and mono-winforms


This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7012549
  • Creation Date:04-JUN-13
  • Modified Date:20-MAR-15
    • SUSESUSE Linux Enterprise Desktop
      SUSE Linux Enterprise Server

Did this document solve your problem? Provide Feedback