hands-off enrollment fails for some users

  • 7012554
  • 05-Jun-2013
  • 06-Jun-2013

Environment

ZENworks Mobile Management 2.7.2

Situation

Allow Hands-Off Enrollment has been has been enabled through an ActiveSync Server

The error message:
"...
The remote server returned an error: (401) unauthorized
..."
shows on the device to be enrolled.

Resolution

Users need to specify their username in domain\username or user@domain format.

Cause

The user name was provided without a valid domain name.

Additional Information

See Adding Users and Enrolling Devices for more information on enrolling of devices.

On page 15 is noted:
"...
Enabling Hands-Off Enrollment for Users Associated with an ActiveSync Server

Enabling the Hands-Off Enrollment option, when defining an ActiveSync server, allows any user with
credentials on the ActiveSync server to enroll against the ZENworks Mobile Management server. Hands-off
enrollment will be set automatically for an ActiveSync server if it is set for a linked LDAP server.

You must also provide a domain that is configured on this server. Hands-off enrollment requires users to
enroll with the domain in the domain\username or user@domain format. If an LDAP server is linked to this
ActiveSync server, the LDAP server’s domain can also be used for logging in.

Users are automatically added to the ZENworks Mobile Management server, as long as their credentials are
recognized by the ActiveSync server. ZENworks Mobile Management creates the new account using the
ActiveSync user account credentials and the default servers, policy suite, and device connection schedule
specified for the organization.

..."