zac unr command can cause SQL database deadlock
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Environment
Situation
SQL database gets into deadlock status
Cause
These two operations can not update and delete the same entries in the same table at the very same time which can cause this deadlock situation on the SQL database related to this specific device on which zac unr is being executed.
Status
Reported to EngineeringAdditional Information
A way to enforce rule-based imaging is to remove ZISD information (e.g. by running %zenworks_home%\bin\preboot\ziswin.exe -w) and call zac unr on a specific device. On the next imaging boot-up, rule-based imaging will be applied. Clearing ZISD indicates that the device is not managed by a ZENworks setup. Additionally the imaging service verifies that there is not still an existing device object with same serial number or MAC address to ensure that it's not just ZISD information that is missing from the device.
Since an agent refresh is started relative to ZCM agent service startup (adding the configured delay for the Random Time to Wait value if configured), this can quite easily coincide with a script script being launched relative to device startup which call zac unr. Please note this initial agent refresh is also getting triggered if agent refresh has been configured to manual instead of timed refresh.
Disclaimer
This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.
- Document ID:7012580
- Creation Date:07-JUN-13
- Modified Date:08-JUN-13
- NovellZENworks Asset ManagementZENworks Configuration ManagementZENworks Endpoint Security ManagementZENworks Full Disk EncryptionZENworks Patch Management
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