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Unable to sync mail, contacts, or calendar

This document (7012677) is provided subject to the disclaimer at the end of this document.

Environment

Novell Data Synchronizer Mobility Pack

Situation

Either mail, contacts, and/or calendar items are not syncing to device for specific user(s)
Mobility server is not updated with GroupWise items, phones not updating, not getting any emails, but still appear as synced
New mail items do not sync to device
Most or all other users sync fine
Fails to receive mail yet can send
Sync is not up to date for user
Mail not syncing to device
Contacts not syncing to device
Calendar not syncing to device
Some mails don't reach the device

Resolution

  1. Repair user from GroupWise System. Please select one of the following options:
    • Option A: Follow the steps provided in documentation to run GWCheck for the user:
      • Object Type: User/Resource
      • Action: Analyze/Fix Databases
      • Structure, Contents, Fix problems
      • Databases tab: User, Message
      • Misc tab | Support Options: DELDUPFOLDERS
    • Option B: Structure/Contents Fix Problems on User using ConsoleOne
      • Right-click on the individual user object | GroupWise Utilities | Mailbox/Library Maintenance
      • Same configuration from Option A above, CC yourself the results
      • Select Run
    • Correct any issues that should be resolved. Repeat this check until no errors are returned.
  2. Verify proper GroupWise folder structure. Please select one of the following options:
    • Option A: Login as the user account and make sure that the folder structure is proper and all the System Folders are in the root and not buried under some other folder (Mailbox, Contacts FolderCalendar). If they are under any other folder, move it back to the Root Folder. Note: At the time of writing this TID, improper folder structure prevents sync.
    • Option B: dsapp.sh | User Issues | Check GroupWise Folder Structure.
    • Cleanup Folder Structure for proper sync.
  3. Remove the user from the Mobility server (see documentation for Managing Users)
  4. dsapp | User Issues | Remove user db references or follow TID 7008852 to completely remove all references of the user from Mobility.
  5. Add the user back to the Mobility server (see documentation for Managing Users)
    Note: Wait for the user to appear as Synced in the Mobility Connector Monitor from WebAdmin before testing on the device.

Cause

Corruption in GroupWise prevents proper sync with Mobility.

Additional Information

See Novell Cool Solutions Tool - dsapp Mobility Administration.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7012677
  • Creation Date:21-JUN-13
  • Modified Date:02-JUL-14
    • NovellData Synchronizer
      GroupWise

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