Remote management agent not reachable

  • 7012901
  • 18-Jul-2013
  • 18-Jul-2013

Environment

Novell ZENworks Configuration Management 11.2 Remote Management

Situation

The Novell ZENworks Remote Management powered by VNC service is started but the device can not get remote controlled.

The remote management port, which is 5950 by default, is open but does not work properly.

The WinVNC.log shores messages like:
"...
[ 10/05/12 09:59:53 AM ].\vncSockConnect.cpp: started socket connection thread
[ 10/05/12 09:59:53 AM ].\vncSockConnect.cpp: quitting socket connection thread

..."

Resolution

This is not something which can be fixed on the Novell side, since the available API calls to bind to Winsock fail in this case.

The only known workaround is to remove additional Windows providers below HKLM\SYSTEM\CurrentControlSet\services\Winsock2

Cause

Additional 3rd party Winsock providers are registered.

Additional Information

3rd party Winsock providers can be removed, e.g. with the Autoruns for Windows tool as available at http://technet.microsoft.com/en-us/sysinternals/bb963902.