Unable to start Novell Messenger Agent (LDAP down)

  • 7012968
  • 31-Jul-2013
  • 31-Jul-2013

Environment

Novell Messenger

Situation

Logging into Novell Messenger shows "The client is unable to connect to the server. Verify that the remote address and port are defined correctly."
Unable to start Novell Messenger with rcnovell-nmma start
NMMA is unavailable, not running, inactive
Starting Novell Messenger Services manually provides the following error message:
NMMA: Agent configuration failure [0xAD2D]
NMMA:
NMMA: Cause: LDAP server is not available

NMMA: Cleaning up...

NMMA: Unloading...

LDAP is not listening on the defined ports (default: 389 or 636)

Resolution

Although there are several reasons an LDAP server could be unavailable, the steps below address a situation in which the LDAP objects have become corrupt.

  1. Remove the LDAP objects from the TREE
  2. To recreate the LDAP objects for this server, enter the following in a terminal window on the LDAP server:
    ndsconfig upgrade
  3. Go to the Properties of the LDAP group object that has been created in the TREE
  4. Select the General tab | uncheck Require TLS for simple binds with password
  5. Select Apply and then Close.

Cause

Corrupt LDAP objects preventing LDAP from listening on the defined ports.