miCASA client fails to connect to CASA service

  • 7013063
  • 16-Aug-2013
  • 17-Aug-2013

Environment

Novell ZENworks Configuration Management 11.2 Authentication

Situation

Users are not able to login to ZCM

zmd-messages.log shows error:
"...
[DEBUG] [08/08/2013 15:51:14.907] [1500] [ZenworksWindowsService] [9] [] [CommonCasa] [] [ObtainAuthToken returning -939589602] [] []
[DEBUG] [08/08/2013 15:51:14.907] [1500] [ZenworksWindowsService] [9] [] [RemotingService] [] [Return Unavailable Auth Server Status] [] []

..."

casaauthtoken.log shows error:
"...
[5DC-4DC] [15:51:14:876] CASA_AuthToken -InternalRpc- Unable to connect to server
[5DC-4DC] [15:51:14:892] CASA_AuthToken -InternalRpc- End, retStatus = C7FF001E

..."

Resolution

Remove or fix WinHTTP proxy configuration on the managed devices.

To see the current configuration run: netsh winhttp view proxy
To remove the current configuration run: netsh winhttp reset proxy

For more information on using netsh winhttp commands see e.g. Netsh Commands for Windows Hypertext Transfer Protocol (WINHTTP)

Cause

The miCASA client uses Windows WinHTTP and WinHTTP has been configured with a proxy configuration which does not allow for connection to a ZENworks authentication server.

Additional Information

A very similar issue has been documented for ZCM 10 with TID 7000977.