Error 2147219705 when installing the NRC SSRS DATA extensions

  • 7013087
  • 22-Aug-2013
  • 22-Aug-2013

Environment

NetIQ Directory & Resource Administrator 8.5
NetIQ Directory & Resource Administrator 8.5 Service Pack 1
NetIQ Directory & Resource Administrator 8.6 
NetIQ Directory & Resource Administrator 8.6 Service Pack 1
NetIQ Directory & Resource Administrator 8.6 Service Pack 2

Situation

When trying to install the NRC SSRS Data Extensions on the SQL server you receive a 2147219705 error and after you click ok a 0x80040706 error will appear.

Resolution

To resolve this issue:
  1. Lanuch regedit and naveagate to  HKEY_Local_Machine/SOFTWARE\NetIQ\Generic\Tracing  
  2. Verify that the data for the NRCTempTraceLogPath and NRCTraceLogPath values list valid paths. (Typicality the path for  NRCTempTraceLogPath is what is causing the issue.) 
  3. Modify the the the value of the path that is invalid to point to a valid path.
  4. Rerun the NRC installer and the error will not occur.

Cause

The cause of this issue that the  directory that NRC is trying to put the installation log does not exist.