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Errors installing iPrint printer: Winsock 10060, iPrint 1801

This document (7013088) is provided subject to the disclaimer at the end of this document.

Environment

OES 11
iPrint

Situation

When attempting to install a printer from the <ipaddress>/ipp web page, Winsock error 10060 (Connection has timed out) is displayed:



Then, iPrint error 1801 (The printer name is invalid) is displayed:



Resolution

Identify and correct the name resolution or communications problem which is preventing the iPrint client from communicating with the Print Server Manager.

1.  /etc/opt/novell/iprint/conf/ipsmd.conf and look for the PSMHostAddress value.

2. Open a CMD prompt and ping the name or address for the PSM you found in step 1.
ping <name or address>
If unable to ping, the name or address is not reachable.

3. In the CMD prompt, telnet over port 631 to the name or address for the PSM you found in step 1.
telnet <name or address> 631
If unable to telnet, the server is not listening on port 631, which is the port where iPrint is listening.

Once you are able to ping and telnet to the PSM, the problem should be resolved.

Cause

There are several possible causes. A few of the most common causes are:

1. DHCP is handing out the wrong DNS server address.
2. DNS is not properly configured, or is not working.
3. The workstation has the wrong DNS server configured (check ipconfig /a).
4. An intermediate device such as a switch or router could be mis-configured (wrong helper address, etc).
5. Server could not be listening on port 631.
6. General communications problems.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7013088
  • Creation Date:22-AUG-13
  • Modified Date:22-AUG-13
    • NovelliPrint

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