How to configure Workstation iManager on a Windows desktop for certificate administration

  • 7013239
  • 10-Sep-2013
  • 10-Sep-2013

Environment

NetIQ eDirectory
NetIQ iManager

Situation

Unable to user iManager to renew or repair eDirectory / LDAP certificates and/or the Root CA.
How to configure Workstation iManager on a Windows desktop for certificate administration.
 

Resolution

  1. Download the latest version of iManager to the Windows Workstation:
    • From a browser, navigate to https://download.novell.com
    • Select iManager and the latest version
    • Click Search
    • Select the link from the Download column
    • Download iMan_versionNumber_workstation_win.zip
  2. Extract the zip to the C:\ and browse to C:\imanager\bin
  3. Run the iManager Windows Batch File
    • (conditional) If NICI is not already installed, select Yes to do so.
  4. Login to iManager, providing the admin's credentials and server information.
  5. Install the Novell Certificate Server Plug-ins for iManager:
    • Select Configure (person behind a desk icon) | Plug-in Installation | Available Novell Plug-in Modules
    • From the list, select eDirectoryXX Plugins, Novell Certificate Server Plug-ins for iManager
    • Click Install from the top
    • Select Agree and OK
  6. Close out of iManager. Reload iManager from the same Windows Batch File: C:\imanager\bin\iManager
  7. Login to iManager. The left panel Roles & Tasks should now display the module's roles:
    • Novell Certificate Access
    • Novell Certificate Server
 

Cause

Need to use Workstation version of iManager to validate, renew, repair, re-create eDirectory certificates. 
eDirectoryXX Plugin are needed to validate certificates, Novell Certificate Server Plug-ins for iManager are needed for certificate Roles & Tasks.