Novell Home

My Favorites

Close

Please to see your favorites.

Device cannot communicate to the Zone until cache is cleared and the device is refreshed

This document (7013316) is provided subject to the disclaimer at the end of this document.

Environment

Novell ZENworks Configuration Management 11.2

Situation

Device stops talking to the zone: Server DNS, Address and Zone name are all reported as Unknown in the ZENworks icon

If cache is cleared ("zac cc") and the device refreshed ("zac ref"), the device can communicate again

Debug-level zmd-messages.log shows exceptions similar to:

[DEBUG] [08/06/2013 10:57:08.668] [1208] [ZenworksWindowsService] [6] [] [ZenCache] [] [Unknown exception accessing C:\Program Files (x86)\Novell\ZENworks\cache\zmd\ZenCache\93ab3ac6-4092-48bf-b03b-eed3ce64f05f] [] []
 [DEBUG] [08/06/2013 10:57:08.668] [1208] [ZenworksWindowsService] [6] []
[ZenCache] [] [Message: Binary stream '0' does not contain a valid BinaryHeader. Possible causes are invalid stream or object version change between serialization and deserialization.] [] []



Cause

This is a cache corruption case that was not found when fixing earlier issues in
TID 7011416 Missing files in ZCM agent cache
TID 7011381 Devices become unmanaged due to corrupt cache

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7013316
  • Creation Date:18-SEP-13
  • Modified Date:18-SEP-13
    • NovellZENworks Configuration Management

Did this document solve your problem? Provide Feedback