Environment
iPrint Appliance
Situation
After importing an eDirectory certificate from a remote OES11SP1 server, using TID 3176104, into the JVM Certificates keystore on the iPrint appliance with no errors, selecting the certificate and using the "View info" button, an error is displayed:
"Array index out of range: 0"
"Array index out of range: 0"
Resolution
This is a cosmetic error, and does not affect functionality.
Cause
Unknown at the moment.
Additional Information
Import of the certificates was successful regardless of the error when trying to view certificate information. To validate that the certificates were properly imported, issue this command on the appliance bash shell:
keytool -list -keystore /usr/lib64/jvm/java-1.7.0-ibm-1.7.0/jre/lib/security/cacerts -alias <alias_name> -storepass changeit
For example:
keytool -list -keystore /usr/lib64/jvm/java-1.7.0-ibm-1.7.0/jre/lib/security/cacerts -alias oes11sp1 -storepass changeit
This will return the information as:
Alias name, Sep 16, 2013, trustedCertEntry, Certificate fingerprint, [sha1]: C1:81:7F:AA:3E:44:ER:FH:T2
Which means that the certificates are properly stored on the JVM keystore
Using this certificate to LDAP sync between appliance and remote OES11SP1 server worked with no issues, regardless the array error.
keytool -list -keystore /usr/lib64/jvm/java-1.7.0-ibm-1.7.0/jre/lib/security/cacerts -alias <alias_name> -storepass changeit
For example:
keytool -list -keystore /usr/lib64/jvm/java-1.7.0-ibm-1.7.0/jre/lib/security/cacerts -alias oes11sp1 -storepass changeit
This will return the information as:
Alias name, Sep 16, 2013, trustedCertEntry, Certificate fingerprint, [sha1]: C1:81:7F:AA:3E:44:ER:FH:T2
Which means that the certificates are properly stored on the JVM keystore
Using this certificate to LDAP sync between appliance and remote OES11SP1 server worked with no issues, regardless the array error.