uvservd hangs when running Oracle checks

  • 7013453
  • 14-Oct-2013
  • 30-Oct-2013

Environment

Using the 7.x NetIQ for Unix agent with Secure Configuration Manager 5.8 or 5.9+

Situation

Any Oracle check submitted hangs uvservd until the process is manually killed.
Note that Unix OS checks run OK.

Resolution

a) In the SCM job queues cancel the running job(s)
b) On the Unix system login then su to root:
       1) kill -9 all running uvservd processes
       2) Stop uvserv
                 - AIX:         /etc/rc.uvserv stop
                 - SunOS:     /etc/init.d/uvserv stop
                 - Linux:       /etc/rc.d/init.d/uvserv stop
                 - HP-UX:     /sbin/init.d/uvserv stop
       3) Stop the VigilEntAgent process
                 - PSHOME/netiq/vsau/bin/stopca
                         PSHOME is the agent base installation directory.  To find its value key:   grep  PSHOME=  /etc/vsaunix.cfg
                         Also note that VigilEntAgent can be stopped with kill -9, but ensure the file removals just below are completed.
                 - If exists remove the file:
                             PSHOME/netiq/vsau/local/cache/va
                             PSHOME/netiq/cmnagent/tmp/VigilEntAgent.pid
                             PSHOME/netiq/cmnagent/tmp/VigilEntAgent_sockV5
       4) Start the uvserv process
                 - AIX:         /etc/rc.uvserv start
                 - SunOS:     /etc/init.d/uvserv start
                 - Linux:       /etc/rc.d/init.d/uvserv start
                 - HP-UX:     /sbin/init.d/uvserv start
       5) Start the VigilEntAgent process if needed
                 - PSHOME/netiq/vsau/bin/startca
                         Run  ps -ef  | grep Vig   to see if its running.  The uvserv process autostarts VigilEntAgent in most cases.
      6) Check the file permissions on  $ORACLE_HOME/bin/sqlplus  to see if any files have the sticky bits turned on.
               In some cases the permissions might be set to   -rws--x---   .  Also check other files in this directory and verify
               that they also do not with sticky bits on.     To resolve change the file permissions with chmod:
                               chmod  $ORACLE_HOME/bin/sqlplus  750
       7) Once completed then resubmit the Oracle check

Cause

The underlying issue here is the sticky bits turned on for sqlplus which the agent uses to run Oracle queries.
The sticky bit results in sqlplus being launched as another UserID which causes the SCM processes to hang.