NetIQ DRA Change Activity Report -- No Results found

  • 7014060
  • 07-Nov-2013
  • 19-Dec-2013

Environment

NetIQ Directory and Resource Administrator 8.6.x
NetIQ Directory and Resource Administrator 8.7.x

Situation

NetIQ Directory and Resource Administrator (DRA) provides the ability to run change activity audit reports, from within the Delegation and Configuration Console (D&C Console). These reports will query the Log Archive Server (LAS) on any / all specified DRA Server(s), using the criteria selected in the wizard. It is possible for the report results to come back with a "No results found" error.

Resolution

I. The criteria specified in the Change Activity Report does not contain any data
a. Expand the data range used in the criteria
b. Verify that "Restrict query to these DRA servers" is not checked
 
II. The LAS(s) on the DRA Servers used in the query do not contain data
a. Verify that the NetIQ DRA Log Archive Service is started on all DRA Servers
b. Verify that there are folders and data for the date range specified in the NetIQLogArchiveData folder (typically installed in the <path to DRA Program Files>\NetIQLogArchiveData folder) on all DRA Servers
c. Use the NetIQ Security Manager Log Archive Configuration Utility (LAS Config Utility) (Start -- All Programs -- NetIQ Security Manager) to verify that the "Read Only" check box for the Log Archive Volume is unchecked.
1. This utility is specific to each DRA Server's local LAS, therefore it must be run locally on each / every DRA Server.
2. If the "Read Only" box IS checked, Un-Check the box. After closing the LAS Config Utility, restart the LAS Service on every DRA.
3. Rerun the same Change Activity Report query again.

Cause

There are a couple of causes for the "No Results Found" error:
 
1. The criteria specified in the Change Activity Report does not contain any data.
2. The specified LAS(s) in the Change Activity Report do not contain any data.