Novell Home

My Favorites

Close

Please to see your favorites.

nothing provides perl-ldap needed by pattern:Novell_GroupWise_Mobility_Service

This document (7015000) is provided subject to the disclaimer at the end of this document.

Environment

Novell GroupWise Mobility Service
Novell Data Synchronizer Mobility Pack

Situation

Dependency errors during Mobility Service Installation.
perl-ldap package dependency or dependencies error.
The following error is displayed during the install:
nothing provides perl-ldap needed by pattern:Novell_GroupWise_Mobility_Service-2.0.0.x86_64

Conflict Resolution:
do not install pattern:Novell_GroupWise_Mobility_Service-2.0.0.x86_64
break Novell_GroupWise_Mobility_Service-2.0.0.x86_64 by ignoring some of its dependencies

Resolution

The perl-ldap package should be available from the SLES11 DVD.

It is possible the server is unable to see the SLES 11 DVD. Verify the SLES 11 Repository information is proper:
YaST2 | Software | Software Repositories, verify the SLES 11 repository is Enabled and accessible.
See TID 7014489 - How to add SLES repository on SLES server for more details.

This package can also be installed manually, select one of the following options:
  • Option 1: Using zypper, from a terminal window:
    zypper in perl-ldap

  • Option 2: Using yast, from a terminal window:
    yast -i perl-ldap

  • Option 3: YaST2 | Software | Software Management by searching for perl-ldap

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7015000
  • Creation Date:02-MAY-14
  • Modified Date:02-MAY-14
    • NovellData Synchronizer
      GroupWise

Did this document solve your problem? Provide Feedback