Environment
NetIQ Operations Center
NetIQ AppManager Operations Portal
NetIQ AppManager Operations Portal
Situation
NOC Dashboard 5.0 supports three communication modes: unsecured communication, secured communication using SSL, or concurrent usage of both. This can be set and changed from Dashboard's configuration tool (Customizer). This tool updates in the background (among others) Apache Tomcat server configuration file ..\NovellOperationsCenter\Dashboard\server\conf\server.xml, and writes down the requested communication mode information.
The configuration entry created in this file for unsecured communication is correct, and unsecured mode works correctly. Unfortunately, the configuration entry for secured communication is not correct, protocol value "HTTP/1.1", which is used by the tool, causes an internal issue, as logged in catalina log file:
This in turn results in indefinite waiting loop in blank HTML viewer, as soon as user attempts to open secured communication against the dashboard server.
The configuration entry created in this file for unsecured communication is correct, and unsecured mode works correctly. Unfortunately, the configuration entry for secured communication is not correct, protocol value "HTTP/1.1", which is used by the tool, causes an internal issue, as logged in catalina log file:
SEVERE: Error initializing endpoint java.lang.Exception: No Certificate file specified or invalid file format |
This in turn results in indefinite waiting loop in blank HTML viewer, as soon as user attempts to open secured communication against the dashboard server.
Resolution
At the moment the only solution is to manually update the file \NovellOperationsCenter\Dashboard\server\conf\server.xml, and correct the tag for secured communication. Below is the connector tag for secure communication, with incorrect parameter value in RED:
The incorrect value above should be replaced with one of these:
- "org.apache.coyote.http11.Http11Protocol"
- "org.apache.coyote.http11.Http11NioProtocol"
and the dashboard server should be restarted.
<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true" maxThreads="150" scheme="https" secure="true" clientAuth="false" sslProtocol="TLS" enableLookups="false" disableUploadTimeout="true" maxPostSize="0" keystoreFile="conf/keystore" keystorePass="formula" URIEncoding="UTF-8" /> |
The incorrect value above should be replaced with one of these:
- "org.apache.coyote.http11.Http11Protocol"
- "org.apache.coyote.http11.Http11NioProtocol"
and the dashboard server should be restarted.
Cause
The "wrong" protocol value being used by Dashboard configuration tool is supposed to work for Tomcat 7, but not for Tomcat 6, on which current Dashboard version is based.
Additional Information
This has been posted to engineering.