Vibe timed workflow transitions cease working

  • 7015439
  • 29-Jul-2014
  • 29-Jul-2014

Environment

Novell Vibe OnPrem 3

Situation

Vibe workflow transitions based on an elapsed time stop occurring. They remain in the original state, rather than making the transition to the desired new state, and not even a reboot will fix the problem. Once stuck, they remain stuck.

Resolution

A database entry has been corrupted and must be fixed manually. The specifics of this fix depend on the database you are using and also whether you are using SQL commands from the command line, or a graphical database browser. Whichever is the case, here are the steps to follow:
  1. select the "sitescape" database
  2. in the table called SSQRTZ_TRIGGERS, find the row which contains the TRIGGER_GROUP entry of "workflow-timer"
  3. confirm that the TRIGGER_STATE column for the workflow-timer row is set to "BLOCKED"
  4. modify the TRIGGER_STATE column for this row to "WAITING"

Timed workflow transitions will begin to occur. Be aware that very old transitions will all happen at once. Users should be forewarned that there may be a flood of old transitions. Since one action that a workflow transition can cause is sending an email, there may be a flood of old emails while the system catches up with all those blocked transitions that are now unblocked.

Cause

The blocked state is used by Vibe to make sure timed operations happen one at a time. Normally after an operation completes, it will unblock the others to allow them to proceed. If an operation is interrupted however (for example, due to a power outage during the operation) the blocked state will remain forever blocked since the interrupted task doesn't finish and doesn't perform the unblock operation. This is why it must be cleared manually.