On some devices NalShell is not loading, hence the extension is not loaded for Computer > ZENworks Adaptive Agent

  • 7016018
  • 23-Dec-2014
  • 04-Oct-2016

Environment

Novell ZENworks Configuration Management 11.3.1

Situation

On some devices NalShell is not loading, hence the extension is not loaded for the Explorer view.
Bundles are seen from ZENworks Application Window.
Bundles are not seen from Computer > ZENworks Adaptive Agent.,

Resolution

Only have one instance of Explorer.exe running to avoid this symptom.  This is working as intended and designed.

Cause

The device has two instances of Explorer.exe process running.

Additional Information

NalShell uses the Explorer process that displays in the task bar Explorer.exe so does not use the other instance of Explorer.exe process(es) and hence the NalShell extension is not loaded for other instances of Explorer.exe, resulting in the missing bundles at Computer > ZENworks Adaptive Agent.
 
Check if one of the following option is set on the device?

1.  Shortcuts for the user to start Explorer.exe with options where certain folder is automatically selected or opened in Explorer, such as:  explorer.exe /select, C:\Program Files (x86)

2.  Folder options set to launch folder windows in a separate process:

 Open My Computer > Organize > Folder and search Options > View > 'Launch folder windows in a separate process'
 
Since 11.3.1 (previously code had not been working as intended and designed) NalShell only uses the Explorer.exe process that displays in the Task Bar Explorer, so using the above two options will create this symptom.  If either or both of the above two options need to be used, bundles will not be available via Computer > ZENworks Adaptive Agent.
 
Note:  HKLM\Software\Novell\ZCM\NAL, AllowNonTaskbarExplorer=1(DWORD) will allow for NALSHELL to use multiple Explorer.exe processes, but this may cause memory related stability issues with Explorer.exe and NALSHELL and thus should be used with caution.