Unable to start GMS engine properly after installing GMS 2.1

  • 7016372
  • 31-Mar-2015
  • 08-Jan-2016

Environment

Novell GroupWise Mobility Service

Situation

After rebooting the mobility server after installing a new GMS install has been completed, the webadmin shows "AttributeError - Could not connect to the ConfigEngine"
When trying to restart GMS the following error is seen: WARNING: Some datasync service(s) had a problem shutting down. Please see the README for details

Resolution

To fix the server without rebooting, follow the steps below:
  1. Check for the python process by launching a terminal session
  2. At the terminal prompt, type ps -aux | grep python
  3. If python process are returned, type killall -9 python
  4. Start GMS by typing rcgms start
  5. If all comes up properly, verify that everything is now working
If the steps above correct the issues, proceed with the following instructions
  1. Type chkconfig gms off
  2. Type chkconfig | grep datasync to verify results containing datasync say on 
  3. Reboot the server and services should come up properly


Cause

duplicate processes try to start up on the server with a new install of 2.1