GroupWise Webaccess users have very slow performance or 500/503 Errors when server is under heavy load

  • 7017423
  • 29-Mar-2016
  • 28-Jun-2017

Environment

Novell GroupWise 2012 Support Pack 2
Novell GroupWise 2014
Novell GroupWise 2014 R2
SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)

Situation

After updating from an older version of GroupWise to GroupWise 2014 R2 the performance in the Webaccess client is very slow.  Slow activities are logging in, reading mail, sending mail.  The performance in the GroupWise Windows client is fine.  This customer does not have OES11 on this SLES11 server. SLES12 can also be considered.

The customer can also experience 500 (Server Error) or 503 (Service Unavailable) when attempting to access the GroupWise Webaccess client after the server has been working for long periods of time and under a heavy user load.

Resolution

Please follow the following instructions to help with scalability and performance relating to the number of GroupWise Webaccess users logged in. 

APACHE:  ( This applies to both SLES11 with or without OES11; it also applies to SLES12 )
  1. Open the /etc/apache2/server-tuning.conf
  2. Under 'prefork' section ( begins with <IfModule prefork.c> )
    1. Change the ServerLimit to 500
    2. MaxClients to 500
  3. Under 'worker' section ( begins with <IfModule worker.c> )
    1. MaxSpareThreads to 150
    2. MaxClients to 500
  4. Save the file and restart Apache (rcapache restart)

TOMCAT:  ( This applies to SLES11 without OES11 )
  1. Open the /etc/tomcat6/server.xml file
  2. Add maxThreads="500" to the "Connector" XML element (that has port="8080" attribute, begins with <Connector port="8080" protocol="HTTP/1.1" .... ) as follows:
    <Connector port=”8080”
                          maxThreads=”500”
                          protocol=”HTTP/1.1”
                          connectionTimeout=”20000”
                          redirectortPort=”8443” />
  3. Save the file and restart Tomcat (rctomcat6 restart)


TOMCAT:  ( This applies to SLES12 )
  1. Open the /etc/tomcat/server.xml file
  2. Add maxThreads="500" to the "Connector" XML element (that has port="8080" attribute, begins with <Connector port="8080" protocol="HTTP/1.1" .... ) as follows:
    <Connector port=”8080”
                          maxThreads=”500”
                          protocol=”HTTP/1.1”
                          connectionTimeout=”20000”
                          redirectortPort=”8443” />
  3. Save the file and restart Tomcat (rctomcat restart)

TOMCAT:  ( This applies to SLES11 with OES11 )
  1. Open the /var/opt/novell/tomcat6/conf/server.xml file
      2.  By default the OES11 version of Tomcat6 has only 1 configured "Connector port=" which is to port 9009.  All other listed Connector ports are remarked out with these characters before the 
configuration "<!--" and these characters after the configuration "-->".  You will also ADD the maxThreads="500" attribute if not already present, or modify it if it is present already.

So search for this :

<!--
<Connector port="8180"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="17887" acceptCount="100"
               debug="0" connectionTimeout="20000" 
               disableUploadTimeout="true" /> 
        -->

and replace it with :


<Connector port="8180"
               maxThreads="500" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="17887" acceptCount="100"
               debug="0" connectionTimeout="20000" 
               disableUploadTimeout="true"/> 

3.  Now restart tomcat with the command rcnovell-tomcat6 restart

Cause

The root cause of this issue was related to the configuration of Apache2 and Tomcat6, once the configuration was optimized to allow more connections, the problem went away in GroupWise Webaccess.