"Failed to connect" during framework agent registration

  • 7017635
  • 23-May-2016
  • 23-May-2016

Environment

NetIQ Privileged Account Manager
NetIQ Privileged User Manager

Situation

Unable to register the framework agent to the framework manager.
Administrator can't register the framework agent because it fails to connect.
While registering a Framework Agent (/opt/netiq/npum/sbin/unifi regclnt register), the following errors could be reported in the Agent's unifid log (logs/unifid.log):
  • Error, Failed to connect to <IP/DNS of Framework Agent>:29120
    Error, Failed to connect to registry <IP/DNS of Framework Agent>:29120
  • Error, Failed to connect to <IP/DNS of Framework Agent>:34463
    Error, Failed to connect to registry <IP/DNS of Framework Agent>:34463


Resolution

Please verify the IP or DNS Address and port defined in the registration process is correct. These errors can occur when the wrong Framework Manager's IP/DNS and/or port is entered.

Additionally, it is possible for a network communication or configuration issue to be present (i.e. time is not synchronized, failed DNS lookups, firewall blocking the port, etc.). To rule these possibilities out, please see the resolution steps found in TID 7016996.

Cause

Invalid or incorrect framework manager DNS/IP or incorrect port.