Environment
PlateSpin Protect 11.x
PlateSpin Migrate 12.x
PlateSpin Migrate 12.x
Situation
Discovery of source workload failed. Inventory result returned nothing
Resolution
Use the following workaround to discover source workload
1. Set the value of "EarliestWindowsVersionForCommonInventory" to 6.4 in Platespin Configuration settings
2. Remove the failed source workload from Protect Server.
3. Run the MachineDiscovery.exe that has been copied to ADMIN$ location of the source workload. If this is not found, copy the same from the Protect Server (C:\Program Files(x86)\Platespin Protect Server\bin\MachineDiscovery.exe) to \\sourcemachine\ADMIN$ and run the MachineDiscovery.exe
4. This will generate MachineDiscovery.xml file on ADMIN$.
5. Rename this xml to ManualMachineDiscovery.xml.
6. Now add the workload from Protect Server. The source machine will get added successfully.
1. Set the value of "EarliestWindowsVersionForCommonInventory" to 6.4 in Platespin Configuration settings
2. Remove the failed source workload from Protect Server.
3. Run the MachineDiscovery.exe that has been copied to ADMIN$ location of the source workload. If this is not found, copy the same from the Protect Server (C:\Program Files(x86)\Platespin Protect Server\bin\MachineDiscovery.exe) to \\sourcemachine\ADMIN$ and run the MachineDiscovery.exe
4. This will generate MachineDiscovery.xml file on ADMIN$.
5. Rename this xml to ManualMachineDiscovery.xml.
6. Now add the workload from Protect Server. The source machine will get added successfully.
Cause
This discovery issue is most likely caused by a permission issue with the source workload.
Additional Information
Note: Keep the value of "EarliestWindowsVersionForCommonInventory" to 6.4 when running replication etc for this workload.
Revert this to 5.2 for other workloads.