Unable to register iSeries agents

  • 7017893
  • 28-Jul-2016
  • 29-Jul-2016

Environment

NetIQ Secure Configuration Manager 6.1

Situation

iSeries agents will not  register with Secure Configuration Manager. Secure Configuration Manager displays the following error when attempting to register an iSeries agent:

Failed to register agent: An I/O error occurred communicating with vssl://<IP address> 

An I/O error is received when running a report.

Resolution

Perform the following steps to enable Secure Configuration Manager to use SSL 3.0 for communication with agents:

1.       Go to the Advanced tab in the Core Configuration Utility.

To access the Advanced tab in the Core Services Configuration Utility:

1.       Close the Core Services Configuration Utility if it is open.

2.       Go to the \NetIQ\Secure Configuration Manager\Core Services\bin folder and run the Config.bat (in 32-bit computers) or the Configx64.bat (in 64-bit computers) file.

This opens the Core Services Configuration Utility with the Advanced tab.

2.       Update the value of the network/protocols field to TLSv1,TLSv1.1,TLSv1.2,SSLv3.

NOTE: This field is case-sensitive.

3.       Restart NetIQ Core Services.

Cause

This issue occurs because Secure Configuration Manager does not support SSL 3.0 by default, whereas iSeries uses SSL 3.0 for communication.